markpaterson
Posts: 2
Joined: Mon Feb 18, 2019 9:53 pm

Outputting PAL from HDMI to VGA adapter to PAL/VGA CRT monitor. Getting bad scaling issues. How do I get 1:1 pixels?

Mon Feb 18, 2019 10:21 pm

I have an Amiga M1438S multiscan monitor, it supports 15Khz PAL, NTSC and regular ~30Khz PC VGA modes. I'm using Ambian and aim to have a correct looking PAL signal outputted to the CRT. I'm *almost* there. My path output path is… Raspberry Pi 3 B+ > Amibian > HDMI > Belkin VGA Adapter > Amiga CRT monitor.

The emulated Amiga screen is definitely PAL on my monitor, and I have nice natural scanlines from the CRT, however there's an issue with scaling. Pixels do not perfectly line up. This is also evident in the Amiberry menu and Pi command line. I've experimented with many different settings in config.txt, but they only seem to affect the Pi side of things, not the Amiga screen. You can see from this screenshot on the Amiga how the scaling is messed up. That pattern of lines should be single pixels. https://imgur.com/a/Ub639FI

In Amiberry display options, my 'Amiga Screen' is set to 704x256. 704w is needed so that the screen isn't severely overscanned left to right. Overscan settings in Amiberry config seem to have no effect on the Amiga screen but only on the Amiberry menu.

I suspect whatever is scaling is affecting *everything* system wide. How do I just get true 1:1 pixels?

---
MY CONFIG.TXT
I started out with the default config for CRT as a starting point. Below are some settings I've modified.

FRAMEBUFFER
Unsure what this does to the Amiga. I chose this number because it's an Amiga native size. Only seems to affect the Pi side of things though, such as the Amiberry menu and the Pi command prompt. Tried these as 640x512, 720x512, 720x576 too. Interestingly, if I comment out the frame buffer I get perfect 1:1 pixels in the pi terminal, but the font is huge and stretched vertically, and weirdly the Amiberry menu *still* looks badly scaled. I have no clue what is going on here.

Code: Select all

framebuffer_width= 704
framebuffer_height=512
SDTV MODE
I thought this was only for composite output, but seems to affect the HDMI output too eg - regular PAL mode gives me an interlaced output over all resolutions, which I do not want. Mode 18 progressive pal 720x288p output.

Code: Select all

sdtv_mode=18
OVERSCAN
I tried this setting to get 640x512 from a 720x576 image. Unsure if I'm doing this right though. This only seems to affect the Pi and not the 'Amiga' screen. Since changing these settings I've also tried disabling Overscan Compensation in rasps-config, but again it had no impact on 'Amiga', only the Pi. I've since commented all this out, and it has had no effect anyway.

Code: Select all

overscan_top=32
overscan_bottom=32
overscan_left=40
overscan_right=40
HDMI SETTINGS

Code: Select all

hdmi_cvt=704 566 50 4 0 0 0 0
hdmi_group=1
hdmi_mode=23
scaling-kernal 0

also tried scaling-kernal commented out or at the default of 8
Also tried the following with (and without) commenting out the hdmi_cvt value…

Code: Select all

hdmi_timings=320 1 14 46 28 256 1 17 32 9 0 0 0 50 0 6400000 1 # 320:256 Amiga (PAL)
---

MY AMIGA.UAE file
Found these settings that might fix it, but so far have not. The scaling, the options are: -1: Auto, 0: Nearest neighbor, 1: Linear

Code: Select all

amiberry.scaling_method=1
gfx_lores=false
gfx_resolution=hires
gfx_fullscreen_amiga=false

Also tried…

Code: Select all

amiberry.scaling_method=1
gfx_lores= true
gfx_resolution= lores
gfx_fullscreen_amiga= true
Last edited by markpaterson on Mon Feb 18, 2019 11:40 pm, edited 1 time in total.

markpaterson
Posts: 2
Joined: Mon Feb 18, 2019 9:53 pm

Re: Outputting PAL from HDMI to VGA adapter to PAL/VGA CRT monitor. Getting bad scaling issues. How do I get 1:1 pixels?

Mon Feb 18, 2019 11:40 pm

I'm curious if it's being scaled due to overscan. This image on Wikipedia about 1:1 image mapping looks like the effect im currently getting (ie all the overscan images) https://upload.wikimedia.org/wikipedia/ ... splays.png

Return to “Gaming”