DraStic DS emulator for RPi 2/3 - beta testers wanted


28 posts   Page 1 of 2   1, 2
by Exophase » Mon Jan 09, 2017 6:57 am
Hi everyone,

I have been working on a port of my Nintendo DS emulator named DraStic for Raspberry Pi 2 and 3 (RPi 1 won't be supported). It may be ready for release soon, and I was hoping to get some feedback and, if possible, a round of private beta testing from a few individuals before pushing out the first public builds.

Some basic info:

1) It's intended to be, for now, proprietary software, but gratis, unlike the Android version (but like the Open Pandora version). For those who don't know, the basic point of this emulator is that it's faster than DeSmuME, particularly on ARMv7a devices.

2) If anyone here has used the Pandora version, it's mostly based off that UI and feature-wise, for now. But unlike the most recently released Pandora version it will have configurable controls, for keyboard or gamepad. Mouse can be used for touch input but it's not configurable. Gamepad sticks, buttons or keys can be configured to move the mouse cursor in order to sort of get touchscreen functionality without a mouse or real touchscreen.

3) For the initial release, I only currently have a minimal amount of screen positioning options: either vertical or horizontal orientation, and a selection of scaling options (1x/2x/3x/4x/fullscreen) that applies to both of the emulated DS screens. I'd like to add more freely configurable screen positioning options along with a rotation option, but for a later release. That is, unless I get feedback that this isn't good enough for a first release.

4) The UI is meant to be usable with just a gamepad, but chances are good that the default configuration won't work for you and it might be difficult to do the initial reconfiguration without a keyboard. I can provide default configurations for my two controllers - a Logitech F710 and F310 (you'd think one would be a subset of the other but they aren't!), and maybe others can provide some other defaults? I don't really know what gamepads are popular

5) I'd like to have a private beta test first just to make sure it's not completely broken, missing crucial features, or unacceptably packaged for RPi distribution (I assume a simple tarball is OK?). After it passes that hurdle I can upload a build somewhere or as an attachment to this thread, then everyone can test it.

If anyone is interested in volunteering to beta test, please shoot me a PM and I'll get back to you probably within a couple days. Otherwise, if anyone has any questions (like about features or support or whatever) feel free to ask them in this thread.
Posts: 5
Joined: Thu Aug 04, 2011 10:09 pm
by stainy » Mon Jan 09, 2017 4:30 pm
i`ll be interested :) I use the Pandora version :)
I have both pi2 and pi3 if that`ll help with testing..


thanks man
Posts: 13
Joined: Thu Mar 08, 2012 1:29 pm
Location: Charlotte, NC
by dankcushions » Fri Jan 20, 2017 12:09 am
i know for the http://retropie.org.uk project this would be very popular! please post on https://retropie.org.uk/forum/category/ ... evelopment if you'd like some testers or input.

however, to fit nicely into that it would be ideal if it could launched straight into games via the command line, and in an X-less environment. retropie uses a dedicated (SDL2?) UI (emulationstation) that launches into games via command line calls. (perhaps this is already possible in your current build).
Posts: 20
Joined: Sat Jun 13, 2015 10:40 am
by Exophase » Fri Jan 20, 2017 3:28 am
It can launch via command line. It currently uses SDL1. I don't know if it can run in an X-less environment.. can any of the testers comment on that?
Posts: 5
Joined: Thu Aug 04, 2011 10:09 pm
by welshy » Fri Jan 20, 2017 9:55 am
Exophase
I can confirm works fine under CLI. I did send some updated testing a few days ago (with the Multi Thread Version). Here's an extract -

Multi Thread Binary (Performance in %)
Under XWindows
RPi 3 - 100%
RPi 2 - 96% (Default ) O/C @ 1GHz 99%
From CLI
RPi 3 - 100%
RPi 2 - 100%

Obviously, as can be seen from the results, this makes little difference for the Pi3 or O/C'd Pi2. However, for the 'Default' clocked Pi2 the unburdening of the X environment brings performance up to 100% and makes DraStic's inclusion on RetroPie a possibility.
"The list of things I have heard now contains everything!"
Posts: 1649
Joined: Mon Oct 29, 2012 2:07 pm
by startrek.steve » Fri Jan 20, 2017 11:27 am
I would be interested in Beta testing, I have Pi1's Pi2's a Pi3 and two zeroes
Pi 2 running Openelec Isengard, Pi 2 running Wheezy Desktop, Pi 1 headless Wheezy, downloading Radio, Pi 1 running Picore headless Media Server, Pi Zero to be an Old Time Radio Project. Pi 3 testing. Pi Zero W downloading Radio shows headless.
User avatar
Posts: 338
Joined: Thu Aug 30, 2012 7:19 pm
by veketor » Fri Jan 20, 2017 3:36 pm
I´m interested too in test DraStic, I have pi B+, pi Zero, pi 2 and pi 3.
Posts: 22
Joined: Fri May 18, 2012 6:59 am
by kryptalivian » Fri Jan 20, 2017 8:41 pm
I see a post about good performance, but is there anyone that can comment on the performance, including the game that is being tested?
Posts: 22
Joined: Thu Apr 09, 2015 6:14 pm
by Exophase » Sat Jan 21, 2017 1:44 am
Thanks for the new offers for beta testing, but if it's just the same with you guys I think I'm just going to shoot for a first proper release this weekend.
Posts: 5
Joined: Thu Aug 04, 2011 10:09 pm
by MiltyPi » Mon Jan 23, 2017 6:41 am
Would love to participate in the beta
Posts: 1
Joined: Mon Jan 23, 2017 6:39 am
by windale » Mon Jan 23, 2017 11:13 am
Not sure where to report bugs, but with the current test version I experienced these :-

GTA Chinatown Wars - Exited the Emulator when it said 'saving' (very beginning of game)
Legend of Zelda Phantom Hourglass - Exited the Emulator
Mystery Case Files Millionheir - Exited the Emulator when it asked to use the microphone to clean the badge (No microphone emulation ?) (yet)
Posts: 47
Joined: Fri May 15, 2015 3:41 pm
by welshy » Mon Jan 23, 2017 12:12 pm
windale
That's rather interesting, I wasn't aware the RPi Code had been released yet? Where did you get it?
Oh, I had the same issue with Zelda, it has been reported to the Author.
"The list of things I have heard now contains everything!"
Posts: 1649
Joined: Mon Oct 29, 2012 2:07 pm
by Paeryn » Mon Jan 23, 2017 2:05 pm
Yup, looks like it fails when trying to open a microphone but there isn't one.
Code: Select all
drastic: pcm_params.c:2286: snd_pcm_hw_refine: Assertion `pcm && params' failed.
ERROR: Unable to open audio capture device hw:0,1 (No such file or directory)

windale: I don't remember GTA using the mic... Just went to see if it said anything in the manual and when I opened the box for GTA I found a couple of other carts I thought I'd lost in there ;-)
She who travels light — forgot something.
User avatar
Posts: 1445
Joined: Wed Nov 23, 2011 1:10 am
Location: Sheffield, England
by Vanfanel » Mon Jan 23, 2017 4:36 pm
@Exophase: Any chances of an SDL2 version, please?
Posts: 402
Joined: Sat Aug 18, 2012 5:58 pm
by cyborgcnc » Tue Jan 24, 2017 8:00 pm
I just tried this emulator on my Retropie setup with attarct mode, and it works quite well!! Been playing Garfields nightmare, with literally NO LAG that I can detect....(This on a stock and NOT overclocked RPi-3).

couple of issues:

-For some reason, i have NOT been able to bring up a configuration menu while in the emulator, by hitting the "m" key...is there a trick to doing this? Hitting m simply blanks the screen.....not sure why this is.

-Looking for a configuration file in /opt/retropie/configs/nds/drastic/config/ there is not one, instead there is a config.cf which does not seem to be readable?

As such, I have not been able to map any of my controls, and I was wondering if there is something obvious I am missing, or if anyone has a config.cfg along with its format that I can use to map controls?

Really appreciate all the hard work that went into this.....this is huge for us retropie users!
Posts: 1
Joined: Mon Jan 23, 2017 7:28 pm
by schnitt1auch » Thu Jan 26, 2017 3:52 pm
Testet the Drastic beta in Retropie from the experimental packages section on my RPi3.
The stylus emulation works very good with my PS3 controller, Playstation Button gives access to the emulator's menu, so far "Fullscreen" and "4x" seem to do the same, there's still a little black bar at the top and bottom.

Performance seems to be near perfect, minor graphical glitches here and there (In the intro of pokemon soulsilver the tiles of the roofs for example). After you exit the game from the drastic menu it returns back to emulationstation just fine.

@Exophase Just wanted to let you know, i really appreciate your work. First time installing gpSP until now feels like quite some time.
Posts: 1
Joined: Thu Jan 26, 2017 1:37 pm
by MediaMogul » Thu Jan 26, 2017 11:35 pm
Hello Exophase. I'm a big fan of DraStic and a paid user of the Android version. One pretty big issue on the RPi version that I don't see mentioned here yet is that DraStic fails to restore the framebuffer after it exits. On RetroPie, this means that you really have to restart the whole system after a DraStic gaming session to be able to run the other emulators RetroPie has to offer. There are others discussing the problem at the link below for reference.

https://retropie.org.uk/forum/topic/7435/drastic-nintendo-ds-emulator-out-now-for-pi2-3/35

Thanks for all your hard work and for bringing DraStic to the Raspberry Pi. It is much appreciated.
Posts: 1
Joined: Thu Jan 26, 2017 11:18 pm
by bradonchase » Fri Jan 27, 2017 5:15 am
I would love to be in a beta test for the DraStic DS emulator! I've recently discovered the RPie3 and this whole new world and I'm loving it so far. If you need certain games tested, just let me know.
Posts: 1
Joined: Fri Jan 27, 2017 5:13 am
by joyrider3774 » Mon Jan 30, 2017 4:26 pm
Hi Exophase,

I remember you from the good old gp2x / wiz / canoo days (i never had / programmed for the pandora) ;)

Anyway i tested drastic and there currently are 3 issues i know of, one is servere and 1 request i have that might be benificial to others as well (dealing with stylus movement)

1) on my picade which has a 800x600 resolution and is a 4:3 monitor, if you go to the menu settings using the button the screen turns black and you don't see anything, Drastic did not crash though because if i press the exit gui button the game i was running works further without a problem it's just the in emulator menu that doesn't seem to display. I'm not the only guy that noticed this in the retropie forum there are other people with 4:3 monitor (don't know their resolultion or if ithat matters at all) and they get the same black screen. So i took a cfg from someone else and assigning the inputs manually

2) (This is serious). When you exit the emulator, the framebuffer doesn't seem to get restored to the state it originally was in before starting the emulator, giving problems in the menu's and when launching other emulators afterwards. I think this issue happend with previous emulators as well

3) i can't seem to "touch" the screen. i have assigned the keys manually in drastic.cfg and set the up / down etc to keyboard up / down etc codes as touch screen press / touch i used the return key (key code 13 in config) but doesn't seem to do anything when pressing it, not sure what i'm doing also tried other keys but can't seem to get it to work. Does it work for someone else (with keyboard shortcuts ) ?

4) (the request): Would it be possible to add an extra button which if assigned needs to be pressed in order to be able to move the the cursor (stylus icon). The thing is, i have a picade only 6 buttons and 1 joystick + 2 buttons (select + start) on front + 2 buttons on the right side. what i tried to do is move the stylus with the same joystick as the joystick that moves my character but now moving the stylus also moves the characters as it's mapped to the same keys. If you had another control button to act as a trigger / condition before moving the stylus that problem is solved. Then i could do : move player using joystick while the stylus is not moved, if i need to move the stylus i press and hold another button and then the stylus starts moving and not my character.
basically it acts as a modifier key to switch between stylus movement and character / player movement.
Posts: 19
Joined: Sun Mar 13, 2016 12:21 pm
by alexkidd_ropi » Mon Jan 30, 2017 8:28 pm
Hey Exophase,
Alerino here from OpenPandora community. It's been a long time, I'm glad you're still successful with DraStic. Please put me in the list. i would be glad to test it in other Fruits Pi if possible. (Orange Pi and Banana Pi).
thanks a lot, congrats on your accomplishments
Posts: 1
Joined: Mon Jan 30, 2017 8:21 pm
by bite_your_idols » Thu Feb 02, 2017 11:43 am
I grabbed DraStic binary and dependecies from RetroPie and testing in my LibreELEC based Pi2. It runs smoothly, good sound and Dualshock is working ok (PS button for menu, and analog stick as mouse are awesome).
But my problem is that after exiting emulator, if I try to launch it again it display only a black screen. I read in RetroPie forums it can be related with framebuffer or similiar... is there any command to close/kill/restart any process in order to be able to start DraStic again?

also, I launch emulator with cli, both into emu GUI or passing a rom path... are there any other parameters that can be used in cli?

thanks for this awesome emu!!!
User avatar
Posts: 95
Joined: Thu Dec 05, 2013 10:49 pm
by PompPenguin » Thu Feb 02, 2017 3:41 pm
Glad to see DraStic make it to the RPI 2/3! I remember contacting you a few years back about this when there was only the RPI 1. I would be very interested in doing some beta testing for you. I have both the RPI 2 and RPI 3. Thanks for the great work Exophase!
User avatar
Posts: 16
Joined: Fri Aug 31, 2012 5:34 pm
by malrobot » Thu Mar 02, 2017 1:24 am
Couple items of feedback:
  • Even if I turn off displaying framerate, during emulation I still see a constant counter of "0" in the top left hand side of my screen.
  • Upon exiting a game, DraStic seems to leave Emulation Station in a weird state where upon booting another emulator, I see a mouse cursor and a black screen rather than the standard retroarch blue configuration screen. This prevents me from selecting a different emulator until I reboot my Raspberry Pi.
  • More configuration options for screen positioning would be greatly appreciated, especially around making one screen dominant and allowing the secondary screen (status for a lot of games) to be small.
Thanks for your amazing work!
Posts: 1
Joined: Thu Mar 02, 2017 1:18 am
by PompPenguin » Thu Mar 02, 2017 7:03 pm
First off I have to say that this is a fantastic emulator!
I am running RetroPie v4.1 on a RPI3 with the prebuilt binary version of Drastic. Almost all of the games that I have tried run at 100% speed:
    -Tony Hawk's American Sk8land
    -Mario kart DS
    -Pokemon Black
    -New Super Mario Bros. (minor graphical issues with clouds in later levels)
    -Castlevania: Portait of Ruin
I did have an issue with some games booting:
    -GTA: China Town Wars (crashes after saving screen)
    -The Legend of Zelda: Spirit Tracks(dpad patch) ( Crashes on Startup)

I have experienced similar issues as malrobot.
    -The FPS counter is still displayed in the top left when disabled.
    -When I close DraStic it leaves a mouse cursor in the top left of a black screen. This shows up when I start another emulator, start a setup script, or try to Poweroff the Pi via the menu.

Keep up the great work!
User avatar
Posts: 16
Joined: Fri Aug 31, 2012 5:34 pm
by kaichou » Fri Mar 03, 2017 5:28 pm
Hey, I'm so happy about this emulator being released to RetroPie. I've been playing for several hours worth, and I've noticed that LoadState doesn't appear to work. I mapped them both to buttons on my controller, and it appears that SaveState works, because the game pauses for brief moment and then continues. LoadState I believe I was only able to get it to work once, but not since then. I've tried getting this to work in Fire Emblem: Shadow Dragon, Pokemon: SoulSilver.

Hope this helps!
Posts: 1
Joined: Fri Mar 03, 2017 5:19 pm