Page 1 of 1

Daphne - RetroPi (Pi3) - NO emulator showing

Posted: Mon Jan 09, 2017 4:57 am
by OmegaPrima1
Hello Gang,
I am officially Stumped. I have checked, rechecked and triple checked my settings and i can not for the life of me get Daphne up and Runnin.
I have the most recent daphne version installed. I'm trying to get Dragon's Lair up and running.

I have it working on the pc with no issues. Downloaded Daphne, put i my DVD, went through the verification and all that. I installed Daphne through retropie (from Source)and seemed to installed with no problems. It's a retropie 3 with the most recent updates. I took the lair.zip rom and added it to ~~\retropie\roms\daphne\roms and the took the .m2v, the txt and the ogg files , and added to lair.daphne folder (and added that folder to the daphne folder)
the txt files's first line is blank and second line reads 151 lair.m2v

i've tried a bunch of stuff (added the rom called dle21.zip over to the rom folder, created a new dl21.daphne folder (and all that jazz) as I have seen it reference to use that rom instead of the lair.zip rom

I reboot and ..well, no daphne emulator to select from emulationstation.

I dont think it is the rom file and the folder structre, but i have absolutely no clue!
Guess i'm wondern if there is a way to check the Daphne log file to see whats going on.

I can post any/all info if needed.

Please, Obi Wan(s) you are my only hope.

Re: Daphne - RetroPi (Pi3) - NO emulator showing

Posted: Tue Jan 10, 2017 1:59 am
by OmegaPrima1
Bump?

Re: Daphne - RetroPi (Pi3) - NO emulator showing

Posted: Tue Jan 10, 2017 9:41 pm
by Vanfanel
There is a properly ported Daphne version running on SDL2 with no absurd dependencies here:

https://github.com/btolab/hypseus

It builds and runs fine on the Pi... except it does not show video. A small code fix is needed, but I don't have the time. Maybe someone can take a look?

Re: Daphne - RetroPi (Pi3) - NO emulator showing

Posted: Wed Jan 11, 2017 3:24 am
by OmegaPrima1
Hey Van,

Thank you the reply. That would be a godsend if someone would actually that workin. I'm still completely in the dark over here.

I'm fairly competent when it comes to following step by step directions but when it comes to coding, definitely not my specialty.

Below are My most recent thoughts on this Travesty are below:

-may not be running the correct commands in es_systems.cfg. ( How do i know, can i check a log file or something?)

- a lair.sh file in the /home/pi/RetroPie/roms/Daphne folder (is not there in my setup, does this get created after a successful launch on the game. If not , is this supposed to be created once the daphne emulator installs? ( i do not have this file in the above mentioned folder

-I may need to copy /etc/emulationstation/es_systems.cfg to ~/.emulationstation/es_systems.cfg (as it only updates /etc/emulationstation/es_systems.cfg so it was never showing up in the menu) . What is the ~ directory !! i would do this but i don't undetand what is meant by ~/.emulationstation/es_systems.cfg

Any thoughts you have on what i can check or do would be welcomed with open arms.

Re: Daphne - RetroPi (Pi3) - NO emulator showing

Posted: Sat Jan 14, 2017 3:36 am
by OmegaPrima1
Still no Luck

I think it has to do with some sort of ini or cfg file.

I have since added C64 and Coleco emus with the correct roms extensions for the roms and they don't show up either.

i'm on 4.1 , as a note.

Gotta be Someone,,somewhere that has any clues .at all?

Gimme something to work with :!:

Re: Daphne - RetroPi (Pi3) - NO emulator showing

Posted: Thu Jan 19, 2017 12:46 pm
by Vanfanel
You can try to fix what's preventing Hypseus to work, if you want to invest time on this:

https://github.com/btolab/hypseus/issues/1

But I don't know/care about emulationstation or whatever that is you are using, only Raspbian (an Lakka, but there's no daphne on libretro so...)

Re: Daphne - RetroPi (Pi3) - NO emulator showing

Posted: Fri Jan 20, 2017 11:05 pm
by pjft
Hi. I ran into this as well.

The ~/ folder is also known as /home/pi, and your guess is absolutely right. At least in my case, copying

/etc/emulationstation/es_systems.cfg to /home/pi/.emulationstation/es_systems.cfg solved it.

Hope it helps.