User avatar
rpiMike
Posts: 850
Joined: Fri Aug 10, 2012 12:38 pm
Location: Cumbria, UK

Re: How to setup Minecraft 1.8.9 on RaspPi2

Tue Mar 22, 2016 7:58 pm

Which Raspberry Pi are you using ? Did you get glxgears working at about 60fps? How many amps are your power supply?

User avatar
rpiMike
Posts: 850
Joined: Fri Aug 10, 2012 12:38 pm
Location: Cumbria, UK

Re: How to setup Minecraft 1.8.9 on RaspPi2

Thu Mar 24, 2016 8:48 am

alguien wrote:I cant enable opengl. if i enable it i dont see anything on the screen. Why is this? Im using a raspberry pi 2
Sounds like your power supply can't cope. How many amps are your power supply, should really be 2 amps for Raspberry Pi 2.

Anocs
Posts: 6
Joined: Wed Mar 09, 2016 11:49 am

Re: How to setup Minecraft 1.8.9 on RaspPi2

Thu Mar 24, 2016 9:06 am

rpiMike wrote:
alguien wrote:I cant enable opengl. if i enable it i dont see anything on the screen. Why is this? Im using a raspberry pi 2
Sounds like your power supply can't cope. How many amps are your power supply, should really be 2 amps for Raspberry Pi 2.
Currently experimental Mesa and DRM driver for Broadcom VC4 hardware driver works only in 1080p.
See this thread: https://github.com/anholt/linux/issues/7

EdwinJ85
Posts: 269
Joined: Wed Feb 01, 2012 4:44 pm
Contact: Website

Re: How to setup Minecraft 1.8.9 on RaspPi2

Thu Mar 24, 2016 8:29 pm

Hi there, when I try to download the replacement jar file I get a 502 error - is there an alternative host for this?

Thanks,

Edwin.
Hello!

User avatar
rpiMike
Posts: 850
Joined: Fri Aug 10, 2012 12:38 pm
Location: Cumbria, UK

Re: How to setup Minecraft 1.8.9 on RaspPi2

Thu Mar 24, 2016 8:57 pm

EdwinJ85 wrote:Hi there, when I try to download the replacement jar file I get a 502 error - is there an alternative host for this?

Thanks,

Edwin.
I've just downloaded it myself. Seems ok.

EdwinJ85
Posts: 269
Joined: Wed Feb 01, 2012 4:44 pm
Contact: Website

Re: How to setup Minecraft 1.8.9 on RaspPi2

Fri Mar 25, 2016 8:52 pm

I get this with the lwjgl.jar link

502 Bad Gateway Error

Your request generated an Internal Server Error. A problem may have occured with the PWP service -- refer to the Status Page for further information.
Hello!

res1233
Posts: 6
Joined: Fri Dec 11, 2015 9:56 am

Re: How to setup Minecraft 1.8.9 on RaspPi2

Sun Mar 27, 2016 3:20 pm

EdwinJ85 wrote:I get this with the lwjgl.jar link

502 Bad Gateway Error

Your request generated an Internal Server Error. A problem may have occured with the PWP service -- refer to the Status Page for further information.
It seems to randomly throw out that error. Try again in a minute or two and the problem should go away.

Sindybad
Posts: 3
Joined: Tue Mar 01, 2016 8:29 pm

Re: How to setup Minecraft 1.8.9 on RaspPi2

Mon Mar 28, 2016 8:41 am

You can download a preview of OptiFine 1.9 at http://www.minecraftforum.net/forums/ma ... haders-and if anyone is willing to try it on an RPI.

Heath
Posts: 2
Joined: Mon Mar 28, 2016 4:54 pm

Re: How to setup Minecraft 1.8.9 on RaspPi2

Mon Mar 28, 2016 5:08 pm

I am doing this on a Raspberry Pi 1 B+. When I do java -jar Minecraft.jar it says:
Error: Invalid or corrupt jarfile Minecraft.jar
I didn't do the "Enable ‘AA GL Driver'" step as I could not find this option in raspiconfig.

Heath
Posts: 2
Joined: Mon Mar 28, 2016 4:54 pm

Re: How to setup Minecraft 1.8.9 on RaspPi2

Tue Mar 29, 2016 8:22 am

I fixed the corrupted jar problem. Midori wouldn't download the file completely so I used Google Chrome. Note: Another post I posted didn't show up in here about the corrupted jar because I think it had to be checked by a moderator. I only made an account to a post about this problem. I noticed that it's shown up.

EdwinJ85
Posts: 269
Joined: Wed Feb 01, 2012 4:44 pm
Contact: Website

Re: How to setup Minecraft 1.8.9 on RaspPi2

Tue Mar 29, 2016 10:30 pm

res1233 wrote:
EdwinJ85 wrote:I get this with the lwjgl.jar link

502 Bad Gateway Error

Your request generated an Internal Server Error. A problem may have occured with the PWP service -- refer to the Status Page for further information.
It seems to randomly throw out that error. Try again in a minute or two and the problem should go away.
Hmm, you are right - the third time I tried to download them it worked! Strange...thank you for your help :)
Hello!

GamingStar
Posts: 8
Joined: Sat Apr 02, 2016 2:25 pm

Re: How to setup Minecraft 1.8.9 on RaspPi2

Sat Apr 02, 2016 2:29 pm

Hello, when I do all that and run it it gives me an error:
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Java HotSpot(TM) Client VM warning: You have loaded library /home/pi/.minecraft/versions/1.8.9/1.8.9-natives-40573021246787/liblwjgl64.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/pi/.minecraft/versions/1.8.9/1.8.9-natives-40573021246787/liblwjgl.so: /home/pi/.minecraft/versions/1.8.9/1.8.9-natives-40573021246787/liblwjgl.so: cannot open shared object file: No such file or directory (Possible cause: can't load IA 32-bit .so on a ARM-bit platform)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1929)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1847)
at java.lang.Runtime.loadLibrary0(Runtime.java:870)
at java.lang.System.loadLibrary(System.java:1119)
at org.lwjgl.Sys$1.run(Sys.java:72)
at java.security.AccessController.doPrivileged(Native Method)
at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
at org.lwjgl.Sys.loadLibrary(Sys.java:96)
at org.lwjgl.Sys.<clinit>(Sys.java:117)
at ave.J(SourceFile:2539)
at net.minecraft.client.main.Main.main(SourceFile:41)
Can anyone help?

User avatar
rpiMike
Posts: 850
Joined: Fri Aug 10, 2012 12:38 pm
Location: Cumbria, UK

Re: How to setup Minecraft 1.8.9 on RaspPi2

Sun Apr 03, 2016 7:20 pm

GamingStar wrote:Hello, when I do all that and run it it gives me an error:
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Java HotSpot(TM) Client VM warning: You have loaded library /home/pi/.minecraft/versions/1.8.9/1.8.9-natives-40573021246787/liblwjgl64.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/pi/.minecraft/versions/1.8.9/1.8.9-natives-40573021246787/liblwjgl.so: /home/pi/.minecraft/versions/1.8.9/1.8.9-natives-40573021246787/liblwjgl.so: cannot open shared object file: No such file or directory (Possible cause: can't load IA 32-bit .so on a ARM-bit platform)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1929)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1847)
at java.lang.Runtime.loadLibrary0(Runtime.java:870)
at java.lang.System.loadLibrary(System.java:1119)
at org.lwjgl.Sys$1.run(Sys.java:72)
at java.security.AccessController.doPrivileged(Native Method)
at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
at org.lwjgl.Sys.loadLibrary(Sys.java:96)
at org.lwjgl.Sys.<clinit>(Sys.java:117)
at ave.J(SourceFile:2539)
at net.minecraft.client.main.Main.main(SourceFile:41)
Can anyone help?
Looks like you haven't replaced lwjgl-2.9.4-nightly-20150209.jar properly.

C-Fu
Posts: 88
Joined: Mon Nov 26, 2012 10:07 am
Location: Malaysia

Re: How to setup Minecraft 1.8.9 on RaspPi2

Mon Apr 04, 2016 7:42 am

Tried twice, still no go. Running raspbian jessie via berryboot.

Code: Select all

[email protected]:~/minecraft $ ./run.sh 
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   414  100   255  100   159    227    142  0:00:01  0:00:01 --:--:--   228
todays access token = 8b92e89e7b114493be05c47d796ed08e
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
2016-04-04 15:40:13,980 ERROR Cannot access RandomAccessFile {}) java.io.FileNotFoundException: logs/latest.log (Permission denied)
2016-04-04 15:40:13,986 ERROR Unable to invoke method createAppender in class org.apache.logging.log4j.core.appender.RollingRandomAccessFileAppender for element RollingRandomAccessFile java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:497)
	at org.apache.logging.log4j.core.config.BaseConfiguration.createPluginObject(BaseConfiguration.java:841)
	at org.apache.logging.log4j.core.config.BaseConfiguration.createConfiguration(BaseConfiguration.java:595)
	at org.apache.logging.log4j.core.config.BaseConfiguration.createConfiguration(BaseConfiguration.java:587)
	at org.apache.logging.log4j.core.config.BaseConfiguration.doConfigure(BaseConfiguration.java:244)
	at org.apache.logging.log4j.core.config.BaseConfiguration.start(BaseConfiguration.java:142)
	at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:339)
	at org.apache.logging.log4j.core.LoggerContext.reconfigure(LoggerContext.java:378)
	at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:149)
	at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:85)
	at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:34)
	at org.apache.logging.log4j.LogManager.getLogger(LogManager.java:387)
	at org.apache.logging.log4j.LogManager.getLogger(LogManager.java:322)
	at ave.<clinit>(SourceFile:145)
	at net.minecraft.client.main.Main.main(SourceFile:41)
Caused by: java.lang.IllegalStateException: Unable to create a manager
	at org.apache.logging.log4j.core.appender.AbstractManager.getManager(AbstractManager.java:73)
	at org.apache.logging.log4j.core.appender.OutputStreamManager.getManager(OutputStreamManager.java:65)
	at org.apache.logging.log4j.core.appender.rolling.RollingRandomAccessFileManager.getRollingRandomAccessFileManager(RollingRandomAccessFileManager.java:62)
	at org.apache.logging.log4j.core.appender.RollingRandomAccessFileAppender.createAppender(RollingRandomAccessFileAppender.java:196)
	... 18 more

2016-04-04 15:40:14,002 ERROR Null object returned for RollingRandomAccessFile in Appenders
2016-04-04 15:40:14,288 ERROR Unable to locate appender File for logger 
Exception in thread "main" java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path
	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1864)
	at java.lang.Runtime.loadLibrary0(Runtime.java:870)
	at java.lang.System.loadLibrary(System.java:1122)
	at org.lwjgl.Sys$1.run(Sys.java:72)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
	at org.lwjgl.Sys.loadLibrary(Sys.java:96)
	at org.lwjgl.Sys.<clinit>(Sys.java:117)
	at ave.J(SourceFile:2539)
	at net.minecraft.client.main.Main.main(SourceFile:41)
[email protected]:~/minecraft $ 
if anything, the only thing i did different is I made a "minecraft" folder instead of "Minecraft" that's all.

User avatar
rpiMike
Posts: 850
Joined: Fri Aug 10, 2012 12:38 pm
Location: Cumbria, UK

Re: How to setup Minecraft 1.8.9 on RaspPi2

Mon Apr 04, 2016 7:40 pm

C-Fu wrote:Tried twice, still no go. Running raspbian jessie via berryboot.

Code: Select all

[email protected]:~/minecraft $ ./run.sh 
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   414  100   255  100   159    227    142  0:00:01  0:00:01 --:--:--   228
todays access token = 8b92e89e7b114493be05c47d796ed08e
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
2016-04-04 15:40:13,980 ERROR Cannot access RandomAccessFile {}) java.io.FileNotFoundException: logs/latest.log (Permission denied)
2016-04-04 15:40:13,986 ERROR Unable to invoke method createAppender in class org.apache.logging.log4j.core.appender.RollingRandomAccessFileAppender for element RollingRandomAccessFile java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:497)
	at org.apache.logging.log4j.core.config.BaseConfiguration.createPluginObject(BaseConfiguration.java:841)
	at org.apache.logging.log4j.core.config.BaseConfiguration.createConfiguration(BaseConfiguration.java:595)
	at org.apache.logging.log4j.core.config.BaseConfiguration.createConfiguration(BaseConfiguration.java:587)
	at org.apache.logging.log4j.core.config.BaseConfiguration.doConfigure(BaseConfiguration.java:244)
	at org.apache.logging.log4j.core.config.BaseConfiguration.start(BaseConfiguration.java:142)
	at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:339)
	at org.apache.logging.log4j.core.LoggerContext.reconfigure(LoggerContext.java:378)
	at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:149)
	at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:85)
	at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:34)
	at org.apache.logging.log4j.LogManager.getLogger(LogManager.java:387)
	at org.apache.logging.log4j.LogManager.getLogger(LogManager.java:322)
	at ave.<clinit>(SourceFile:145)
	at net.minecraft.client.main.Main.main(SourceFile:41)
Caused by: java.lang.IllegalStateException: Unable to create a manager
	at org.apache.logging.log4j.core.appender.AbstractManager.getManager(AbstractManager.java:73)
	at org.apache.logging.log4j.core.appender.OutputStreamManager.getManager(OutputStreamManager.java:65)
	at org.apache.logging.log4j.core.appender.rolling.RollingRandomAccessFileManager.getRollingRandomAccessFileManager(RollingRandomAccessFileManager.java:62)
	at org.apache.logging.log4j.core.appender.RollingRandomAccessFileAppender.createAppender(RollingRandomAccessFileAppender.java:196)
	... 18 more

2016-04-04 15:40:14,002 ERROR Null object returned for RollingRandomAccessFile in Appenders
2016-04-04 15:40:14,288 ERROR Unable to locate appender File for logger 
Exception in thread "main" java.lang.UnsatisfiedLinkError: no lwjgl in java.library.path
	at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1864)
	at java.lang.Runtime.loadLibrary0(Runtime.java:870)
	at java.lang.System.loadLibrary(System.java:1122)
	at org.lwjgl.Sys$1.run(Sys.java:72)
	at java.security.AccessController.doPrivileged(Native Method)
	at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
	at org.lwjgl.Sys.loadLibrary(Sys.java:96)
	at org.lwjgl.Sys.<clinit>(Sys.java:117)
	at ave.J(SourceFile:2539)
	at net.minecraft.client.main.Main.main(SourceFile:41)
[email protected]:~/minecraft $ 
if anything, the only thing i did different is I made a "minecraft" folder instead of "Minecraft" that's all.
I believe raspbian (linux) is case sensitive - please try with "Minecraft"

Bamboozle
Posts: 2
Joined: Thu Jul 19, 2012 1:10 pm
Location: Germany

Re: How to setup Minecraft 1.8.9 on RaspPi2

Wed Apr 06, 2016 10:00 pm

Thank you very much for you effort for posting this. I will try it tomorrow. Maybe then i dont have to buy my daugther a new computer for playing pc-minecraft :)

GamingStar
Posts: 8
Joined: Sat Apr 02, 2016 2:25 pm

Re: How to setup Minecraft 1.8.9 on RaspPi2

Sat Apr 09, 2016 2:55 pm

rpiMike wrote:
GamingStar wrote:Hello, when I do all that and run it it gives me an error:
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Java HotSpot(TM) Client VM warning: You have loaded library /home/pi/.minecraft/versions/1.8.9/1.8.9-natives-40573021246787/liblwjgl64.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/pi/.minecraft/versions/1.8.9/1.8.9-natives-40573021246787/liblwjgl.so: /home/pi/.minecraft/versions/1.8.9/1.8.9-natives-40573021246787/liblwjgl.so: cannot open shared object file: No such file or directory (Possible cause: can't load IA 32-bit .so on a ARM-bit platform)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1929)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1847)
at java.lang.Runtime.loadLibrary0(Runtime.java:870)
at java.lang.System.loadLibrary(System.java:1119)
at org.lwjgl.Sys$1.run(Sys.java:72)
at java.security.AccessController.doPrivileged(Native Method)
at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
at org.lwjgl.Sys.loadLibrary(Sys.java:96)
at org.lwjgl.Sys.<clinit>(Sys.java:117)
at ave.J(SourceFile:2539)
at net.minecraft.client.main.Main.main(SourceFile:41)
Can anyone help?
Looks like you haven't replaced lwjgl-2.9.4-nightly-20150209.jar properly.
Okay, I'll try it again.

C-Fu
Posts: 88
Joined: Mon Nov 26, 2012 10:07 am
Location: Malaysia

Re: How to setup Minecraft 1.8.9 on RaspPi2

Wed Apr 13, 2016 8:38 am

Okay, I know the problem. It's my monitor. Currently using 1366x768 monitor, and rainbow screen comes up after the restarting step. But once I moved the mouse I can see the desktop. Haven't installed minecraft yet, but I presume everything works.

What's weird is that the rainbow screen comes up even after restarting again, AND in berryboot OS options screen... which I don't think should happen as I believe the raspi-config AA GL setting is per OS setting, and now something like a hardware switch, right?

I'll try again on a 1080p monitor and let you know the result.

User avatar
rpiMike
Posts: 850
Joined: Fri Aug 10, 2012 12:38 pm
Location: Cumbria, UK

Re: How to setup Minecraft 1.8.9 on RaspPi2

Wed Apr 13, 2016 8:41 am

C-Fu wrote:Okay, I know the problem. It's my monitor. Currently using 1366x768 monitor, and rainbow screen comes up after the restarting step. But once I moved the mouse I can see the desktop. Haven't installed minecraft yet, but I presume everything works.

What's weird is that the rainbow screen comes up even after restarting again, AND in berryboot OS options screen... which I don't think should happen as I believe the raspi-config AA GL setting is per OS setting, and now something like a hardware switch, right?

I'll try again on a 1080p monitor and let you know the result.
I believe the experimental OpenGL driver has limited monitor support. Best to use 1080p.

C-Fu
Posts: 88
Joined: Mon Nov 26, 2012 10:07 am
Location: Malaysia

Re: How to setup Minecraft 1.8.9 on RaspPi2

Wed Apr 13, 2016 2:57 pm

It works! A bit sluggish though. Gonna try running it on RPi3 tomorrow.

OptiFine's version doesn't work for me. Only thing that's different is I used the current-version ASM 5.1 and not asm 5.0.3 as well as OptiFine_1.8.9_HD_U_H5 as I can't find OptiFine_1.8.9_HD_U_H3.

Code: Select all

[email protected]:~/Minecraft $ ./runOptifine.sh 
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   417  100   255  100   162    278    176 --:--:-- --:--:-- --:--:--   278
todays access token = c973ca064629493d9c7f8afc66828cf2
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Apr 13, 2016 10:54:45 PM net.minecraft.launchwrapper.LogWrapper log
INFO: Loading tweak class name optifine.OptiFineTweaker
Apr 13, 2016 10:54:45 PM net.minecraft.launchwrapper.LogWrapper log
SEVERE: Unable to launch
java.lang.ClassNotFoundException: optifine.OptiFineTweaker
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:99)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:348)
	at net.minecraft.launchwrapper.Launch.launch(Launch.java:94)
	at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

Rjnbarnett
Posts: 1
Joined: Wed Apr 20, 2016 4:28 pm

Re: How to setup Minecraft 1.8.9 on RaspPi2

Wed Apr 20, 2016 4:37 pm

I'm new to this rpi or even coding in general. I'm trying to follow instructions but I can't get the directories made.
'Mkdr' line gives errors of
"Cannot create directory '/Minecraft': No such file or directory"
Am I doing something wrong?

Everything up to this point worked I think. I downloaded the minecraft.jar using the browser included in raspbian. It showed up in the downloads folder.

I tried to use the file manager to make a /Minecraft folder and I got the error permission denied. I will try it without the forward slash.

BaconCat
Posts: 3
Joined: Thu Apr 21, 2016 12:29 am

Re: How to setup Minecraft 1.8.9 on RaspPi2

Thu Apr 21, 2016 12:38 am

I'm getting a really weird failing log when I try to run the Optifine command, ./runOptifine.sh
I honestly have no idea what this is talking about.

Code: Select all

SEVERE: Unable to launch
java.lang.ClassNotFoundException: optifine.OptiFineTweaker
	at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:99)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
	at java.lang.Class.forName0(Native Method)
	at java.lang.Class.forName(Class.java:348)
	at net.minecraft.launchwrapper.Launch.launch(Launch.java:94)
	at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

I also have a problem with going onto a online server. I'm concisely getting the "Invalid session Try restarting you're game"
Any ideas how to fix this?
Never mined fixed the muityplayer issue
I have no idea what I'm doing

ChickenPillow
Posts: 13
Joined: Thu Mar 10, 2016 9:06 pm

Re: How to setup Minecraft 1.8.9 on RaspPi2

Thu Apr 21, 2016 8:19 pm

rpiMike wrote:
ChickenPillow wrote:Hello, Ive managed to set up minecraft and can play perfectly. The problem is there is no sound, in the Terminal thing it says it cant find the sound. How do I fix this? The video i saw had sound working and its not my pi, just minecraft. Thanks.
I think this should fix the sound :

sudo apt-get install libalut0 libalut-dev
Still doesnt give sound, all I can hear is a fuzzing sound, there is and error in the minecraft running terminal thing, and sound works on other things like youtube :( Plzzz help me

User avatar
rpiMike
Posts: 850
Joined: Fri Aug 10, 2012 12:38 pm
Location: Cumbria, UK

Re: How to setup Minecraft 1.8.9 on RaspPi2

Thu Apr 21, 2016 10:04 pm

ChickenPillow wrote:
rpiMike wrote:
ChickenPillow wrote:Hello, Ive managed to set up minecraft and can play perfectly. The problem is there is no sound, in the Terminal thing it says it cant find the sound. How do I fix this? The video i saw had sound working and its not my pi, just minecraft. Thanks.
I think this should fix the sound :

sudo apt-get install libalut0 libalut-dev
Still doesnt give sound, all I can hear is a fuzzing sound, there is and error in the minecraft running terminal thing, and sound works on other things like youtube :( Plzzz help me
Edit run.sh and change MINECRAFT_VERSION=1.8.9 to MINECRAFT_VERSION=1.8

ChickenPillow
Posts: 13
Joined: Thu Mar 10, 2016 9:06 pm

Re: How to setup Minecraft 1.8.9 on RaspPi2

Fri Apr 22, 2016 6:02 pm

ChickenPillow wrote:
rpiMike wrote:
ChickenPillow wrote:Hello, Ive managed to set up minecraft and can play perfectly. The problem is there is no sound, in the Terminal thing it says it cant find the sound. How do I fix this? The video i saw had sound working and its not my pi, just minecraft. Thanks.
I think this should fix the sound :

sudo apt-get install libalut0 libalut-dev
Still doesnt give sound, all I can hear is a fuzzing sound, there is and error in the minecraft running terminal thing, and sound works on other things like youtube :( Plzzz help me
AMAZING! Thx, sound works fine now.

Just a couple questions:

1. Will there be sound for after 1.8 (1.8 - 1.9.2)

2. Is there a way to have an icon you can just click to run minecraft and if so how?

Return to “Gaming”