How to setup Minecraft 1.8.9 on RaspPi2


294 posts   Page 11 of 12   1 ... 8, 9, 10, 11, 12
by xXRoboBoyXx » Fri Jun 09, 2017 1:11 pm
rpiMike wrote:Sounds like you have got Minecraft working. However do not try running it full screen as the Pi cannot cope and will likely crash. You have to play Minecraft in windowed mode with at least render chunks turned down to 2.


I´ve gotten everything working and with a rpi overclocked to 1.45 ghz and with a heatsink and fan I have gotten minecraft fullscreened!

-edit 1: Well not everything. The f1-f12 keys don´t work
Posts: 32
Joined: Sat Feb 04, 2017 3:22 pm
by Xcom6000 » Sat Jun 10, 2017 12:50 am
I followed the instructions found here in this link and got Minecraft desktop version 1.8.9 working perfectly.
https://www.novaspirit.com/2017/03/09/i ... pberry-pi/
The issue is the move from 1.8.9 to 1.11.2. In the tutorial novaspirit simply edits the run.sh file and logs into the game. But what he misses to do is to login to a world and get it to work. Following his instruction all works fine until attempting to log into a world running 1.11.2.

Could someone please help with a bit more clear instructions on how to upgrade your 1.8.9 version to 1.11.2. Is it really as simple as editing the run.sh file?
Posts: 16
Joined: Sat Jun 10, 2017 12:42 am
by xXRoboBoyXx » Sat Jun 10, 2017 10:07 pm
Xcom6000 wrote:I followed the instructions found here in this link and got Minecraft desktop version 1.8.9 working perfectly.
https://www.novaspirit.com/2017/03/09/i ... pberry-pi/
The issue is the move from 1.8.9 to 1.11.2. In the tutorial novaspirit simply edits the run.sh file and logs into the game. But what he misses to do is to login to a world and get it to work. Following his instruction all works fine until attempting to log into a world running 1.11.2.

Could someone please help with a bit more clear instructions on how to upgrade your 1.8.9 version to 1.11.2. Is it really as simple as editing the run.sh file?

It is that simple but if you want minecraft to run reliably then use this. (Oh and servers don't work unless you do this)

You should do the steps to open minecraft. until you get 1.8.9 running. To start installing optifine+server script download the optifine jar from this link http://optifine.net/adloadx?f=OptiFine_1.11.2_HD_U_B7.jar

And then in the Downloads directory type
Code: Select all
java -jar OptiFine_1.11.2_HD_U_B7.jar
and install it Don't change anything. Then open the minecraft launcher and try to start optifine. After it doesnt work exit the launcher and download the server+optifine run.sh file by using
Code: Select all
cd ~/Minecraft && wget https://www.dropbox.com/s/vyra53z5wmtkjid/runOptifine2.sh && sudo chmod +x runOptifine2.sh
Thats what i did and it works for me! Hope i helped!
Last edited by xXRoboBoyXx on Mon Jun 12, 2017 8:49 pm, edited 2 times in total.
Posts: 32
Joined: Sat Feb 04, 2017 3:22 pm
by Aang » Sat Jun 10, 2017 10:12 pm
I got minecraft forge 1.10.2 with mods + optifine + foamfix + betterfps running at a playable fps rate ( about 15 - 20 ) on pi2. Is anyone interested about explanation to reproduce it ?
It work flawlessly with ic2, trying with galacticraft, and why not both ? Actually I start it in offline mod.
Posts: 16
Joined: Sat Jun 10, 2017 10:07 pm
by Xcom6000 » Sat Jun 10, 2017 10:40 pm
Sadly I cant get the base game to work on 1.11.2.

Link is a picture of the crash that the console reads out. I am unsure as what it is I'm doing wrong. I can get 1.8.9 working fine. I just want the base game to work before I install optifine and add more complications.

Image
Posts: 16
Joined: Sat Jun 10, 2017 12:42 am
by Aang » Sat Jun 10, 2017 10:58 pm
The 1.8.9 base run.sh is broken for 1.11...
Try using fixes from the precedent posts. If they doesn’t work I will make a fix.
Posts: 16
Joined: Sat Jun 10, 2017 10:07 pm
by Xcom6000 » Sat Jun 10, 2017 11:01 pm
Which post should I download the run.sh from?
Posts: 16
Joined: Sat Jun 10, 2017 12:42 am
by Aang » Sat Jun 10, 2017 11:19 pm
THe only one I found does not work for 1.11.2. I don’t have my pi now, so I will explain to you how to create the script yourself.
Start the normal launcher, to download 1.11.2, let it crash.
Paste all the logs you got in the console where you started the launcher here, I will correct it for the pi.
After go to .minecraft and create a folder « natives » and put in what’s it the Minecraft/Natives folder.
After this, create a new run.sh file and paste the code I will give.
This is method I used to get it work, and approximately the same for forge...


PS : I know my English is not perfect...
Posts: 16
Joined: Sat Jun 10, 2017 10:07 pm
by Xcom6000 » Sat Jun 10, 2017 11:26 pm
I tried the run2.sh from page 5 https://www.raspberrypi.org/forums/view ... 35#p990835 and edited the lines to get 1.11.2 working. Got the same crash. I searched the thread and there are other people reporting the same exact issue without a fix.

Code: Select all
[23:14:59] [Server thread/INFO]: Starting integrated minecraft server version 1.11.2
[23:14:59] [Server thread/INFO]: Generating keypair
[23:15:05] [Server thread/ERROR]: Encountered an unexpected exception
java.lang.NoClassDefFoundError: it/unimi/dsi/fastutil/longs/Long2ObjectMap
   at mt.d(SourceFile:270) ~[1.11.2.jar:?]
   at lt.<init>(SourceFile:62) ~[1.11.2.jar:?]
   at lw.<init>(SourceFile:123) ~[1.11.2.jar:?]
   at cch.a(SourceFile:98) ~[1.11.2.jar:?]
   at cch.j(SourceFile:130) ~[1.11.2.jar:?]
   at net.minecraft.server.MinecraftServer.run(SourceFile:436) [1.11.2.jar:?]
   at java.lang.Thread.run(Thread.java:745) [?:1.8.0_65]
Caused by: java.lang.ClassNotFoundException: it.unimi.dsi.fastutil.longs.Long2ObjectMap
   at java.net.URLClassLoader.findClass(URLClassLoader.java:381) ~[?:1.8.0_65]
   at java.lang.ClassLoader.loadClass(ClassLoader.java:424) ~[?:1.8.0_65]
   at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331) ~[?:1.8.0_65]
   at java.lang.ClassLoader.loadClass(ClassLoader.java:357) ~[?:1.8.0_65]
   ... 7 more
[23:15:05] [Server thread/ERROR]: This crash report has been saved to: /home/pi/.minecraft/crash-reports/crash-2017-06-10_23.15.05-server.txt
[23:15:05] [Server thread/INFO]: Stopping server
[23:15:05] [Server thread/INFO]: Saving players
[23:15:05] [Server thread/INFO]: Saving worlds
^C[23:15:32] [Client Shutdown Thread/INFO]: Stopping server
[23:15:32] [Client Shutdown Thread/INFO]: Saving players
[23:15:32] [Client Shutdown Thread/INFO]: Saving worlds


Just to eliminate all doubt I rather give all the info.
Reinstalled the SD card with latest 2017-04-10-raspbian-jessie pixel using FAT32. Installed everything as per instructions from novaspirit and edited the run.sh file to run 1.11.2 after getting 1.8.9 working.

Other people are reporting running the game on 1.11.2 and others have issues in the thread. It seams a bit random and unclear to the full instructions from start to finish. I must be doing something wrong and I cant pinpoint the problem as the error log indicates missing files. Another person on page 4 had the same issue but no solution was provided.
Posts: 16
Joined: Sat Jun 10, 2017 12:42 am
by Aang » Sat Jun 10, 2017 11:28 pm
So, I will write a complete guide for 1.11.2 tomorrow, from start to beginning.
Posts: 16
Joined: Sat Jun 10, 2017 10:07 pm
by Xcom6000 » Sat Jun 10, 2017 11:32 pm
This is the full crash after running the launcher and clicking to play 1.11.2 with the launcher.

Code: Select all
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Java HotSpot(TM) Client VM warning: You have loaded library /home/pi/.minecraft/versions/1.11.2/1.11.2-natives-4043281906040/liblwjgl64.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/pi/.minecraft/versions/1.11.2/1.11.2-natives-4043281906040/liblwjgl.so: /home/pi/.minecraft/versions/1.11.2/1.11.2-natives-4043281906040/liblwjgl.so: cannot open shared object file: No such file or directory (Possible cause: can't load IA 32-bit .so on a ARM-bit platform)
   at java.lang.ClassLoader$NativeLibrary.load(Native Method)
   at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1938)
   at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1854)
   at java.lang.Runtime.loadLibrary0(Runtime.java:870)
   at java.lang.System.loadLibrary(System.java:1122)
   at org.lwjgl.Sys$1.run(Sys.java:72)
   at java.security.AccessController.doPrivileged(Native Method)
   at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
   at org.lwjgl.Sys.loadLibrary(Sys.java:96)
   at org.lwjgl.Sys.<clinit>(Sys.java:117)
   at bes.I(SourceFile:2777)
   at net.minecraft.client.main.Main.main(SourceFile:39)
Posts: 16
Joined: Sat Jun 10, 2017 12:42 am
by Xcom6000 » Sat Jun 10, 2017 11:33 pm
Thank you for all the help. Really appreciated.
Posts: 16
Joined: Sat Jun 10, 2017 12:42 am
by Aang » Sat Jun 10, 2017 11:38 pm
Xcom6000 wrote:This is the full crash after running the launcher and clicking to play 1.11.2 with the launcher.

Code: Select all
Java HotSpot(TM) Client VM warning: Using incremental CMS is deprecated and will likely be removed in a future release
Java HotSpot(TM) Client VM warning: You have loaded library /home/pi/.minecraft/versions/1.11.2/1.11.2-natives-4043281906040/liblwjgl64.so which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/pi/.minecraft/versions/1.11.2/1.11.2-natives-4043281906040/liblwjgl.so: /home/pi/.minecraft/versions/1.11.2/1.11.2-natives-4043281906040/liblwjgl.so: cannot open shared object file: No such file or directory (Possible cause: can't load IA 32-bit .so on a ARM-bit platform)
   at java.lang.ClassLoader$NativeLibrary.load(Native Method)
   at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1938)
   at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1854)
   at java.lang.Runtime.loadLibrary0(Runtime.java:870)
   at java.lang.System.loadLibrary(System.java:1122)
   at org.lwjgl.Sys$1.run(Sys.java:72)
   at java.security.AccessController.doPrivileged(Native Method)
   at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
   at org.lwjgl.Sys.loadLibrary(Sys.java:96)
   at org.lwjgl.Sys.<clinit>(Sys.java:117)
   at bes.I(SourceFile:2777)
   at net.minecraft.client.main.Main.main(SourceFile:39)

I need what you get in the terminal where you execute java -jar Minecraft.jar
In this logs there is the command to launch minecraft, after only the native paths has to get changed to get it work, this is what run.sh does wrong.
Posts: 16
Joined: Sat Jun 10, 2017 10:07 pm
by Xcom6000 » Sat Jun 10, 2017 11:45 pm
This is after I run java -jar Minecraft.jar

Code: Select all
pi@raspberrypi:~/Minecraft $ java -jar Minecraft.jar
Bootstrap (v5)
Current time is Jun 10, 2017 11:41:50 PM
System.getProperty('os.name') == 'Linux'
System.getProperty('os.version') == '4.9.31-v7+'
System.getProperty('os.arch') == 'arm'
System.getProperty('java.version') == '1.8.0_65'
System.getProperty('java.vendor') == 'Oracle Corporation'
System.getProperty('sun.arch.data.model') == '32'

Looking for update
Downloading: https://s3.amazonaws.com/Minecraft.Download/launcher/launcher.pack.lzma
Didn't find an update in time.
Reversing LZMA on /home/pi/.minecraft/launcher.pack.lzma to /home/pi/.minecraft/launcher.pack
Got reply in: 2601ms
No update found.
Unpacking /home/pi/.minecraft/launcher.pack to /home/pi/.minecraft/launcher.jar
Cleaning up /home/pi/.minecraft/launcher.pack
Starting launcher.
[23:42:33 INFO]: Minecraft Launcher 1.6.73-j (through bootstrap 5) started on linux...
[23:42:33 INFO]: Current time is Jun 10, 2017 11:42:33 PM
[23:42:33 INFO]: System.getProperty('os.name') == 'Linux'
[23:42:33 INFO]: System.getProperty('os.version') == '4.9.31-v7+'
[23:42:33 INFO]: System.getProperty('os.arch') == 'arm'
[23:42:33 INFO]: System.getProperty('java.version') == '1.8.0_65'
[23:42:33 INFO]: System.getProperty('java.vendor') == 'Oracle Corporation'
[23:42:33 INFO]: System.getProperty('sun.arch.data.model') == '32'
[23:42:33 INFO]: proxy == DIRECT
[23:42:36 INFO]: Refreshing local version list...
[23:42:38 INFO]: Refreshing remote version list...
[23:42:39 INFO]: Refresh complete.
[23:42:41 INFO]: Loaded 1 profile(s); selected 'Xcom6000'
[23:42:41 INFO]: Refreshing auth...
[23:42:41 INFO]: Logging in with access token


This is after I click run.

Code: Select all
[23:43:32 INFO]: Getting syncinfo for selected version
[23:43:32 INFO]: Queueing library & version downloads
[23:43:33 INFO]: Download job 'Version & Libraries' started (16 threads, 33 files)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/com/paulscode/soundsystem/20120107/soundsystem-20120107.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl/2.9.4-nightly-20150209/lwjgl-2.9.4-nightly-20150209.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl_util/2.9.4-nightly-20150209/lwjgl_util-2.9.4-nightly-20150209.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-api/2.0-beta9/log4j-api-2.0-beta9.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/com/paulscode/codecjorbis/20101023/codecjorbis-20101023.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/com/paulscode/libraryjavasound/20101123/libraryjavasound-20101123.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/io/netty/netty-all/4.0.23.Final/netty-all-4.0.23.Final.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/net/java/jinput/jinput/2.0.5/jinput-2.0.5.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/oshi-project/oshi-core/1.1/oshi-core-1.1.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/com/google/code/gson/gson/2.2.4/gson-2.2.4.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl-platform/2.9.4-nightly-20150209/lwjgl-platform-2.9.4-nightly-20150209-natives-linux.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/net/java/jinput/jinput-platform/2.0.5/jinput-platform-2.0.5-natives-linux.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/net/sf/jopt-simple/jopt-simple/4.6/jopt-simple-4.6.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/com/paulscode/librarylwjglopenal/20100824/librarylwjglopenal-20100824.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/com/paulscode/codecwav/20101023/codecwav-20101023.jar for job 'Version & Libraries'... (try 0)
[23:43:33 INFO]: Attempting to download /home/pi/.minecraft/libraries/it/unimi/dsi/fastutil/7.0.12_mojang/fastutil-7.0.12_mojang.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Download job 'Resources' skipped as there are no files to download
[23:43:34 INFO]: Job 'Resources' finished successfully (took 0:00:00.002)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/io/netty/netty-all/4.0.23.Final/netty-all-4.0.23.Final.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/net/java/jutils/jutils/1.0.0/jutils-1.0.0.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl/2.9.4-nightly-20150209/lwjgl-2.9.4-nightly-20150209.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/org/apache/commons/commons-compress/1.8.1/commons-compress-1.8.1.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl-platform/2.9.4-nightly-20150209/lwjgl-platform-2.9.4-nightly-20150209-natives-linux.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/org/apache/httpcomponents/httpcore/4.3.2/httpcore-4.3.2.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/it/unimi/dsi/fastutil/7.0.12_mojang/fastutil-7.0.12_mojang.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/net/java/jutils/jutils/1.0.0/jutils-1.0.0.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/commons-io/commons-io/2.4/commons-io-2.4.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/net/sf/jopt-simple/jopt-simple/4.6/jopt-simple-4.6.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/org/apache/httpcomponents/httpclient/4.3.3/httpclient-4.3.3.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/net/java/jinput/jinput/2.0.5/jinput-2.0.5.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/com/mojang/netty/1.6/netty-1.6.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/com/paulscode/codecwav/20101023/codecwav-20101023.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-core/2.0-beta9/log4j-core-2.0-beta9.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/com/mojang/netty/1.6/netty-1.6.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/com/mojang/realms/1.10.16/realms-1.10.16.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/com/paulscode/librarylwjglopenal/20100824/librarylwjglopenal-20100824.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/com/mojang/authlib/1.5.24/authlib-1.5.24.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/com/google/code/gson/gson/2.2.4/gson-2.2.4.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/org/apache/commons/commons-lang3/3.3.2/commons-lang3-3.3.2.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/net/java/jinput/jinput-platform/2.0.5/jinput-platform-2.0.5-natives-linux.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/net/java/dev/jna/platform/3.4.0/platform-3.4.0.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/commons-codec/commons-codec/1.9/commons-codec-1.9.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/oshi-project/oshi-core/1.1/oshi-core-1.1.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/com/ibm/icu/icu4j-core-mojang/51.2/icu4j-core-mojang-51.2.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/com/paulscode/codecjorbis/20101023/codecjorbis-20101023.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/net/java/dev/jna/jna/3.4.0/jna-3.4.0.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/com/paulscode/libraryjavasound/20101123/libraryjavasound-20101123.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/commons-logging/commons-logging/1.1.3/commons-logging-1.1.3.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-api/2.0-beta9/log4j-api-2.0-beta9.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/libraries/com/google/guava/guava/17.0/guava-17.0.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl_util/2.9.4-nightly-20150209/lwjgl_util-2.9.4-nightly-20150209.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Attempting to download /home/pi/.minecraft/versions/1.11.2/1.11.2.jar for job 'Version & Libraries'... (try 0)
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/com/paulscode/soundsystem/20120107/soundsystem-20120107.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/org/apache/httpcomponents/httpcore/4.3.2/httpcore-4.3.2.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/commons-io/commons-io/2.4/commons-io-2.4.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/commons-logging/commons-logging/1.1.3/commons-logging-1.1.3.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/com/mojang/authlib/1.5.24/authlib-1.5.24.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/commons-codec/commons-codec/1.9/commons-codec-1.9.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/org/apache/commons/commons-compress/1.8.1/commons-compress-1.8.1.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/net/java/dev/jna/platform/3.4.0/platform-3.4.0.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:34 INFO]: Finished downloading /home/pi/.minecraft/libraries/org/apache/httpcomponents/httpclient/4.3.3/httpclient-4.3.3.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:35 INFO]: Finished downloading /home/pi/.minecraft/libraries/org/apache/commons/commons-lang3/3.3.2/commons-lang3-3.3.2.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:35 INFO]: Finished downloading /home/pi/.minecraft/libraries/net/java/dev/jna/jna/3.4.0/jna-3.4.0.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:35 INFO]: Finished downloading /home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-core/2.0-beta9/log4j-core-2.0-beta9.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:35 INFO]: Finished downloading /home/pi/.minecraft/libraries/com/google/guava/guava/17.0/guava-17.0.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:35 INFO]: Finished downloading /home/pi/.minecraft/libraries/com/ibm/icu/icu4j-core-mojang/51.2/icu4j-core-mojang-51.2.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:35 INFO]: Finished downloading /home/pi/.minecraft/libraries/com/mojang/realms/1.10.16/realms-1.10.16.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:36 INFO]: Finished downloading /home/pi/.minecraft/versions/1.11.2/1.11.2.jar for job 'Version & Libraries': Local file matches hash, using that
[23:43:36 INFO]: Job 'Version & Libraries' finished successfully (took 0:00:03.338)
[23:43:36 INFO]: Launching game
[23:43:36 INFO]: Unpacking natives to /home/pi/.minecraft/versions/1.11.2/1.11.2-natives-4801562524787
[23:43:36 INFO]: Launching in /home/pi/.minecraft
[23:43:37 INFO]: Half command: /usr/lib/jvm/jdk-8-oracle-arm32-vfp-hflt/jre/bin/java -Xmx512M -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M -Djava.library.path=/home/pi/.minecraft/versions/1.11.2/1.11.2-natives-4801562524787 -cp /home/pi/.minecraft/libraries/com/mojang/netty/1.6/netty-1.6.jar:/home/pi/.minecraft/libraries/oshi-project/oshi-core/1.1/oshi-core-1.1.jar:/home/pi/.minecraft/libraries/net/java/dev/jna/jna/3.4.0/jna-3.4.0.jar:/home/pi/.minecraft/libraries/net/java/dev/jna/platform/3.4.0/platform-3.4.0.jar:/home/pi/.minecraft/libraries/com/ibm/icu/icu4j-core-mojang/51.2/icu4j-core-mojang-51.2.jar:/home/pi/.minecraft/libraries/net/sf/jopt-simple/jopt-simple/4.6/jopt-simple-4.6.jar:/home/pi/.minecraft/libraries/com/paulscode/codecjorbis/20101023/codecjorbis-20101023.jar:/home/pi/.minecraft/libraries/com/paulscode/codecwav/20101023/codecwav-20101023.jar:/home/pi/.minecraft/libraries/com/paulscode/libraryjavasound/20101123/libraryjavasound-20101123.jar:/home/pi/.minecraft/libraries/com/paulscode/librarylwjglopenal/20100824/librarylwjglopenal-20100824.jar:/home/pi/.minecraft/libraries/com/paulscode/soundsystem/20120107/soundsystem-20120107.jar:/home/pi/.minecraft/libraries/io/netty/netty-all/4.0.23.Final/netty-all-4.0.23.Final.jar:/home/pi/.minecraft/libraries/com/google/guava/guava/17.0/guava-17.0.jar:/home/pi/.minecraft/libraries/org/apache/commons/commons-lang3/3.3.2/commons-lang3-3.3.2.jar:/home/pi/.minecraft/libraries/commons-io/commons-io/2.4/commons-io-2.4.jar:/home/pi/.minecraft/libraries/commons-codec/commons-codec/1.9/commons-codec-1.9.jar:/home/pi/.minecraft/libraries/net/java/jinput/jinput/2.0.5/jinput-2.0.5.jar:/home/pi/.minecraft/libraries/net/java/jutils/jutils/1.0.0/jutils-1.0.0.jar:/home/pi/.minecraft/libraries/com/google/code/gson/gson/2.2.4/gson-2.2.4.jar:/home/pi/.minecraft/libraries/com/mojang/authlib/1.5.24/authlib-1.5.24.jar:/home/pi/.minecraft/libraries/com/mojang/realms/1.10.16/realms-1.10.16.jar:/home/pi/.minecraft/libraries/org/apache/commons/commons-compress/1.8.1/commons-compress-1.8.1.jar:/home/pi/.minecraft/libraries/org/apache/httpcomponents/httpclient/4.3.3/httpclient-4.3.3.jar:/home/pi/.minecraft/libraries/commons-logging/commons-logging/1.1.3/commons-logging-1.1.3.jar:/home/pi/.minecraft/libraries/org/apache/httpcomponents/httpcore/4.3.2/httpcore-4.3.2.jar:/home/pi/.minecraft/libraries/it/unimi/dsi/fastutil/7.0.12_mojang/fastutil-7.0.12_mojang.jar:/home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-api/2.0-beta9/log4j-api-2.0-beta9.jar:/home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-core/2.0-beta9/log4j-core-2.0-beta9.jar:/home/pi/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl/2.9.4-nightly-20150209/lwjgl-2.9.4-nightly-20150209.jar:/home/pi/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl_util/2.9.4-nightly-20150209/lwjgl_util-2.9.4-nightly-20150209.jar:/home/pi/.minecraft/versions/1.11.2/1.11.2.jar net.minecraft.client.main.Main
[23:43:37 INFO]: Looking for orphaned versions to clean up...
[23:43:38 INFO]: Looking for old natives & assets to clean up...
[23:43:46 ERROR]: Game ended with bad state (exit code 1)
[23:43:46 INFO]: Ignoring visibility rule and showing launcher due to a game crash
[23:43:46 INFO]: Deleting /home/pi/.minecraft/versions/1.11.2/1.11.2-natives-4801562524787
Posts: 16
Joined: Sat Jun 10, 2017 12:42 am
by Aang » Sun Jun 11, 2017 12:02 am
Code: Select all
java -Xmx1024M -XX:+UseConcMarkSweepGC -XX:+CMSIncrementalMode -XX:-UseAdaptiveSizePolicy -Xmn128M -Djava.library.path=/home/pi/Minecraft/Natives -cp /home/pi/.minecraft/libraries/com/mojang/netty/1.6/netty-1.6.jar:/home/pi/.minecraft/libraries/oshi-project/oshi-core/1.1/oshi-core-1.1.jar:/home/pi/.minecraft/libraries/net/java/dev/jna/jna/3.4.0/jna-3.4.0.jar:/home/pi/.minecraft/libraries/net/java/dev/jna/platform/3.4.0/platform-3.4.0.jar:/home/pi/.minecraft/libraries/com/ibm/icu/icu4j-core-mojang/51.2/icu4j-core-mojang-51.2.jar:/home/pi/.minecraft/libraries/net/sf/jopt-simple/jopt-simple/4.6/jopt-simple-4.6.jar:/home/pi/.minecraft/libraries/com/paulscode/codecjorbis/20101023/codecjorbis-20101023.jar:/home/pi/.minecraft/libraries/com/paulscode/codecwav/20101023/codecwav-20101023.jar:/home/pi/.minecraft/libraries/com/paulscode/libraryjavasound/20101123/libraryjavasound-20101123.jar:/home/pi/.minecraft/libraries/com/paulscode/librarylwjglopenal/20100824/librarylwjglopenal-20100824.jar:/home/pi/.minecraft/libraries/com/paulscode/soundsystem/20120107/soundsystem-20120107.jar:/home/pi/.minecraft/libraries/io/netty/netty-all/4.0.23.Final/netty-all-4.0.23.Final.jar:/home/pi/.minecraft/libraries/com/google/guava/guava/17.0/guava-17.0.jar:/home/pi/.minecraft/libraries/org/apache/commons/commons-lang3/3.3.2/commons-lang3-3.3.2.jar:/home/pi/.minecraft/libraries/commons-io/commons-io/2.4/commons-io-2.4.jar:/home/pi/.minecraft/libraries/commons-codec/commons-codec/1.9/commons-codec-1.9.jar:/home/pi/.minecraft/libraries/net/java/jinput/jinput/2.0.5/jinput-2.0.5.jar:/home/pi/.minecraft/libraries/net/java/jutils/jutils/1.0.0/jutils-1.0.0.jar:/home/pi/.minecraft/libraries/com/google/code/gson/gson/2.2.4/gson-2.2.4.jar:/home/pi/.minecraft/libraries/com/mojang/authlib/1.5.24/authlib-1.5.24.jar:/home/pi/.minecraft/libraries/com/mojang/realms/1.10.16/realms-1.10.16.jar:/home/pi/.minecraft/libraries/org/apache/commons/commons-compress/1.8.1/commons-compress-1.8.1.jar:/home/pi/.minecraft/libraries/org/apache/httpcomponents/httpclient/4.3.3/httpclient-4.3.3.jar:/home/pi/.minecraft/libraries/commons-logging/commons-logging/1.1.3/commons-logging-1.1.3.jar:/home/pi/.minecraft/libraries/org/apache/httpcomponents/httpcore/4.3.2/httpcore-4.3.2.jar:/home/pi/.minecraft/libraries/it/unimi/dsi/fastutil/7.0.12_mojang/fastutil-7.0.12_mojang.jar:/home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-api/2.0-beta9/log4j-api-2.0-beta9.jar:/home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-core/2.0-beta9/log4j-core-2.0-beta9.jar:/home/pi/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl/2.9.4-nightly-20150209/lwjgl-2.9.4-nightly-20150209.jar:/home/pi/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl_util/2.9.4-nightly-20150209/lwjgl_util-2.9.4-nightly-20150209.jar:/home/pi/.minecraft/versions/1.11.2/1.11.2.jar net.minecraft.client.main.Main --username “Player” --version 1.11.2 --gameDir /home/pi/.minecraft--assetsDir /home/pi/.minecraft/assets --assetIndex 1.11 --uuid null --accessToken  “”

This should work assuming your natives are in Minecraft/Natives ( surely the case ).
Note that it start in offline mode, it will make it online tomorrow, I need my pi...
Posts: 16
Joined: Sat Jun 10, 2017 10:07 pm
by Xcom6000 » Sun Jun 11, 2017 12:41 am
What version of the operative system and format should I use? could that have any impact? Is it possible that RPi2B cant handle the 1.11.2 version?
Posts: 16
Joined: Sat Jun 10, 2017 12:42 am
by Aang » Sun Jun 11, 2017 12:52 am
I ran in without problem, with the last Raspbian, so it can.
Yes the system can cause trouble, but the last version just work fine...
The problem you have come from an error in run.sh, a change between 1.8.9 and 1.11.2
Posts: 16
Joined: Sat Jun 10, 2017 10:07 pm
by xXRoboBoyXx » Sun Jun 11, 2017 3:58 pm
Anyone got 1.12 working yet? Im guessing that when 1.12 optifine comes out i can just change the optifine run script
Posts: 32
Joined: Sat Feb 04, 2017 3:22 pm
by Aang » Sun Jun 11, 2017 4:24 pm
I have not tried yet, I focus on mods...
But it is surely possible.
Posts: 16
Joined: Sat Jun 10, 2017 10:07 pm
by Xcom6000 » Sun Jun 11, 2017 11:10 pm
Aang could you please post the run.sh that you have. I could try figure out what differs from the version I have and find a fix. Or if its possible to help find a solution for the vanilla version of 1.11.2.
Posts: 16
Joined: Sat Jun 10, 2017 12:42 am
by Xcom6000 » Mon Jun 12, 2017 6:37 am
When attempting to login to a server causes this crash.

Code: Select all
[06:32:01] [Client thread/FATAL]: Error executing task
java.util.concurrent.ExecutionException: java.lang.NullPointerException
   at java.util.concurrent.FutureTask.report(FutureTask.java:122) ~[?:1.8.0_65]
   at java.util.concurrent.FutureTask.get(FutureTask.java:192) ~[?:1.8.0_65]
   at h.a(SourceFile:47) [1.11.2.jar:?]
   at bes.av(SourceFile:962) [1.11.2.jar:?]
   at bes.a(SourceFile:398) [1.11.2.jar:?]
   at net.minecraft.client.main.Main.main(SourceFile:124) [1.11.2.jar:?]
Caused by: java.lang.NullPointerException
   at bno.a(SourceFile:795) ~[1.11.2.jar:?]
   at id.a(SourceFile:41) ~[1.11.2.jar:?]
   at id.a(SourceFile:8) ~[1.11.2.jar:?]
   at fo$1.run(SourceFile:13) ~[1.11.2.jar:?]
   at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) ~[?:1.8.0_65]
   at java.util.concurrent.FutureTask.run(FutureTask.java:266) ~[?:1.8.0_65]
   at h.a(SourceFile:46) ~[1.11.2.jar:?]
   ... 3 more


I even attempted to search for the missing file fastutil that the error logs reads as missing. Nothing useful was found through google. Is it possible that I don't have the correct version of java or some other update that I don't have?
Posts: 16
Joined: Sat Jun 10, 2017 12:42 am
by Aang » Mon Jun 12, 2017 6:48 am
This is the same issue... I will post my 1.11.2 run.sh in a few hours.
Posts: 16
Joined: Sat Jun 10, 2017 10:07 pm
by Aang » Mon Jun 12, 2017 9:01 am
I made a working run.sh for 1.11.2.
https://www.dropbox.com/s/a16xnk1do36bm ... .2.sh?dl=1
I will write one for 1.12
Posts: 16
Joined: Sat Jun 10, 2017 10:07 pm
by Xcom6000 » Mon Jun 12, 2017 11:19 am
Thank you so much for the run.sh. I used it to attempt to login to the game. Either Pi2 isn't enough to run the game or somethings still wrong. The game doesn't run on the pi at all. Crashes the second the world finishes loading.
Posts: 16
Joined: Sat Jun 10, 2017 12:42 am
by Aang » Mon Jun 12, 2017 1:38 pm
I run it on my pi2 in 1.10.2 with 35 mods... And 23 in 1.11.2. So this is not the problem, try making a new blank SD card or « sudo apt update && sudo apt upgrade -y » your current, OpenGL has updates.
Posts: 16
Joined: Sat Jun 10, 2017 10:07 pm