RaspiBasti
Posts: 2
Joined: Wed Mar 20, 2019 3:22 pm

Re: How to setup Minecraft 1.8.9 on RaspPi2

Thu Mar 21, 2019 9:00 pm

Sindybad wrote:
Tue Mar 01, 2016 8:31 pm
I have worked out how to install the OptiFine mod :D
Runs on average at a good 20 frames per second :o


How to install the OptiFine mod for better performance:
Assuming you have completed the tutorial above(and installed Minecraft 1.8.9):

Go to http://optifine.net/downloads
And download “OptiFine 1.8.9 HD U H3”

Go to your downloads

Code: Select all

cd ~/Downloads
And run optifine installer

Code: Select all

java -jar OptiFine_1.8.9_HD_U_H3.jar
Click install.

Now launch Minecraft

Code: Select all

cd ~/Minecraft
java -jar Minecraft.jar
Select the OptiFine profile and click play. The launcher will crash

Install asm:

Code: Select all

cd ~/Minecraft
mkdir Libraries
cd Libraries
Download asm-5.0.4-bin.zip from http://forge.ow2.org/project/showfiles. ... se_id=5660
Move it to the Libraries folder

Code: Select all

cd ~/Minecraft/Libraries
mv ~/Downloads/asm-5.0.4-bin.zip .
Unzip it

Code: Select all

unzip asm-5.0.4-bin.zip

Now download my updated run.sh:

Code: Select all

cd ~/Minecraft
wget https://www.dropbox.com/s/0r5trow18vi5vls/runOptifine.sh?dl=1 -O runOptifine.sh
Fill runOptifine.sh with your Minecraft login details
Edit MINECRAFT_LOGIN, MINECRAFT_USERNAME, MINECRAFT_PASSWORD and MINECRAFT_UUID:

Code: Select all

nano runOptifine.sh
Change permissions of file:

Code: Select all

chmod 700 runOptifine.sh
Now run it:

Code: Select all

./runOptifine.sh
When Minecraft has launched, turn everything down to low in the video settings (and turn on things like fast math)
Close Minecraft(It might crash if you open a world now)
And relaunch it:

Code: Select all

./runOptifine.sh

Thanks for reading!
P.S. rpiMike, you can include this in the original post if you want
I have two problems with it:

First: There is no "OptiFine_1.8.9_HD_U_H3.jar" just a "OptiFine_1.8.9_HD_U_I3.jar" but it doesnt work either.

Second: (I tried almost all 1.8.9 OptiFine jar's) When i run "runOptifine.sh" it gives me this error:

Code: Select all

Error: Could not find or load main class net.minecraft.launchwrapper.Launch
So, i looked into the .sh file, but net.minecraft.launchwrapper.Launch is in it. I don't know how to fix this.

User avatar
rpiMike
Posts: 753
Joined: Fri Aug 10, 2012 12:38 pm
Location: Cumbria, UK

Re: How to setup Minecraft 1.8.9 on RaspPi2

Fri Mar 22, 2019 3:22 pm

The very last paragraph of the 1.12.1 tutorial describes how to create a new classpath (cp=)
If you want to attempt getting a new version of Minecraft working :

1 Install required version using java -jar Minecraft.jar - and allow to crash
2 Scroll up in terminal window and find last ../jre/bin/java command, scroll across and find ‘-cp ’, copy this path list until ‘ net.minecraft.launchwrapper.Launch’
3 Paste this text into the cp= in the run.sh script

Gess1t
Posts: 16
Joined: Tue Oct 02, 2018 8:24 pm

Re: How to setup Minecraft 1.8.9 on RaspPi2

Fri Mar 22, 2019 11:45 pm

First, https://occycraft.blogspot.com/2016/02/ ... todos.html, there is apparently a version of optifine available, but i don't know if it's safe.

If you don't want to take risk,
Try replacing the content of your runoptifine.sh with this : https://pastebin.com/UhmaJ71K while keeping your optifine version which was 1.8.9 I3
don't forget to set your infos, email / username (it won't run without it, even if the launcher doesn't use it) / password.

btw, move optifine to the desktop to avoid permissions issues. Cause if you sudo when launching the optifine installer, then it will install in the root folder, or you will need to setup the permissions again manually + if you don't do this, and you try to sudo ./runoptifine.sh, then it won't work.

If this doesn't work, then re-download Minecraft 1.8.9 vanilla via the launcher and repeat all the steps again.

masterwhos
Posts: 1
Joined: Thu Mar 28, 2019 7:08 pm

Re: How to setup Minecraft 1.8.9 on RaspPi2

Thu Mar 28, 2019 7:16 pm

This is how you fixx "unsatisfied link" error so copy this into your run.sh but edit "email,name,password" to your minecraft login :D btw im postinng this on a pi 3 model b+ on chromium it lags
#!/bin/sh
#
# script to run minecraft on ARM linux. for reference:
#
# http://rogerallen.github.io/jetson/2014 ... etson-tk1/
# https://devtalk.nvidia.com/default/topi ... etson-tk1/
# https://gist.github.com/rogerallen/91526c9c8be1a82881e0
#

# !!! YOU MUST PERSONALIZE ALL OF THIS INFO !!!
# your personal login/password. chmod 700 to keep this private
MINECRAFT_LOGIN="email"
MINECRAFT_USERNAME="name"
MINECRAFT_PASSWORD="password"
# where did you store the native liblwjgl.so and libopenal.so?
MINECRAFT_NATIVE_PATH=~/Minecraft/Natives
# info from initial run data in .minecraft/launcher_profiles.json
MINECRAFT_CLIENTTOKEN=b61fb8e9-97bf-435f-8354-1feaba0ce734
MINECRAFT_UUID=12345678-1234-1234-1234-123456789abc
MINECRAFT_VERSION=1.8

# SHOULD NOT NEED TO EDIT BELOW THIS LINE

# long list of paths from the minecraft logged commandline
CP=/home/pi/.minecraft/libraries/oshi-project/oshi-core/1.1/oshi-core-1.1.jar:/home/pi/.minecraft/libraries/net/java/dev/jna/jna/3.4.0/jna-3.4.0.jar:/home/pi/.minecraft/libraries/net/java/dev/jna/platform/3.4.0/platform-3.4.0.jar:/home/pi/.minecraft/libraries/com/ibm/icu/icu4j-core-mojang/51.2/icu4j-core-mojang-51.2.jar:/home/pi/.minecraft/libraries/net/sf/jopt-simple/jopt-simple/4.6/jopt-simple-4.6.jar:/home/pi/.minecraft/libraries/com/paulscode/codecjorbis/20101023/codecjorbis-20101023.jar:/home/pi/.minecraft/libraries/com/paulscode/codecwav/20101023/codecwav-20101023.jar:/home/pi/.minecraft/libraries/com/paulscode/libraryjavasound/20101123/libraryjavasound-20101123.jar:/home/pi/.minecraft/libraries/com/paulscode/librarylwjglopenal/20100824/librarylwjglopenal-20100824.jar:/home/pi/.minecraft/libraries/com/paulscode/soundsystem/20120107/soundsystem-20120107.jar:/home/pi/.minecraft/libraries/io/netty/netty-all/4.0.23.Final/netty-all-4.0.23.Final.jar:/home/pi/.minecraft/libraries/com/google/guava/guava/17.0/guava-17.0.jar:/home/pi/.minecraft/libraries/org/apache/commons/commons-lang3/3.3.2/commons-lang3-3.3.2.jar:/home/pi/.minecraft/libraries/commons-io/commons-io/2.4/commons-io-2.4.jar:/home/pi/.minecraft/libraries/commons-codec/commons-codec/1.9/commons-codec-1.9.jar:/home/pi/.minecraft/libraries/net/java/jinput/jinput/2.0.5/jinput-2.0.5.jar:/home/pi/.minecraft/libraries/net/java/jutils/jutils/1.0.0/jutils-1.0.0.jar:/home/pi/.minecraft/libraries/com/google/code/gson/gson/2.2.4/gson-2.2.4.jar:/home/pi/.minecraft/libraries/com/mojang/authlib/1.5.21/authlib-1.5.21.jar:/home/pi/.minecraft/libraries/com/mojang/realms/1.7.59/realms-1.7.59.jar:/home/pi/.minecraft/libraries/org/apache/commons/commons-compress/1.8.1/commons-compress-1.8.1.jar:/home/pi/.minecraft/libraries/org/apache/httpcomponents/httpclient/4.3.3/httpclient-4.3.3.jar:/home/pi/.minecraft/libraries/commons-logging/commons-logging/1.1.3/commons-logging-1.1.3.jar:/home/pi/.minecraft/libraries/org/apache/httpcomponents/httpcore/4.3.2/httpcore-4.3.2.jar:/home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-api/2.0-beta9/log4j-api-2.0-beta9.jar:/home/pi/.minecraft/libraries/org/apache/logging/log4j/log4j-core/2.0-beta9/log4j-core-2.0-beta9.jar:/home/pi/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl/2.9.4-nightly-20150209/lwjgl-2.9.4-nightly-20150209.jar:/home/pi/.minecraft/libraries/org/lwjgl/lwjgl/lwjgl_util/2.9.4-nightly-20150209/lwjgl_util-2.9.4-nightly-20150209.jar:/home/pi/.minecraft/libraries/tv/twitch/twitch/6.5/twitch-6.5.jar:/home/pi/.minecraft/versions/1.8.9/1.8.9.jar

# thanks to xRoyx on the nvidia dev forums for this update.
# the authtoken changes daily, so we need to login to authenticate
MINECRAFT_ATOKEN="$(\
curl -i \
-H "Accept:application/json" \
-H "content-Type:application/json" \
https://authserver.mojang.com/authenticate \
-X POST \
--data '{"agent": {"name": "Minecraft","version": 1}, "username": "'$MINECRAFT_LOGIN'", "password": "'$MINECRAFT_PASSWORD'", "clientToken": "'$MINECRAFT_CLIENTTOKEN'" }' \
| sed '/accessToken":"/!d;s//&\n/;s/.*\n//;:a;/",/bb;$!{n;ba};:b;s//\n&/;P;D' \
)"
# '

echo "todays access token = "$MINECRAFT_ATOKEN

# run minecraft with all the right commandline options
/usr/lib/jvm/jdk-8-oracle-arm32-vfp-hflt/jre/bin/java \
-Xmn128M -Xmx1024M \
-XX:+UseConcMarkSweepGC \
-XX:+CMSIncrementalMode \
-XX:-UseAdaptiveSizePolicy \
-Djava.library.path=$MINECRAFT_NATIVE_PATH \
-cp $CP \
net.minecraft.client.main.Main \
--username $MINECRAFT_USERNAME \
--accessToken "$MINECRAFT_ATOKEN" \
--uuid "$MINECRAFT_UUID" \
--version $MINECRAFT_VERSION \
--userProperties {} \
--gameDir ~/.minecraft \
--assetsDir ~/.minecraft/assets \
--assetIndex $MINECRAFT_VERSION

Blackhawk_135
Posts: 1
Joined: Sun May 05, 2019 6:30 am

Re: How to setup Minecraft 1.8.9 on RaspPi2

Sun May 05, 2019 6:43 am

Hi there, while your tutorial does work for the versions you have specified, I have founs that minecraft 1.7.10 won't work in any way, I have followed both of the tutorials and only following the 1.8.9 guide does minecraft 1.7.10 start, just to crash whenever I create a world, and I tried to join a friend's server but it won't detect it.
I have tried everything and I can't seem to get it to work properly.
Could you do a guide for this version specifically?
Or maybe you could install 1.7.10 version following your guide to see if it works for you.
Thanks

Return to “Gaming”