leiptrstormr
Posts: 60
Joined: Mon May 18, 2015 12:33 pm

RetroPie mame4all controls not working

Thu Jul 09, 2015 5:18 am

I've downloaded the RetroPie RPi2 v3 beta 4 image, flashed my micro SD card and set up controls for my Hori EX2 arcade stick. Every other emulator works great using the /opt/retropie/configs/all/retroarch.cfg input settings, but when I try to play a game using mame4all the controls are non responsive. I would assume this is using lr-mame4all emulator, but I'm not sure where to look to verify. I can't even use Start + Select to exit the games which all appear to be working fine otherwise. I have to remote login and killall -9 mame to regain control. I would be grateful for any tips to get this working properly.

leiptrstormr
Posts: 60
Joined: Mon May 18, 2015 12:33 pm

Re: RetroPie mame4all controls not working

Thu Jul 09, 2015 6:07 am

Never mind I figured it out. Change default="mame4all" to default="lr-imame4all"
/opt/retropie/configs/mame-mame4all/emulators.cfg

cacophony555
Posts: 140
Joined: Sat Jan 18, 2014 5:54 pm

Re: RetroPie mame4all controls not working

Thu Jul 09, 2015 4:53 pm

You solved it by switching to the mame4all retroarch core. The standalone core has significantly better performance/framerate than the retroarch core so I'd suggest switching back. To set the controls in standalone you just need to plug a keyboard in and press TAB after a game has loaded. This will bring up the configuration menu.

darkenvy
Posts: 13
Joined: Fri Jan 17, 2014 11:59 pm

Re: RetroPie mame4all controls not working

Wed Dec 07, 2016 4:51 am

leiptrstormr, I love you. Thank you <3

cacophony555, I have read that on the wiki as well. That may be true, but the tab menu doesnt offer an option to quit the game via a gamepad. Sticking to the retro-controller (did I recall that name correctly?) works better for this project :\.

Thanks again guys! Love the internet!

Return to “Gaming”