User avatar
Wildern
Posts: 62
Joined: Wed Feb 10, 2021 12:38 pm
Location: Antarctica
Contact: Website

ATLauncher : Minecraft Launcher with Microsoft account support

Fri Mar 26, 2021 1:38 pm

ATLauncher : A launcher that runs minecraft on the Pi, with Forge + Fabric pre-installed, hundreds of mods to choose from and install with a click + Microsoft account support, I have to say I'm pretty amazed.

www.youtube.com/watch?v=wCY-IOLIGbM&t=44s for the youtube tutorial.

Easily install from https://atlauncher.com (download the .deb file and your set).

Once launched, select "Accounts" and sign in with your minecraft account.

Now, to install a version, go to "Vanilla Packs" and either select Vanilla Minecraft(minecraft with no mods), Minecraft with Forge(allows you to use mods) or Minecraft with Fabric(same as Forge). If you want to use Optifine with this I recommend using Forge.

Now after you've installed that, it's time for some code. Select instances, then the version you installed and then settings.

Go onto the Java Parameters and paste this code above where it says "-XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20" :

Code: Select all

For 32bit:

< 1.13 :

-Dorg.lwjgl.librarypath=/home/pi/lwjgl2arm32

= 1.13 :

-Dorg.lwjgl.librarypath=/home/pi/lwjgl3arm32

Code: Select all

For 64bit:

Replace the open jdk path with the oracle jdk path:

/opt/jdk/jdk1.8.0_251/bin/java

Add the following to the beginning of the arguments to specify lwjgl3 (if using a user other than 'pi' change accordingly):

= 1.13 :

-Dorg.lwjgl.librarypath=/home/pi/lwjgl3arm64
(Above : Extract from rpiMike's tutorial)



Go to the start of the G1NewSizePercent arg (its right after the lwjgl arg) press backspace, and then press space(otherwise you get a nasty error).

Finally, select Java Path and change it to

Code: Select all

/opt/jdk/jdk1.8.0_251/bin/java (32-bit)

Press save and Play! :D


Image
I’ll tell you a DNS joke but be advised, it could take up to 24 hours for everyone to get it.

https://discord.gg/GmzjdHxkgS

My friend finally came to the conclusion that Raspberry Pi's are small.
Read more...

FinnisAmerican
Posts: 2
Joined: Sat Mar 13, 2021 1:16 am

Re: ATLauncher : Minecraft Launcher with Microsoft account support

Fri May 07, 2021 4:10 am

It shows up with this error

Code: Select all

 Caused by: java.lang.RuntimeException: java.lang.UnsatisfiedLinkError: Failed to locate library: liblwjgl32.so
does anyone know how to fix this?

User avatar
Wildern
Posts: 62
Joined: Wed Feb 10, 2021 12:38 pm
Location: Antarctica
Contact: Website

Re: ATLauncher : Minecraft Launcher with Microsoft account support

Sat May 08, 2021 1:57 pm

FinnisAmerican wrote:
Fri May 07, 2021 4:10 am
It shows up with this error

Code: Select all

 Caused by: java.lang.RuntimeException: java.lang.UnsatisfiedLinkError: Failed to locate library: liblwjgl32.so
Hmm, does this happen when you try to run atlauncher, or launch an instance?


Maybe try this

Code: Select all

wget https://github.com/mikehooper/Minecraft/raw/main/lwjgl2arm32.tar.gz
wget https://github.com/mikehooper/Minecraft/raw/main/lwjgl3arm32.tar.gz
It installs the lwjgl args, maybe you didn't have that already?

Also, just in case try this to:

Code: Select all

sudo apt-get update
sudo apt-get install oracle-java8-installer
sudo apt-get install oracle-java8-set-default
It installs java8 which you will need for atlauncher.
I’ll tell you a DNS joke but be advised, it could take up to 24 hours for everyone to get it.

https://discord.gg/GmzjdHxkgS

My friend finally came to the conclusion that Raspberry Pi's are small.
Read more...

smulrine
Posts: 1
Joined: Fri May 28, 2021 5:17 pm

Re: ATLauncher : Minecraft Launcher with Microsoft account support

Fri Jun 11, 2021 3:41 pm

I have both Pixelmon and Pokehaan Craft working on an 8GB Pi 4 running 64-bit Raspberry Pi OS, using the Oracle 8 JDK which I downloaded and extracted manually. ATLauncher has a dependency on some Java component which the manual Oracle 8 JDK installation does not satisfy, and both of the aforementioned packs require Minecraft 1.12.2 and therefore the appropriate lwjgl library. Additionally, there was no sound at all due to another missing library. I believe the following would resolve all of these issues:
apt install openjdk-11-jre liblwjgl-java-jni libopenal-dev
Then ATLauncher can be installed. In Settings -> Java/Minecraft, set the Java path to your Oracle 8 JDK installation, and add -Dorg.lwjgl.librarypath=/usr/lib/jni to your Java parameters. I also had to disable the FoamFix and Treasure2 mods to get my Pokehaan Craft instance to load.


Last bumped by Wildern on Fri Jun 11, 2021 3:41 pm.

Return to “Gaming”