NES bluetooth gamepad setup difficulty

3 posts
by BigRodney » Tue Feb 28, 2017 1:00 am
I’m having difficulty getting my NES 8Bitdo SFC30 gamepad to work properly with my Pi3b running RetroPi. I followed instructions in a video I’ll post below. It pairs fine and I can set up the buttons just like on the video but when I try to use it it doesn’t work. It’s like it doesn’t save the gamepad setup. I repeat the process and it’s like the buttons were never set up. I ran thru is a dozen times I just can’t figure it out. What am I missing?

P.S. I set up two hard wired USB controllers just fine.

Posts: 16
Joined: Mon Feb 20, 2017 9:50 pm
by BigRodney » Mon Mar 20, 2017 8:23 pm
Anybody? I'm still at a standstill on this. The controller seems like it works after configuration, I can scroll thru the menus. A and B button work, start button works, all seems good until I pick a game and try to play it. When I pick a game the toggle works and the start button turns into the A button and none of the other buttons do anything. The Bluetooth keyboard works just fine, the button config stays and I can play the game fine from the keyboard.

I reformatted the SD card, reloaded everything from scratch but it’s still the same thing.

Posts: 16
Joined: Mon Feb 20, 2017 9:50 pm
by BigRodney » Tue Mar 21, 2017 4:31 am
So I may have figured out the problem. I was using a version of the Retropie with the filename “retropie-4.1-rpi2_rpi3.img”. I went back to the website where I got that version and found that there is a new version released on the 20th March 2017 with the filename retropie-4.2-rpi2_rpi3.img.

I downloaded the new version and mirrored the image onto my SD card and put the card in my Pi. It booted up fine and I configured the keyboard then pared the controller to the Pi via Bluetooth and configured the controller. After that I formatted my thumb drive and loaded the file structure from the new version on the Pi onto my thumb drive. Then I copied some games onto the thumb drive from my computer then installed them on the SD card in the Pi. Controller pared on its own and worked great, no more problems. I’m guessing there was some sort of problem with the previous OS version.

This is where I got both versions of the OS.

Hope this helps someone.
Posts: 16
Joined: Mon Feb 20, 2017 9:50 pm