el_miki
Posts: 5
Joined: Tue Jan 20, 2015 3:23 pm

Problema montando disco duro externo

Tue Jan 27, 2015 6:54 am

Hola, tengo un problemilla de montaje.

Antes tenía un disco duro de 500GB, con etiqueta jorge, alimentado y conectado a la pi por USB. Funcionaba perfecto, cuando lo encendía lo montaba en /media/jorge

El caso que es era muy viejuno y antes de que petase compré un disco nuevo de 2TB, al crearle la partición en ext4 le puse la etiqueta jorge, tambien, para que funcionase todo igual (mas que nada por las rutas de transmission), y le copié el contenido integro del disco viejo al nuevo.

Pues bien, aqui viene el problema, cuando lo enciendo, la pi me lo monta automáticamente en /media/jorge_ y claro ya tengo que andar conectandome por ssh y desmontando para montar en /media/jorge si quiero que el transmission siga con lo suyo.

Como puedo solucionar esto para que lo monte directamente en /media/jorge ???

Muchas gracias.

User avatar
freesoul
Posts: 72
Joined: Thu Jun 12, 2014 1:29 pm
Location: Spain

Re: Problema montando disco duro externo

Tue Jan 27, 2015 12:55 pm

el_miki wrote:Hola, tengo un problemilla de montaje.

Antes tenía un disco duro de 500GB, con etiqueta jorge, alimentado y conectado a la pi por USB. Funcionaba perfecto, cuando lo encendía lo montaba en /media/jorge

El caso que es era muy viejuno y antes de que petase compré un disco nuevo de 2TB, al crearle la partición en ext4 le puse la etiqueta jorge, tambien, para que funcionase todo igual (mas que nada por las rutas de transmission), y le copié el contenido integro del disco viejo al nuevo.

Pues bien, aqui viene el problema, cuando lo enciendo, la pi me lo monta automáticamente en /media/jorge_ y claro ya tengo que andar conectandome por ssh y desmontando para montar en /media/jorge si quiero que el transmission siga con lo suyo.

Como puedo solucionar esto para que lo monte directamente en /media/jorge ???

Muchas gracias.
Tendrías que comprobar varias cosas:

1) Que tienes los permisos adecuados de lectura y escritura en el nuevo disco duro. Ejemplo:

Code: Select all

sudo chmod 775 /media/jorge
2) Pega aquí lo que tienes en el archivo /etc/fstab. Ejecuta esta orden:

Code: Select all

cat /etc/fstab
3) La cosa que creo que te puede pasar, es que no tienes bien definido el uuid en el fstab, por lo que luego te monta la ruta que el quiere, cuando no es así.

4) Para ello, identifica cuál es tu ruta de tu disco duro con:

Code: Select all

df -h
5) Y luego mediante el comando:

Code: Select all

ls -l /dev/disk/by-uuid/
6) Finalmente, tendrías que editar el fichero etc/fstab (sudo nano /etc/fstab) y tener algo de este estilo:

Code: Select all

UUID="b1a3-4411b9376214...etc"       /media/jorge  ext4    defaults,noatime  0       0 
Guardar, y reiniciar probando que cuando arranca, te coge bien la ruta y todo.

A mi me pasa a veces que cuando desmonto el disco duro sin apagar la raspberry, al volver a conectarlo al hub-usb, me automonta la ruta con "guion_bajo" como a ti (/media/mi-ruta_). Lo que hago es que mediante terminal desmonto:

Code: Select all

sudo umount /dev/sdb2

Code: Select all

sudo mount /dev/sdb2 /media/mi-ruta/
(importante poner "/" al final de /media/mi-ruta/, porque no es lo mismo un directorio relativo que absoluto en linux). Sé que es un coñazo esto último, pero no sé por qué pero raspbmc me lo automonta como quiere sin respetarme la ruta aún bien definida en el fstab... pero como bien he dicho, es un problema muy muy leve y que sé solucionar fácilmente.

A ver si con estas pautas puedes solucionarlo :)

Saludos!!!

el_miki
Posts: 5
Joined: Tue Jan 20, 2015 3:23 pm

Re: Problema montando disco duro externo

Tue Jan 27, 2015 9:08 pm

Hola,

La solución que me planteas es configurar a mano el disco duro en el fstab, como si fuese un disco interno.

Claro, ahora mismo mi disco usb no aparece en el fstab, supongo que es normal, es un disco externo, no?

Si lo pongo en el fstab, que pasaría cuando arranque la pi sin conectar el disco externo?

Muchas gracias.

Cefiro
Posts: 127
Joined: Tue Feb 26, 2013 4:14 pm

Re: Problema montando disco duro externo

Tue Jan 27, 2015 10:24 pm

Hola.
Claro, ahora mismo mi disco usb no aparece en el fstab, supongo que es normal, es un disco externo, no?
Sí. Lo de ponerlo en el fichero fstab es para que se monte automáticamente cada vez que conectes la Raspberry. Pero, si lo prefieres, puedes hacerlo manualmente con los comandos mount/umount en el momento que lo necesites.
Si lo pongo en el fstab, que pasaría cuando arranque la pi sin conectar el disco externo?
No pasará nada, simplemente no se podrá automontar al no estar conectado.

Saludos.
--------
Mi web sobre la RasPi: http://rpi.uroboros.es

User avatar
freesoul
Posts: 72
Joined: Thu Jun 12, 2014 1:29 pm
Location: Spain

Re: Problema montando disco duro externo

Tue Jan 27, 2015 10:30 pm

el_miki wrote:Hola, La solución que me planteas es configurar a mano el disco duro en el fstab, como si fuese un disco interno.
No, el fstab lo que hace es que cada vez que enciendas y arranques tu raspberry, te monte el disco duro asociado a ese uuid en la ruta que tu le digas (como te he explicado arriba)
el_miki wrote:Claro, ahora mismo mi disco usb no aparece en el fstab, supongo que es normal, es un disco externo, no?
Si no lo tienes y quieres que al encender la raspberry se automonte solo, entonces sigue los pasos que te puse en mi comentario anterior de más arriba.
el_miki wrote: Si lo pongo en el fstab, que pasaría cuando arranque la pi sin conectar el disco externo?

Muchas gracias.
Si por el contrario NO pones nada en el fstab y NO conectas ningun disco duro externo ni nada, el sistema operativo arrancará normal pero, obviamente, no te habrá automontado la ruta del disco duro ni nada (porque no está especificado en el fstab).

Si una vez encendido y funcionando tu sistema operativo en la raspberry, conectaras un disco duro, el sistema operativo, te puede asignar de forma aleatoria un punto de montaje (que puede ser diferente al que te gustaría tener a ti).

En ese caso, puedes controlar tu qué montar o qué no montar con "sudo mount /dev/sdb1 /media/jorge" o "sudo umount /dev/sdba1"

Saludos!

el_miki
Posts: 5
Joined: Tue Jan 20, 2015 3:23 pm

Re: Problema montando disco duro externo

Mon Feb 02, 2015 8:48 am

Hola, pues muchas gracias, lo he puesto en el fstab y va perfecto!

No lo había solucionado de esta manera porque pensaba que el fstab era para discos duros y dispositivos internos! No sabía que se podía utilizar también para externos!

Gracias.

Return to “Español”