Drivers Realtek Wifi USB


4 posts
by oscarvady » Mon Jun 16, 2014 10:02 am
Buenas a todos,

he comprado un adaptador WLAN 300 (CSL) para dar soporte WiFi que en principio, era compatible para la Raspberry Pi.

El identificador es el siguiente: (lsusb)
Code: Select all
pi@raspberrypi ¬ $ lsusb
Bus 001 Device 004: ID 0bda:8172 Realteck Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter


Lo que he hecho es instalar los drivers tal y como he leído aquí:
viewtopic.php?t=10484&p=117821
Code: Select all
sudo apt-get install firmware-realtek
wget http://www.element14.com/community/servlet/JiveServlet/download/44948-8-97488/r8712u_ko.zip
unzip r8712u_ko.zip
sudo cp -r lib /
sudo depmod


Al reiniciar puedo ver como el dispositivo es alimentado y carga bien los driver, o eso creo, aparece en (lsmod)
Code: Select all
    Module           Size    Used by
    r8712u     168165    0



Por otra parte en el fichero /etc/network/interfaces tengo la configuración de una red ad-hoc (WEP) con IP manual que funcionaba perfectamente con un USB WiFi Edimax, pero parece que no se asocia correctamente con este nuevo dispositivo. A veces, se asocia a la red (lo puedo ver en iwconfig) pero no llega a establecer la conexión, o a asignarle la IP, puedo ver el nombre de la red, pero sin dirección IP.

Que pensais que pueda ser? Estan mal instalados los drivers? Debo desinstalar los antiguos de Edimax? Este pincho realmente no sirve para ello?

Muchas gracias por vuestra ayuda
Oscar
Posts: 9
Joined: Mon Apr 07, 2014 8:49 am
by blamarpa » Mon Jun 16, 2014 9:25 pm
"A veces si..'.". Mmmmmm....
Si ejecutas:
sudo iwlist wlan0 scan
¿ves las redes que están a tu alcance?, puedes probar con los dos adaptadores y ver si hay diferencias significativas.
¿has probado con otra fuente de alimentación?
Posts: 447
Joined: Thu May 23, 2013 4:02 pm
Location: España
by blamarpa » Mon Jun 16, 2014 9:33 pm
En el foro italiano de raspberrypi he visto que un usuario tuvo un problema con un adaptador WiFi n300 y lo pudo solucionar siguiendo esta guía, a ver si hay suerte:
http://www.wickeddutch.com/2013/07/20/r ... i-adapter/
Jeje, curiosamente le fue de mucha ayuda lo que pudo encontrar en el foro italiano de ubuntu, el circulo se cierra y quien da, recibe.
Posts: 447
Joined: Thu May 23, 2013 4:02 pm
Location: España
by oscarvady » Tue Jun 17, 2014 8:39 am
Es curioso pero finalmente lo he conseguido, basta con resetear la interfaz de red una vez arracando el networking. Cada vez que enciendo la Pi debo hacer un

Code: Select all
sudo ifdown wlan0
sudo ifup wlan0


y funciona perfectamente. Asi que he creado un script sencillo que haga esto y lo he metido en el init.d para que lo haga al arrancar. No falla de momento :lol:

Gracias por la ayuda
Posts: 9
Joined: Mon Apr 07, 2014 8:49 am