cyttorak
Posts: 85
Joined: Wed Dec 26, 2012 10:34 pm

El sonido de fondo se oye más alto que el de las voces

Thu Oct 10, 2013 9:47 pm

Hola

Tengo un problema con el audio al reproducir pelis en la Rasberry Pi.
El sonido de fondo parece que se oye bien pero las voces se oyen muy muy bajo

Por ejemplo, estoy viendo un capitulo de IT crowd y solo oigo la sintonía y las risas enlatadas.

¿Como puedo arreglarlo?

raspberrypivictim
Posts: 30
Joined: Sun Jan 22, 2012 10:35 pm

Re: El sonido de fondo se oye más alto que el de las voces

Fri Oct 11, 2013 7:57 am

si te ocurre con los audios en 5.1, era un bug en el firmware/kernel. actualiza a la última versión la distribución que uses y debería de arreglarse.

cyttorak
Posts: 85
Joined: Wed Dec 26, 2012 10:34 pm

Re: El sonido de fondo se oye más alto que el de las voces

Fri Oct 11, 2013 9:12 am

lo actualice ayer y sigue igual

cyttorak
Posts: 85
Joined: Wed Dec 26, 2012 10:34 pm

Re: El sonido de fondo se oye más alto que el de las voces

Fri Oct 11, 2013 5:45 pm

Por si sirve de ayuda

Estoy usando este adaptador http://www.pccomponentes.com/cable_adap ... audio.html ya que mi monitor es VGA

También por si sirve de ayuda, los vídeos que estoy usando de prueba son:

Video codec omx-mpeg4 width 608 height 336 profile 15 fps 25.000000
Audio codec mp3 channels 2 samplerate 48000 bitspersample 16
,
Video codec omx-h264 width 1280 height 720 profile 100 fps 23.976025
Audio codec ac3 channels 6 samplerate 48000 bitspersample 16
y
Video codec omx-h264 width 1280 height 720 profile 100 fps 23.976025
Audio codec dca channels 6 samplerate 48000 bitspersample 16

He probado a reproducir tanto via:
omxplayer -r --align center -o hdmi "/home/pi/video.avi"
como via:
omxplayer -r --align center "/home/pi/video.avi"

Tanto con el cable del audio conectado al adaptador VGA-HDMI como a la salida analógica de la placa y nada.

De hecho, se oye mal con los altavoces enchufados al altavoz pero cuando lo enchufo a la salida analógica de la placa no se oye nada directamente.

cyttorak
Posts: 85
Joined: Wed Dec 26, 2012 10:34 pm

Re: El sonido de fondo se oye más alto que el de las voces

Fri Oct 11, 2013 8:28 pm

Nuevos avances:

He encontrado este manual http://www.raspberrypi-spy.co.uk/2013/0 ... ine-audio/
Si hago
amixer cset numid=3 1

Parece que obligo a que se use la salida analógica y efectivamente cuando hago
aplay police_s.wav
o
mpg321 bubbling_water_1.mp3

se oye por la analógica perfectamente, sin embargo cuando hago
omxplayer -r --align center "/home/pi/video.avi"
sigue sin oírse por la salida analógica

He probado a abrir el mismo vídeo desde el vlc y este si que me saca el sonido por la analógica y se oye bien, el problema es que el vlc no puede con la imagen y va a trompicones :_

Entonces...
o consigo que el omxplayer use la salida analógica
o consigo otro reproductor que si lo haga y no pete con la imagen

¿Ideas?

cyttorak
Posts: 85
Joined: Wed Dec 26, 2012 10:34 pm

Re: El sonido de fondo se oye más alto que el de las voces

Sun Oct 13, 2013 5:36 pm

solucionado

omxplayer -r --align center -o local "/home/pi/video.avi"

Pero aún así, si alguien sabe porque puede estar fallando la salida de audio del adaptador hdmi-vga que por favor lo diga.

Gracias.

Return to “Español”