Xoni
Posts: 2
Joined: Tue Jun 19, 2018 8:50 am

Apache funciona... pero no

Tue Jun 19, 2018 9:04 am

Saludos a [email protected], soy nuevo en esta comunidad y aprovecho para presentarme... soy Xoni :P
Poseo una raspberry pi 3 b+ la cual quiero usar como servidor web.
Instalo el servidor apache, lo veo desde el navegador de la raspberry y también desde los portátiles con windows.
El problema es cuando intento acceder al servidor desde cualquier smartphone con android... no hay manera, me sale que no puedo conectar, que no se puede establecer conexión con el servidor.
Comentar que los accesos los hago en local, via wifi, no saliendo a internet. También que le asigné una ip fija a la raspi.
Lo curioso es que en un portatil tengo un servidor apache y puedo acceder sin problemas a él desde cualquier smartphone android.

¿Alguna sugerencia?, si necesitais datos pedídmelos, gracias :)

User avatar
lmarmisa
Posts: 1164
Joined: Thu Feb 14, 2013 2:22 am
Location: Jávea, Spain

Re: Apache funciona... pero no

Tue Jun 19, 2018 7:32 pm

Tal como lo explicas, parece raro. Creo que el problema debe de estar en android y a lo mejor es algún detallito que se te pasa. Podrías indicar qué navegador usas en android y si estás intentando conectarte mediante la dirección IP de la RPi o con el hostname.local.

Comprueba también la IP local que tiene asignada tu android con Acerca de -> Estado -> Dirección IP. Esa dirección debería ser de la misma subred n (192.168.n.x) que la IP estática que asignaste a la RPi.

Xoni
Posts: 2
Joined: Tue Jun 19, 2018 8:50 am

Re: Apache funciona... pero no

Wed Jun 20, 2018 9:51 am

Hola lmarmisa, gracias por tu interés :)

Resulta que no había nada raro ni en la configuración del servidor ni en los móviles, el problema estaba en el router.
Tenía activado user isolation en la parte wifi y no se veian los dispositivos entre ellos.

La confusión era debida a que el portátil windows con apache está conectado por cable, no afectándole dicho user isolation, aunque a mí si que me afectó bastante jejeje.

Lo dicho, gracias por el interés, no se como irá el tema de cerrar hilos, pero por mi parte... resuelto.

Return to “Español”

Who is online

Users browsing this forum: No registered users and 2 guests