josemi777
Posts: 3
Joined: Wed Dec 28, 2016 9:25 am

403 Forbidden - RETO IMPOSIBLE

Tue Jul 04, 2017 3:38 pm

¡Hola a todos!

Posteo desde la más absoluta desesperación, llevo 8 horas seguidas intentado solucionar el problema y nada (ya he mirado en millones de foros en ingles, francés a incluso aleman), así que perdón por anticipado si sueno algo brusco con lo que vaya a decir.

Mi problema es que estaba intentando ejecutar unos comandos para usar los GPIO desde un archivo php que hace llamadas a la consola (con "shell_exec"), y me ha funcionado por fin, cuando he decidido variar la sentencia de php para la ejecución de esos comandos (he cambiado "shell_exec" por "exec"), se ha vuelto todo loco y el servidor web de raspbian ha comenzado a devolverme "403 Forbidden" en todos los archivos .php a los que intento acceder.

He probado a des-instalar e instalar por completo apache2 y php5, a configurar todos los archivos de todas la maneras posibles de "apache2.conf" (ya que no existe en este caso el httpd.conf), de lighttpd.conf, he cambiado mil y una veces todos los permisos de las carpetas y los archivos, he probado también todas las combinaciones posibles de los usuarios y grupos a los que pueden pertenecer dicho directorios y/o archivos, y NADA DE NADA. También cabe mencionar que el .htaccess no existe en el servidor web raspbian, o al menos esta desactivado por defecto (he intentado crearlo para dar permisos y nada).

¿Como soluciono el problema de "403 Forbidden" al intentar ejecutar archivos php? Ya no se que más hacer ni que más tocar... es imposible.

Saludos y muchas gracias de antemano, aunque solo sea por leeros este tocho jeje :lol:

User avatar
elmapache
Posts: 16
Joined: Fri Jul 21, 2017 2:51 pm

Re: 403 Forbidden - RETO IMPOSIBLE

Fri Jul 21, 2017 3:34 pm

Hola, ¿por qué no pruebas a usar Nginx en vez de Apache? es más eficiente y funciona perfectamente con PHP. Después de instalarlo con apt-get, para una configuración básica con PHP edita el archivo /etc/nginx/sites-enabled/default:

Code: Select all

server {
	listen 80 default_server;
	#listen [::]:80 default_server;

	root /var/www/html;
	server_name _;

	location / {
		# First attempt to serve request as file, then
		# as directory, then fall back to displaying a 404.
		try_files $uri $uri/ =404;
	}

	# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
	#
	location ~ \.php$ {
		include snippets/fastcgi-php.conf;

		# With php5-cgi alone:
		#fastcgi_pass 127.0.0.1:9000;
		# With php5-fpm:
		fastcgi_pass unix:/var/run/php5-fpm.sock;
	}
}


Luego recargas Nginx (con sudo systemctl reload nginx.service) y pon tus archivos en el directorio /var/www/html o en el que hayas especificado.
Placa: Raspberry Pi 3 Model B.
Sistema operativo: OpenBSD 6.2.

Return to “Español”