ImHarvol
Posts: 50
Joined: Sun Dec 11, 2016 9:19 pm
Location: Alicante, España/Spain
Contact: Website

Error despues de desmontar un USB

Sat Mar 04, 2017 11:37 am

Buenas, resulta que hoy iba a desmontar un USB, así que puse:

Code: Select all

sudo umount /media/G-USB/
Pero ponía que estaba siendo usado, así que pensé en apagar la raspberry pi 3, sacar el usb y volver a encenderla.
La apague mediante JDownloaer, en la interfaz de my jdownloader, desde donde controlo las descargas de la rpi, pone un botón de shutdown, y pensé en probarlo, y se apago como siempre. Saque el usb, desconecte y volvi a conectar el cable de la corriente de la rpi para que se encendiera, intente conectarme por ssh y no funcionaba, probé a apagarla varias veces (botonazo), y no funcionaba, probé a volver a insertar el pendrive (lo habia formateado), pero no funcionaba, ahora he probado a conectar la rpi a la television, y me sale esto:
Image
No se que debo hacer. El usb lo tenia montado así en /etc/fstab:

Code: Select all

/dev/sda1       /media/G-USB    vfat    defaults,uid=pi,gid=pi  0       0
No se si no funciona por apagarlo desde JDownloader, o por quitarle el USB. Me gustaría que volviese a la "normalidad", o al menos poder recuperar algunos archivos que tenia
Malditos DNS

User avatar
lmarmisa
Posts: 1267
Joined: Thu Feb 14, 2013 2:22 am
Location: Jávea, Spain

Re: Error despues de desmontar un USB

Sat Mar 04, 2017 3:55 pm

No he usado nunca jdownlader pero supongo que será una aplicación con interfaz gráfica.

¿Qué sistema operativo tienes instado?. ¿Raspbian?. ¿Raspbian con arranque desde NOOBS?.

El problema no se debe a la entrada del fichero fstab. Creo que se ha dañado la partición de arranque de la tarjeta uSD. Si tienes un ordenador con Windows podrías probar a reparar la partición FAT de arranque a ver si se soluciona el problema.

Return to “Español”