ctemes
Posts: 2
Joined: Tue Aug 14, 2012 8:38 pm

Raspi no arranca sin video

Tue Aug 14, 2012 8:44 pm

Hola, hace poco que estoy trabajando con la raspi, en estos momentos tengo la versión 2012-06-18-wheezy-beta y tengo un problema que es si no está conectado el video vía hdmi no me arranca o tarda casi 10 minutos en arrancar alguna solución?
Saludos

mistercasti
Posts: 34
Joined: Sun Aug 12, 2012 8:10 pm

Re: Raspi no arranca sin video

Tue Aug 14, 2012 8:53 pm

Solo por no tener el hdmi sin conectar?

Puedes dar más datos. Tarda en bootear el Raspbian o en arrancar?

ctemes
Posts: 2
Joined: Tue Aug 14, 2012 8:38 pm

Re: Raspi no arranca sin video

Tue Aug 14, 2012 9:13 pm

Gracias por contestar, posiblemente no me he expresado claramente. Si el hdmi no está conectado al monitor, algunas veces y tardando mucho, no bootea. Da la sensación que comienza el boot, parpadea el led verde, luego para, parpadea otra vez y luego se queda como muerto. Si lo desconectas de la tensión y esperas 5 o 6 minutos entonces el boot es correcto y el raspi arranca perfectamente. Si está conectado al monitor vía hdmi no falla nunca. Lo que quiero es que se esté ejecutando una app sin necesidad de monitor y si fallara la alimentación que booteara nuevamente.

mistercasti
Posts: 34
Joined: Sun Aug 12, 2012 8:10 pm

Re: Raspi no arranca sin video

Tue Aug 14, 2012 9:46 pm

Que raro. Voy a tratar de hacer unas pruebas.

Debería funcionar tal y como tu quieres. Si le llega electricidad, está encendido, y si no, apagado. No tiene interruptor ni pulsador de encendido.

mistercasti
Posts: 34
Joined: Sun Aug 12, 2012 8:10 pm

Re: Raspi no arranca sin video

Mon Aug 20, 2012 12:49 pm

Prueba con esta opción en el /boot/config.txt

hdmi_force_hotplug =1

Chuse
Posts: 5
Joined: Mon Aug 20, 2012 6:01 pm

Re: Raspi no arranca sin video

Mon Aug 20, 2012 6:03 pm

Estoy en la misma situación, aunque claro, como no puedo arracan la raspberry tampoco puedo modificar el fichero para que me reconozca el HDMI, ¿alguna idea?

mistercasti
Posts: 34
Joined: Sun Aug 12, 2012 8:10 pm

Re: Raspi no arranca sin video

Mon Aug 20, 2012 11:44 pm

Chuse wrote:Estoy en la misma situación, aunque claro, como no puedo arracan la raspberry tampoco puedo modificar el fichero para que me reconozca el HDMI, ¿alguna idea?
El fichero puedes modificarlo entrando a la Raspberry por ssh, o abriendo la SD desde Linux.

Si no sabes como hacer ninguna de las dos, dímelo.

Chuse
Posts: 5
Joined: Mon Aug 20, 2012 6:01 pm

Re: Raspi no arranca sin video

Tue Aug 21, 2012 5:27 am

Gracias. El problema es que conecto la raspi a la television por HDMI, le doy corriente y se encienden todas las luces, pero no llega señal a la television. Voy a volver a cargar una imagen en la tarjeta SD a ver si esta ahí el problema, pero por lo que estuve leyendo quizas el problema este en el parametro que necesite tocar...pero claro...los que no tenemos un linux instalado no podemos tocar ese parametro ni nos arraca, ¿sabeis de alguna otra forma para hacerlo?

Gracias

petisopoto
Posts: 4
Joined: Thu Nov 17, 2011 4:39 pm

Re: Raspi no arranca sin video

Tue Aug 21, 2012 9:25 am

Creo recordar que el /boot/config.txt está en una partición FAT32, por lo que debería ser posible modificarlo casi desde cualquier sistema.

mistercasti
Posts: 34
Joined: Sun Aug 12, 2012 8:10 pm

Re: Raspi no arranca sin video

Tue Aug 21, 2012 9:26 am

Tu solución es acceder por ssh. Para ello "solamente" tienes que saber la IP de tu Raspi.
¿Como?
Lo más sencillo es que accedas a la pantalla de configuración de tu router, y busques entre las opciones una que dirá: "DHCP Clients" Seguramente estará en "Status" o "Tools" . Ahí verás una que se llamará RaspberryPi. Te apuntas la ip.

Ahora tienes que bajarte esté ejecutable (no hay que instalarlo), para conectarte remotamente.
http://the.earth.li/~sgtatham/putty/lat ... /putty.exe

Una vez lo habras, en Host Address pones la ip del Raspberry y le das a Open.
Te pedirá un usuario: "pi" y un password: "raspberry".

Entonces solo tienes que escribir: "vi /boot/config.txt"
Pulsando la letra "i" podrás entrar en el modo edición, y te permitirá modificar el texto.
Cuando acabes, pulsas "escape" y escribes ":wq" para guardar y salir.
Otra vez en el bash, escribes "reboot" y ya está. En cuanto vuelva a arrancar, debería hacerlo bien.

He dado bastantes detalles porque veo que no te mueves mucho por el mundillo Unix. Si tienes más dudas, pregúntalas.

mistercasti
Posts: 34
Joined: Sun Aug 12, 2012 8:10 pm

Re: Raspi no arranca sin video

Tue Aug 21, 2012 9:27 am

petisopoto wrote:Creo recordar que el /boot/config.txt está en una partición FAT32, por lo que debería ser posible modificarlo casi desde cualquier sistema.
Vaya, muy cierto. Después de pegarme la explicación de como acceder...

Solamente tienes que meter la tarjeta de memoria en tu PC, y ahí te abrirá una partición de unos 56 Mb, donde tienes, entre otros, el config.txt.

Chuse
Posts: 5
Joined: Mon Aug 20, 2012 6:01 pm

Re: Raspi no arranca sin video

Tue Aug 21, 2012 11:56 am

Gracias a todos los que habeis respondido. Así da gusto aprender ...

He optado por la solución facil de modificar el fichero desde otro PC y efectivamente funciona y ha arracando :)

Lo dicho...gracias.

mistercasti
Posts: 34
Joined: Sun Aug 12, 2012 8:10 pm

Re: Raspi no arranca sin video

Tue Aug 21, 2012 12:26 pm

Bueno, me alegra saber que era esa opción.

User avatar
Madbaires
Posts: 3
Joined: Thu May 24, 2012 3:36 pm

Re: Raspi no arranca sin video

Wed Mar 06, 2013 11:29 pm

Gracias me acaban de salvar, me fallaba al reiniciar y nunca había sucedido...claro, antes usaba hdmi, ahora estoy jugando con un tv antiguo y fallaba :D

Return to “Español”