Rickytaun
Posts: 8
Joined: Mon Aug 06, 2012 7:30 pm

Re: Configurar el Pi para Transmission

Tue Aug 21, 2012 12:23 pm

Hola de nuevo, una pregunta, ¿es necesario una ip fija en el raspy para poder abrir el puerto 9091 en el router?.
Lo digo porque desde mi router Belkin, abro los puertos de entrada y privado (9091), con la ip del raspy y me dice que "la dirección ip wan no es válida". Esta última está asignada por dhcp por el router.

Por lo demás, yo también he reducido la velocidad de descarga del Transmission y me funciona perfectamente sin cortes.

Gracias y un saludo.

User avatar
rafaestevez
Posts: 98
Joined: Fri Aug 03, 2012 7:16 am

Re: Configurar el Pi para Transmission

Tue Aug 21, 2012 3:23 pm

iroal wrote:Confirmado, al menos en mi caso.

En cuanto llego a 11-12Mg de descarga el sistema se sigue cayendo.

Actualizaré el firmware a ver si mejora algo.

Yo actualizaría el firmware y el debian... creo que rpi-update no actualiza el debian (alguien lo puede confirmar)

damefrikis
Posts: 4
Joined: Thu Aug 02, 2012 1:56 pm

Re: Configurar el Pi para Transmission

Thu Aug 23, 2012 1:00 pm

Lo primero buenas a todos y gracias por el tiro, escondo mi problema...

Tengo un pendrive de 32Gbytes pinchado en el pi.
Si murió lo detecta, es de marca transcend y me marca los 32Gbytes como sda. Cuando ejecutó el comando de cfdisk me da un fatal error y de así sólo puedo dar entrar y salir.
He instalado la última imagen del so, pero nada. El pendrive lo he probado con unas partición de fat 32y con una de ext 4 hecha desde un ubuntu, mismo resultado y su la monto directamente me da un error de io y me dice que no se puede...

Alguna idea? Desesperado....

User avatar
rafaestevez
Posts: 98
Joined: Fri Aug 03, 2012 7:16 am

Re: Configurar el Pi para Transmission

Wed Aug 29, 2012 6:10 pm

Tengo problemas con el transmission. He conectado un disco duro en formato ntfs y al cabo del tiempo parece como que se corrompe y me da el siguiente mensaje de error en el transmission:
Input/output error (/media/datos/...)

Pensaba que el disco duro estaba mal pero he puesto otro con formato ext4 y me está dando estos errores al cabo de unos días. ¿a alguien le pasa algo parecido?

uukrul
Posts: 47
Joined: Mon Jun 25, 2012 10:27 am

Re: Configurar el Pi para Transmission

Thu Aug 30, 2012 6:04 am

A mí sólo me ha dado ese error cuando, al principio de trastear con transmission, arrancaba el raspberry y se me olvidaba montar el disco habiendo una cola de descargas previa. Obviamente el programa no encontraba los archivos descargados/ en proceso de descarga, y me tiraba ese error. Una vez que puse el montaje del disco automatico en el fstab no he vuelto a verlo.

User avatar
rafaestevez
Posts: 98
Joined: Fri Aug 03, 2012 7:16 am

Re: Configurar el Pi para Transmission

Thu Aug 30, 2012 9:27 am

Que has puesto en el archivo fstab?

Titogus
Posts: 18
Joined: Sun Aug 05, 2012 10:42 pm

Re: Configurar el Pi para Transmission

Fri Aug 31, 2012 12:58 pm

Confirmado, al menos en mi caso.

En cuanto llego a 11-12Mg de descarga el sistema se sigue cayendo.

Actualizaré el firmware a ver si mejora algo.
Yo lo tengo puesto en 8500 y se sigue cayendo lo pongo con la tortuga a 2000 y funciona bien :evil:
Yo actualizaría el firmware y el debian... creo que rpi-update no actualiza el debian (alguien lo puede confirmar)
¿Alguien puede confirmar si hay forma de actualizar que no sea desde el pincipio instalando todo de nuevo?
Con

Code: Select all

sudo aptitude update
sudo aptitude upgrade
actualiza muchas cosas pero no se si todo.
Gracias

User avatar
rafaestevez
Posts: 98
Joined: Fri Aug 03, 2012 7:16 am

Re: Configurar el Pi para Transmission

Sun Sep 02, 2012 6:21 pm

Ya estoy en casita... el error lo había visto desde mi movil. Estas son las trazas:

Code: Select all

Aug 27 06:40:57 raspberrypi kernel: [120910.050332] usb 1-1.3.3: USB disconnect, device number 6
Aug 27 06:40:57 raspberrypi kernel: [120910.054326] sd 0:0:0:0: [sda] Unhandled error code
Aug 27 06:40:57 raspberrypi kernel: [120910.054358] sd 0:0:0:0: [sda]  Result: hostbyte=0x01 driverbyte=0x00
Aug 27 06:40:57 raspberrypi kernel: [120910.054381] sd 0:0:0:0: [sda] CDB: cdb[0]=0x28: 28 00 1d b2 69 b6 00 00 01 00
Aug 27 06:40:57 raspberrypi kernel: [120910.054440] end_request: I/O error, dev sda, sector 498231734
Aug 27 06:40:58 raspberrypi kernel: [120910.593905] Buffer I/O error on device sda1, logical block 498229623
Aug 27 06:40:58 raspberrypi kernel: [120910.593930] lost page write due to I/O error on sda1
Aug 27 06:40:58 raspberrypi kernel: [120910.593959] Buffer I/O error on device sda1, logical block 498229624
Aug 27 06:40:58 raspberrypi kernel: [120910.593975] lost page write due to I/O error on sda1
Aug 27 06:40:58 raspberrypi kernel: [120910.594010] Buffer I/O error on device sda1, logical block 498229625
Aug 27 06:40:58 raspberrypi kernel: [120910.594026] lost page write due to I/O error on sda1
Aug 27 06:40:58 raspberrypi kernel: [120910.594047] Buffer I/O error on device sda1, logical block 498229626
Aug 27 06:40:58 raspberrypi kernel: [120910.594061] lost page write due to I/O error on sda1
Aug 27 06:40:58 raspberrypi kernel: [120910.594080] Buffer I/O error on device sda1, logical block 498229627
Aug 27 06:40:58 raspberrypi kernel: [120910.594094] lost page write due to I/O error on sda1
Aug 27 06:40:58 raspberrypi kernel: [120910.594126] Buffer I/O error on device sda1, logical block 498229628
Aug 27 06:40:58 raspberrypi kernel: [120910.594141] lost page write due to I/O error on sda1
Aug 27 06:40:58 raspberrypi kernel: [120910.594163] Buffer I/O error on device sda1, logical block 498229629
Aug 27 06:40:58 raspberrypi kernel: [120910.594177] lost page write due to I/O error on sda1
Aug 27 06:40:58 raspberrypi kernel: [120910.729548] FAT-fs (sda1): Directory bread(block 483232646) failed

linesguapo
Posts: 73
Joined: Fri Aug 31, 2012 8:42 am

cliente torrent en XBMC

Mon Sep 03, 2012 10:35 am

Aunque ya tengo abierto un hilo al respecto, como veo que sois mu expertos os lo pregunto aquí a ver que opináis:

me gustaría poder utilizar el cliente torrente en XBMC, ya se en RASPBMC o en OPENLEC, ya que es SO que uso por defecto en mi pi.

Imagino que los principios de funcionamiento tienen que ser los mismos, lo que he conseguido es descargar el cliente torrent desde el repsoitorio y luego hay que configurar unos parámetros de red pero hay es donde me pierdo.

a ver si alguien puede ayudarme.

amolina
Posts: 113
Joined: Wed Aug 01, 2012 4:06 am

Re: Configurar el Pi para Transmission

Mon Sep 03, 2012 12:59 pm

Para los que tienen problemas con los discos, ¿tienen energia propia o la sacan del raspberry?, si la sacan del raspberry, auqnue sea con el truco del diodo con puente, me sucede lo mismo, así que el problema va en relacion a los amperes que tiene disponible el pi para entregar y la suma del consumo de los usb + el consumo del procesador que puede variar segun la demanda de procesos que tenga.

lo mejor para eso es proveer de energia externa a los discos con un cable usb tipo Y y un cargador / transformador usb, lo que no se es si sirve cualquiera, pues los de celular suelen subir y bajar los amperes cada X segundos para que las baterias carguen mejor.

User avatar
rafaestevez
Posts: 98
Joined: Fri Aug 03, 2012 7:16 am

Re: Configurar el Pi para Transmission

Mon Sep 03, 2012 6:50 pm

Yo mañana os cuento... voy a utilizar el cable tipo Y.

User avatar
rafaestevez
Posts: 98
Joined: Fri Aug 03, 2012 7:16 am

Re: Configurar el Pi para Transmission

Wed Sep 05, 2012 12:56 pm

Confirmado con el cable en Y ya no tengo problemas con el disco duro en el transmission.

Serval
Posts: 5
Joined: Mon Jul 09, 2012 6:40 am

Re: Configurar el Pi para Transmission

Thu Sep 06, 2012 12:18 pm

Para el tema de transmission yo he seguido los pasos de esta url y me va sin problemas:
http://forum.xbmc.org/showthread.php?tid=61574

Para ejecutar los comandos me he conectado a la Rasberry Pi (en mi caso con Raspbmc) por SSH (putty desde Windows).

Espero que os ayude.

Un saludo!

User avatar
rafaestevez
Posts: 98
Joined: Fri Aug 03, 2012 7:16 am

Re: Configurar el Pi para Transmission

Fri Sep 07, 2012 11:02 am

Serval wrote:Para el tema de transmission yo he seguido los pasos de esta url y me va sin problemas:
http://forum.xbmc.org/showthread.php?tid=61574

Para ejecutar los comandos me he conectado a la Rasberry Pi (en mi caso con Raspbmc) por SSH (putty desde Windows).

Espero que os ayude.

Un saludo!
Yo lo tengo con el Raspbian no con el XBMC. ¿que tal va la reproducción con el transmission a la vez?

xicugros
Posts: 15
Joined: Fri Aug 03, 2012 8:05 am

Re: Configurar el Pi para Transmission

Tue Sep 11, 2012 9:02 pm

Hola a todos,.... la verdad es que me da verguenza poner este post,... por el NIVELAZO que hay,... pero todo tiene un principio (más que novato,... soy algo negado pero insisto),.... por lo que voy al grano

He conseguido (guau!!) poner ips fijas en casa 2 portatiles un phone, falta la rasp ... ¿como se pone una IP fija en la raspberry?

Virutas
Posts: 26
Joined: Wed Sep 12, 2012 6:51 am

Re: Configurar el Pi para Transmission

Wed Sep 12, 2012 7:29 pm

ricardforner wrote:
Yo es así como tengo mi RasPi (tambien con 32GB de SD), con el transmission y usando el script siguiente para mover los ficheros mediante rsync al servidor NAS de red.

Code: Select all

#!/bin/bash

if ls /home/dl/*.avi &> /dev/null; then
  echo "Moviendo ficheros al NAS"
  rsync -av --remove-source-files /home/dl/*.avi [email protected]naspc:/mnt/media/movies/ &
else
  echo "No hay ficheros a mover"
fi
Hola,

¿Qué hay que poner en el script para mover también directorios? Es que cada torrent crea una carpeta y no me las mueve.

Un saludo

lince18
Posts: 3
Joined: Wed Sep 12, 2012 9:01 pm

Re: Configurar el Pi para Transmission

Wed Sep 12, 2012 9:06 pm

Hola a todos,

A alguno os ha pasado que cuando iniciais una descarga os da el siguiente error: "Error: Unable to save resume file: No such file or directory"

Tengo configurada la descarga en un pendrive conectado al pi, y el directorio existe.....
¿Alguna ayuda?

Virutas
Posts: 26
Joined: Wed Sep 12, 2012 6:51 am

Re: Configurar el Pi para Transmission

Thu Sep 13, 2012 7:47 am

Añado el script que he configurado:

Code: Select all

#!/bin/bash

if ls /media/descargas/*.* &> /dev/null; then
  echo "Moviendo ficheros al PENDRIVE"
  rsync -av --remove-source-files /media/descargas/*.* /mnt/pendrive/ &
else
  echo "No hay ficheros a mover"
fi
Copia pero no mueve (es decir, no borrar de la carpeta /media/descargas/). ¿Qué está mal?

También quería saber si es posible poner alguna función que de forma automática chequee si el espacio libre en la SD es de menos de 200MB por ejemplo y que si se cumple la condición mueva todo al pendrive.

lince18 wrote: A alguno os ha pasado que cuando iniciais una descarga os da el siguiente error: "Error: Unable to save resume file: No such file or directory"
Revisa la configuración que has puesto en el transmission (como indica el tutorial). A mi me pasó lo mismo la primera vez y era por la config y porque no había montado el usb correctamente.

Un saludo

Serval
Posts: 5
Joined: Mon Jul 09, 2012 6:40 am

Re: Configurar el Pi para Transmission

Thu Sep 13, 2012 10:14 am

rafaestevez wrote:
Serval wrote:Para el tema de transmission yo he seguido los pasos de esta url y me va sin problemas:
http://forum.xbmc.org/showthread.php?tid=61574

Para ejecutar los comandos me he conectado a la Rasberry Pi (en mi caso con Raspbmc) por SSH (putty desde Windows).

Espero que os ayude.

Un saludo!
Yo lo tengo con el Raspbian no con el XBMC. ¿que tal va la reproducción con el transmission a la vez?
Si tengo varios archivos descargando en el Transmission, la reproducción se para de vez en cuando siendo molesto. No he tenido tiempo para ver si se puede optimizar o limitar de alguna forma el Transmission para intentar evitar las "pausas"

Serval
Posts: 5
Joined: Mon Jul 09, 2012 6:40 am

Re: Configurar el Pi para Transmission

Thu Sep 13, 2012 10:19 am

Virutas wrote:
ricardforner wrote:
Yo es así como tengo mi RasPi (tambien con 32GB de SD), con el transmission y usando el script siguiente para mover los ficheros mediante rsync al servidor NAS de red.

Code: Select all

#!/bin/bash

if ls /home/dl/*.avi &> /dev/null; then
  echo "Moviendo ficheros al NAS"
  rsync -av --remove-source-files /home/dl/*.avi [email protected]:/mnt/media/movies/ &
else
  echo "No hay ficheros a mover"
fi
Hola,

¿Qué hay que poner en el script para mover también directorios? Es que cada torrent crea una carpeta y no me las mueve.

Un saludo
Desde la ignorancia: ¿Por qué no descargáis directamente al NAS? Podéis montar la unidad NAS y descargar directamente al NAS, ¿no?

Virutas
Posts: 26
Joined: Wed Sep 12, 2012 6:51 am

Re: Configurar el Pi para Transmission

Thu Sep 13, 2012 10:33 am

Serval wrote: Desde la ignorancia: ¿Por qué no descargáis directamente al NAS? Podéis montar la unidad NAS y descargar directamente al NAS, ¿no?
Se supone que sí, pero he leido que se saturaba el PI traspasando al USB mientras se está descargando por el Ethernet. Y también porque si descargo directamente en el USB y quiero llevarmelo a otro lado, tengo que dejar de descargar; de la otra manera, puedo seguir descargando en la SD aunque no haya Pendrive USB.

lince18
Posts: 3
Joined: Wed Sep 12, 2012 9:01 pm

Re: Configurar el Pi para Transmission

Thu Sep 13, 2012 8:53 pm

No encuentro la forma de que me comience la descarga. La configuración la tengo igual que en el primer post, pero a mi, se me inicia la descarga y al rato para.
Busco un archivo .part y no encuentra ninguno, no se crea ningún archivo, ese creo que es el problema.

¿Alguna sugerencia?

Grancias a todos!!

uukrul
Posts: 47
Joined: Mon Jun 25, 2012 10:27 am

Re: Configurar el Pi para Transmission

Fri Sep 14, 2012 7:05 pm

¿Sabría alguien hacer un script que ejecutara lo siguiente:

-Cuando transmission esté descargando, que lo deje todo como está, a las velocidades de descarga/subida preconfiguradas;
-Cuando no haya tasa de descargas durante X tiempo, que mande parar el disco duro, independientemente de si hay subida

Gracias.

Agus
Posts: 10
Joined: Sun Sep 16, 2012 6:12 pm

Re: Configurar el Pi para Transmission

Sun Sep 16, 2012 6:50 pm

Buenas chicos como va eso. Soy nuevo por el foro, llevo apenas un tres días con la Raspberry en casa y como no, mi primer mensaje va a ser desgraciadamente para ver si me podéis resolver un problema que tengo. Tengo todo configurado exactamente como se recomienda en este hilo, pero transmission se cierra a los pocos minutos de poner a descargar un par de torrents.

He probado con diferentes torrents, usando puertos aleatorios, con o sin límites de bajadas y subidas y el resultado siempre es el mismo.

A ver si me podéis echar un cable.

Saludos!

User avatar
rafaestevez
Posts: 98
Joined: Fri Aug 03, 2012 7:16 am

Re: Configurar el Pi para Transmission

Mon Sep 17, 2012 6:57 am

Mi experiencia me dice que lo primero que tienes que mirar es como tienes la alimentación del dispositivo y del disco duro. ¿como lo tienes?

Return to “Español”