oskarino
Posts: 7
Joined: Sun Apr 05, 2015 7:43 pm

Problema con HDMI en raspberry pi 2

Sun Apr 05, 2015 7:55 pm

Buenas tardes, os cuento el problema que tengo.
Recibí mi raspberry 2 bien e instale raspbian con hdmi y todo correcto. Mirando foros vi que se podía enchufar mediante RCA a monitores antiguos la manera de hacerlo cambiando el cableado de de posicion. Hasta ahí lo hice segun el tutorial (solo cambiando el rca y perfecto, la raspberry se veía bien.

El problema ha sido volver a HDMI que ahora no me lo reconoce,
- he metido unas cuantas configuraciones que he visto en el foro cambiando el config.txt
- he vuelto a hacer con una nueva tarjeta un nuevo raspbian con mi raspberry b+ antigua y una vez instalado el S.O., viendose en hdmi perfecto, y meterlo ala raspi 2 y sigue sin ir.
-he probado a puentear el pin GPIO 1 y GND poniendo el hdmi_safe=1 en el config.txt para forzar el safe mode y nada.

Lo curioso del todo es que sigue viendose por RCA y funcionando bien, pero el problema es que esa televisión me está dando problemas y la voy a tener que sustituir así que parte gráfica no tendría.

Si alguno me puede ayudar se lo agradecería enormemente, ya se, para otra vez los experimentos con gaseosa :(
Saludos

User avatar
actkk2000
Posts: 1309
Joined: Wed Apr 02, 2014 3:22 am

Re: Problema con HDMI en raspberry pi 2

Mon Apr 06, 2015 1:00 pm

Me parece que vas a tener que grabar una imagen de cero que arranque directamente en la RPI2, tal y como lo hiciste la primera vez para ver si anda de nuevo el hdmi.

Slds!
Robot +Camara +Sensores +Encoder +Servo +Matriz8x8 +Joystick:
https://www.raspberrypi.org/forums/viewtopic.php?f=76&t=130470

oskarino
Posts: 7
Joined: Sun Apr 05, 2015 7:43 pm

Re: Problema con HDMI en raspberry pi 2

Tue Apr 07, 2015 7:38 pm

Nada, no ha habido forma, con RCA se me ve e instala bien pero el HDMI con tarjeta formateada no hace ni mención. Si no hay otra solución me parece que tendré que dejarlo en modo consola via SSH :(, alguna otra alternativa?

Uoho
Posts: 91
Joined: Tue Feb 25, 2014 2:53 pm

Re: Problema con HDMI en raspberry pi 2

Tue Apr 07, 2015 8:56 pm

Es una tontería pero ¿no será problema del cable hdmi? Si tienes otro a mano pruebalo, por descartar posibilidades...

pfvidal
Posts: 50
Joined: Mon Oct 29, 2012 4:00 pm

Re: Problema con HDMI en raspberry pi 2

Wed Apr 08, 2015 2:13 am

A ver por partes que el cansancio es muy malo.
No has posido ver NUNCA una tarjeta que se vea en la RBPI+ en la BPI2 ya que la arquitectura hardware es diferente!
Se ha sustituido el antreior chip BCM 2835 ARMv6 por un BCM 2836 ARMv7 Cortex con cuatro núcleos a 900MHz, es decir en un simil de coche,uno es diesel y el otro gasolina!
Así que el problema muy probablemente este enfocado bien, pero su solución... se pueda mejorar.
Yo te aconsejo, primero comprueba que el HDMI de la TV sigue funcionando. ¿hay veces que estas cosas pasan?
Despues graba de nuevo una versión de software especifica para la RBPI2 en tu SD y pruebala.
Y si así no la ves, cuelgamela en un Dropbox o similar y le echo un ojo... pero vamos te aseguro que este hardware es mas sencillo que el mecanismo de un pito comparado con un ordenador convencional, un movil o una tostadora moderna, asi que no te desesperes... y antes de ponerte a soldar en el GPIO... piensa que algo has "pasado por alto"... y casi seguro que aciertaras.
Un abrazo

ME CORRIJO: SI has actualizado la versión de sistema operativo de la RBPI+ si podrias verla en la RBPI2... pero para que arriesgarte a que tengas una libreria sin actualizar, o similar... en estas cosas lo mejor, es "bajar del cpche y volver a subier2 que dice el chiste.

oskarino
Posts: 7
Joined: Sun Apr 05, 2015 7:43 pm

Re: Problema con HDMI en raspberry pi 2

Thu Apr 09, 2015 3:37 pm

Gracias a todos por vuestras respuestas en primer lugar.
El cable como comentaba lo cambie por otro y lo mismo y con sistema cargado de raspberry b+ tampoco funciona y por el otro lado el hdmi lo he probado en los dos puertos que tiene el TV y tampoco, en cambio con la b+ es llegar y enchufar como dice pfvidal tiene que ser una chorrada pero no doy en el clavo.

User avatar
xoopha
Posts: 106
Joined: Mon Feb 09, 2015 9:52 pm

Re: Problema con HDMI en raspberry pi 2

Thu Apr 09, 2015 3:49 pm

En mi tele no funciona la Pi2B si hdmi_group=2, que es lo que da por defecto el parámetro hdmi_safe. Quizá pudieras probar con hdmi_group=1 y hdmi_mode=1 a ver si hay manera. :?:

oskarino
Posts: 7
Joined: Sun Apr 05, 2015 7:43 pm

Re: Problema con HDMI en raspberry pi 2

Fri Apr 10, 2015 8:19 pm

Gracias!, probaré y te cuento aunque este finde me voy fuera, pero prometo contestar, haber si entre todos damos con el problema

oskarino
Posts: 7
Joined: Sun Apr 05, 2015 7:43 pm

Re: Problema con HDMI en raspberry pi 2

Thu Apr 16, 2015 9:56 am

Nada perdona por la tardanza, tampoco me funciona esta configuracion, alguna solución mas para probar?

User avatar
xoopha
Posts: 106
Joined: Mon Feb 09, 2015 9:52 pm

Re: Problema con HDMI en raspberry pi 2

Thu Apr 16, 2015 11:50 am

Lo único que se me ocurre que es copies y pegues aquí en el foro el contenido de tu archivo /boot/config.txt a ver si damos con algún parámetro que esté fastidiando el tema. Si te funcionaba con HDMI y ahora no, algo tiene que haber cambiado y supongo que no será tener los dos cables conectados al mismo tiempo.

oskarino
Posts: 7
Joined: Sun Apr 05, 2015 7:43 pm

Re: Problema con HDMI en raspberry pi 2

Wed Apr 22, 2015 7:24 pm

Hola de nuevo y gracias por tus ideas, he colgado el código aqui http://ivpaste.com/v/7icyfHww creo que se puede ver mejor y si quieres copiarlo y probarlo se hace mejor que desde una foto. Lo que se ve con la almohadilla abajo tambien lo he probado quitando lo de NOOBS

User avatar
xoopha
Posts: 106
Joined: Mon Feb 09, 2015 9:52 pm

Re: Problema con HDMI en raspberry pi 2

Wed Apr 22, 2015 7:59 pm

Así a bote pronto no tienes nada extraño en el fichero.
Ya por ponernos esotéricos, supongo que no tienes el cable RCA también conectado cuando pruebas el HDMI ¿no? En serio, es que ya no sé qué puede estar pasando. :?

oskarino
Posts: 7
Joined: Sun Apr 05, 2015 7:43 pm

Re: Problema con HDMI en raspberry pi 2

Sat May 02, 2015 4:15 pm

Disculpa la tardanza pero venía este finde mi cuñado que es electronico y tampoco ha dado con el chiste, la cuestion es que probe tambien con poner los dos conectores pero nada, finalmente dejare el bichejo de daemon y mientras tanto haber si le pasa a alguien y sabe como hacerlo, la pena que tocara pillar una nueva para cuando le quiera hacer algo grafico y no sepa hacerlo en consola tirar de ella. Gracias por los intentos, esta vez cachis, no ha habido suerte.

Saludos

pachu
Posts: 34
Joined: Sat Feb 07, 2015 7:59 am

Re: Problema con HDMI en raspberry pi 2

Sun May 03, 2015 7:41 am

Yo formatearía la tarjeta y probaría hacer una instalación limpia de noobs 1.4,también puedes probar lo de pulsar el número 4 en el arranque.

Commando2009
Posts: 35
Joined: Wed Apr 29, 2015 10:56 pm
Location: Madrid

Re: Problema con HDMI en raspberry pi 2

Fri May 08, 2015 4:11 pm

Pregunta indiscreta.......
Que tienes instalado ,raspbian,raspbmc...o?
Si tienes mas de uno,lo has hecho con noobs o berryboot?

Con esos datos quiza podamos saber mas cosas y como erradicar tu problema....
Ten en cuenta que noobs tiene su propio config.txt,raspian el suyo berryboot el suyo,debes de cambiar todos y en todos comentar #sdtv=2 y descomentar los hdmi_safe,hdmi_group,etc,etc.....

Saludos

n3mes
Posts: 2
Joined: Tue Jan 17, 2017 1:33 pm

Re: Problema con HDMI en raspberry pi 2

Tue Jan 17, 2017 2:32 pm

oskarino wrote:Buenas tardes, os cuento el problema que tengo.
Recibí mi raspberry 2 bien e instale raspbian con hdmi y todo correcto. Mirando foros vi que se podía enchufar mediante RCA a monitores antiguos la manera de hacerlo cambiando el cableado de de posicion. Hasta ahí lo hice segun el tutorial (solo cambiando el rca y perfecto, la raspberry se veía bien.

El problema ha sido volver a HDMI que ahora no me lo reconoce,
- he metido unas cuantas configuraciones que he visto en el foro cambiando el config.txt
- he vuelto a hacer con una nueva tarjeta un nuevo raspbian con mi raspberry b+ antigua y una vez instalado el S.O., viendose en hdmi perfecto, y meterlo ala raspi 2 y sigue sin ir.
-he probado a puentear el pin GPIO 1 y GND poniendo el hdmi_safe=1 en el config.txt para forzar el safe mode y nada.

Lo curioso del todo es que sigue viendose por RCA y funcionando bien, pero el problema es que esa televisión me está dando problemas y la voy a tener que sustituir así que parte gráfica no tendría.

Si alguno me puede ayudar se lo agradecería enormemente, ya se, para otra vez los experimentos con gaseosa :(
Saludos




buenas, conseguiste arreglar tu problema.? me pasa exactamente lo mismo que no da señales de salida de video por HDMI de repente...

Return to “Español”