mariano.castellano
Posts: 13
Joined: Mon Feb 23, 2015 12:02 pm

WiFi en RPI

Sat Mar 21, 2015 10:36 pm

Hola muchachos!!

Bueno, despues de tantos idas y vueltas con internet por cable ethernet, decidi tener acceso a internet a traves de un adaptador wifi (TP-Link TL-WN823N), que segun tengo entendido la raspi lo soporta nativamente.

Pero tengo unos problemas con la cofiguracion, al conectar el adaptador la raspi me lo detecta:

Code: Select all

pi@raspberrypi ~ $ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
[b]Bus 001 Device 004: ID 0bda:8178 Realtek Semiconductor Corp. RTL8192CU 802.11n WLAN Adapter
[/b]Bus 001 Device 005: ID 03f0:0862 Hewlett-Packard 
Bus 001 Device 006: ID 0458:003a KYE Systems Corp. (Mouse Systems) NetScroll+ Mini Traveler / Genius NetScroll 120
Y la configuracion de las interfaces esta asi:

Code: Select all

auto lo
iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
wpa-essid "XXXXX"
wpa-psk "ZZZZZZZZ"
Pero al corroborar la conexion me aparece lo siguiente:

Code: Select all

pi@raspberrypi ~ $ iwconfig
wlan0     unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

eth0      no wireless extensions.
Y cuando quiero habilitar el wlan0 aparece esto:

Code: Select all

pi@raspberrypi ~ $ sudo ifup wlan0 
ioctl[SIOCSIWAP]: Operation not permitted
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/wlan0/64:66:b3:22:9f:64
Sending on   LPF/wlan0/64:66:b3:22:9f:64
Sending on   Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
Ya probe con el archivo wpa_supplicant pero no funciono tampoco. Segun lei, tendria que funcionar igual metiendo los parametros de la conexion wifi en el archivo de interfaces.

Espero que me puedan ayudar, saludos!!

Cefiro
Posts: 126
Joined: Tue Feb 26, 2013 4:14 pm

Re: WiFi en RPI

Wed Mar 25, 2015 8:26 am

mariano.castellano wrote:Bueno, despues de tantos idas y vueltas con internet por cable ethernet, decidi tener acceso a internet a traves de un adaptador wifi (TP-Link TL-WN823N), que segun tengo entendido la raspi lo soporta nativamente.

Y la configuracion de las interfaces esta asi:

Code: Select all

auto lo
iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0
iface wlan0 inet dhcp
wpa-essid "XXXXX"
wpa-psk "ZZZZZZZZ"
Dos cosas: en la configuración de las interfaces, quita o comenta la tercera línea ("iface eth0 inet dhcp") o bien cambia "dhcp" por "static" y asígnale una IP estática a eth0. Que yo sepa, no puede haber dos interfaces de red con DHCP. Segundo, comprueba si es "wpa-essid", como tienes, o es "wpa-ssid". Yo tengo lo segundo: http://www.rpi.uroboros.es/sistema.html#5 A lo mejor se puede escribir de las dos formas, pero por si acaso.

Saludos.
--------
Mi web sobre la RasPi: http://rpi.uroboros.es

Return to “Español”