davidony1000
Posts: 8
Joined: Sat Dec 09, 2017 7:40 pm

Duda sobre encendido/apagado raspberry con rele, infrarrojos y mando TV

Sat Dec 09, 2017 7:41 pm

Buenos días a todos
He comprado una Raspberry que viene con el típico" interruptor de lampara" en el cable de alimentación para poder encender y apagar la placa. Dado que me gustaría poder encenderla con el mando de la TV y después de ver este vídeo de Youtube he pensado si se podría aplicar el mismo sistema a nuestras placas y discos.

He encontrado en Aliexpress este Kit por infrarrojos y he pensado que si se instalara en el lugar del interruptor debería funcionar.

En la descripción pone que es para 12v, habría algún problema para usarlo en los 5v de a Raspberry?

Algún iluminado de la electrónica me lo podría confrimar
Muchas gracias
Un saludo

yagomnzr0
Posts: 17
Joined: Sat Dec 02, 2017 6:11 pm
Location: Córdoba, Argentina

Re: Duda sobre encendido/apagado raspberry con rele, infrarrojos y mando TV

Tue Dec 12, 2017 7:41 pm

Hola.
Te comento, no te sirve el kit que encontraste en aliexpress ya que el rele necesita 12V para activarse.
Encontré otro kit en aliexpres que trabaja con 5 V
Y también encontré otro kit más económico que funciona con RF (Radio Frecuencia).
Espero haberte ayudado, saludos.

davidony1000
Posts: 8
Joined: Sat Dec 09, 2017 7:40 pm

Re: Duda sobre encendido/apagado raspberry con rele, infrarrojos y mando TV

Tue Dec 12, 2017 9:37 pm

Muchas gracias por la respuesta yagomnzr0
Al final me di cuenta y compre uno de 5V. A ver si hay suerte y soy capaz de montarlo y sobre todo, de controlarlo con el mando de la TV que es mi objetivo
Gracias de nuevo
Un saludo

raspdroid
Posts: 1531
Joined: Thu Nov 06, 2014 9:15 am
Location: Gran Canaria :: España

Re: Duda sobre encendido/apagado raspberry con rele, infrarrojos y mando TV

Wed Dec 13, 2017 6:16 pm

Hola,

Los del mando no están mal lo que para ello no veo la necesidad de usar la RPi. Y 433mhz ya no se está usando se está usando 868mhz por lo menos por EU. Supongo que son modelos obsoletos.

El que compraste tiene alguna interfaz?, he visto que algunos usan I2C para controlarlo.

Saludos.

davidony1000
Posts: 8
Joined: Sat Dec 09, 2017 7:40 pm

Re: Duda sobre encendido/apagado raspberry con rele, infrarrojos y mando TV

Fri Dec 29, 2017 11:46 am

Bueno, pues la cosa ha ido bien...a medias
El rele funciona con el mando al conectarlo a la red, se conceta y desconecta sin problema, pero al conectarlo a la raspberry no la hace arrancar... El led de conexion de la placa hace un amago de un segundo y se vuelve a apagar... Me extraña por que las posibilidades de equivocarse con los cables hacia la raspberry es bastante baja....
Cable de la derecha desde corriente y cable izquierda hacia raspberry

EDITO: Me pasa algo bastante raro y es que si le doy varias veces al mando arranca sin problema, parece como si le faltara "fuerza"

Image

yagomnzr0
Posts: 17
Joined: Sat Dec 02, 2017 6:11 pm
Location: Córdoba, Argentina

Re: Duda sobre encendido/apagado raspberry con rele, infrarrojos y mando TV

Fri Dec 29, 2017 1:26 pm

Hola, como estas?
Se me ocurren dos soluciones:

1) Verifica las pilas del control remoto, lo podes hacer con la cámara de tu celular, te dejo un video que te muestra como hacerlo
2)Fíjate en la ficha técnica de la placa del rele cuanta corriente necesita para funcionar correctamente, puede ser que la estés alimentando con una fuente que no cumpla con las especificaciones mínimas.

Saludos

davidony1000
Posts: 8
Joined: Sat Dec 09, 2017 7:40 pm

Re: Duda sobre encendido/apagado raspberry con rele, infrarrojos y mando TV

Tue Jan 02, 2018 7:20 pm

Hola yagomnzr0, el mando funciona bien ya que se enciende y apaga el rele correctamente cuando no conecto la raspberry, el problema es al ponerla que parece que le cuesta varios intentos hasta que arranca
Un saludo

yagomnzr0
Posts: 17
Joined: Sat Dec 02, 2017 6:11 pm
Location: Córdoba, Argentina

Re: Duda sobre encendido/apagado raspberry con rele, infrarrojos y mando TV

Tue Jan 02, 2018 11:03 pm

Que fuente estas usando para alimentar la placa del rele?

yagomnzr0
Posts: 17
Joined: Sat Dec 02, 2017 6:11 pm
Location: Córdoba, Argentina

Re: Duda sobre encendido/apagado raspberry con rele, infrarrojos y mando TV

Tue Jan 02, 2018 11:31 pm

El modulo rele esta alimentado directamente a la fuente?, en la imagen que pusiste no se aprecia ese detalle
Fíjate si lo tenes conectado así:
Image

Saludos

PD: perdón por lo cutre de la imagen :lol:

davidony1000
Posts: 8
Joined: Sat Dec 09, 2017 7:40 pm

Re: Duda sobre encendido/apagado raspberry con rele, infrarrojos y mando TV

Wed Jan 03, 2018 9:16 pm

Pues lo tengo como en este esquema
Image

Pero he encontrado el posible problema, me daba la impresión de que le costaba conectar por falta de "fuerza" así que me ha dado por poner una fuente que alimente el relé y otra la raspberry. Ahora va sin problema a la primera, me extraña por que todos los esquemas que he visto y me habéis puesto se supone que con una fuente vale...en fin, seguiré con este método hasta que pruebe con otra fuente
Muchas gracias
Un saludo

Return to “Español”

Who is online

Users browsing this forum: No registered users and 4 guests