maxe
Posts: 4
Joined: Wed Jul 02, 2014 7:05 pm

Kein Internet mehr

Wed Jul 02, 2014 7:13 pm

Hallo an alle.

Durfte gestern meinen ersten Rpi auspacken und wollte auch gleich loslegen. Hab ein kleines Packet installiert welches die Emulationstation, xbmc sowie lxde beinhaltet.

Hat alles wunderbar geklappt. Habe mich dann heut dran gemacht und versucht iceweasel zu installieren. Dies klappte jedoch nicht. Bekam eine Fehlermeldung ausgespuckt, sowas wie "Unable to fetch". Nach einigen Stunden googlen konnte ich es dann endlich installieren, doch seit dem ist mein Internet weg. Auch über den netbrowser komm ich nicht mehr rein.

Sind übrigens meine aller ersten geh versuche mit linux oder dergleichen, deshalb falls was fehlen sollte an Infos tut es mir leid.
Außerdem tipp ich das gerade von meinem Handy aus, die Rechtschreibfehler sind nicht beabsichtigt. :)
Gruß
Last edited by maxe on Fri Jul 04, 2014 2:02 pm, edited 1 time in total.

maxe
Posts: 4
Joined: Wed Jul 02, 2014 7:05 pm

Re: Kein Internet mehr

Thu Jul 03, 2014 12:13 pm

Mut dem Befehl "sudo route" zeigt er mir Garnichts an. Also bei

Code: Select all

Destination Gateway genmask flags metric ref use Interface 
ist alles leer.

Mit ifconfig sagt er mir das die ip Adresse meines pi's 127.0.0.1 ist. Sollte ja auch nicht so sein^^

Edit: Achja ich bin/war mit einem lan kabel verbunden also nicht drahtlos. Dhcp ist auf meinem Router eingeschalten

forenbenutzer
Posts: 148
Joined: Thu Aug 02, 2012 7:08 pm

Re: Kein Internet mehr

Thu Jul 03, 2014 12:59 pm

der Befehl

Code: Select all

ifconfig
sollte 127.0.0.1 nur für das loopback interface anzeigen. Die LAN-Kabel-Verbindung eth0 sollte vom Router etwas in der Art 192.168.0.123 oder Ähnlich anzeigen ("inet addr").
Ist das nicht der Fall, so hat der Raspberry keine IP-Adresse per DHCP bekommen. Das kann unterschiedliche Ursachen haben. Zunächst aber wäre das zu prüfen.

Beispielbild:

Image
Pitendo - Case And Emulator Project - http://edv-huber.com/index.php/problemloesungen/12-pitendo

maxe
Posts: 4
Joined: Wed Jul 02, 2014 7:05 pm

Re: Kein Internet mehr

Thu Jul 03, 2014 1:20 pm

Genau das ist dann anscheinend passiert, denn bei eth0 steht keine ip Adresse.

Es wundert mich nur, denn bevor ich iceweasel installiert habe ging es tadellos ^^

Wie kann ich dem pi jetzt eine Adresse zuweisen?

Edit: Hier mal die die Anleitung aus dem Forum hier. Konnte wiegesagt nichts installieren aufgrund der Fehlermeldung:

Code: Select all

Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Die Anleitung:

Code: Select all

I had the same problem
I found the answer in another part of the forum
You have to edit the resolv.conf file

Code: Select all
sudo nano /etc/resolv.conf


and then add the lines

Code: Select all
nameserver 8.8.8.8
nameserver 8.8.4.4


That's the google DNS server
This solved it for me
Hope it solves the problem for you 

forenbenutzer
Posts: 148
Joined: Thu Aug 02, 2012 7:08 pm

Re: Kein Internet mehr

Mon Jul 07, 2014 12:17 pm

Das zweite hilft nicht weiter, denn du hast ja überhaupt keine Verbindung. Also kannst du auch keine DNS-Server erreichen.

Schreibe hier mal bitte den Inhalt der Datei "/etc/network/interfaces". Danke.
Pitendo - Case And Emulator Project - http://edv-huber.com/index.php/problemloesungen/12-pitendo

maxe
Posts: 4
Joined: Wed Jul 02, 2014 7:05 pm

Re: Kein Internet mehr

Wed Jul 09, 2014 2:25 pm

Das zweite soll euch nur zeigen was ich bereits unternommen habe. Die Anleitung war dafür da, dass ich mit dem Raspberry Pi befehle wie sudo apt get upgrade ausführen kann, denn bei denen hat er auch anfangs gestreikt. Als ich die Schritte in der Anleitung nachgemacht habe ging mein Internet ja auch noch. Erst nach dem Iceweasel installiert wurde war schluss.

Hier ein Bild von /etc/network/interfaces:
Image
Hoffe man erkennt alles nötige.

Gruß

User avatar
mline
Posts: 1287
Joined: Sun Jan 27, 2013 1:47 pm
Location: Austria, Vienna

Re: Kein Internet mehr

Wed Jul 09, 2014 8:25 pm

Warum sollte ein Browser die Netzwerkkonfiguration ändern?
Vermutlich ist dein Netzwerk selbst das Problem. Du hast geschrieben da war was mit "Unable to fetch". Das bedeutet das du schon bei der Installation mal keine Verbindung zum Internet mehr hattest.

Hast schon mal geprüft ob dein Router oder was auch immer überhaupt ne IP vergibt? Schon mal das DHCPLease zurückgesetzt?

Jedenfalls sind die Netzwerkeinstellungen so wie sie sind OK (auch weil zu tausenden von anderen Leuten benutzt) und auch in der resolv.conf muss nix geändert werden.
<~~>

Friesen
Posts: 2
Joined: Tue Jul 22, 2014 9:54 am

Re: Kein Internet mehr

Tue Jul 22, 2014 10:14 am

Bei mir kommt das auch öfter mal vor. Das liegt meist am Router bei mir. Der erkennt zwar den Pi im LAN/ WLAN, aber vergibt dann keine IP. Ich starte den Pi meistens nochmal neu. Ich vermute, das der Pi je nach Auslastung und nicht schnell genug kommuniziert mit dem Router. Schließlich hängt der Pi nur an einem kleinen Ladegerät und muß gleichzeitig Tasks abarbeiten und kommt dann leicht an seine Grenzen, und dann ist dem Router die Kommunikation zu langsam. Auch sollte man drauf achten, die USB-Ports nicht mit stromfressender Peripherie auszustatten. Ich nutze an meinem Modell z.B. einen Dongle für Maus und Tastatur, anstatt Maus und Tastatur seperat anzuschliessen, was mehr Strom frißt. Auch ältere WLAN-Sticks fressen viel Strom. Helfen kann da ein besseres Ladegrät und ein leichtes übertakten des Pi. Das neue Modell B+, was es jetzt seit wenigen Tagen gibt abeitet da schon besser.

Return to “Deutsch”