Kübbi
Posts: 11
Joined: Fri Dec 07, 2012 9:32 pm

Raspberry Pi Kamera - Bild flackert

Tue Aug 20, 2013 6:34 pm

Hallo zusammen,
heute ist meine Raspberry Pi Kamera angekommen und ich habe sie gleich mal ein bischen getestet. Doch dann bin ich auf ein Problem gestoßen, welches ich bisher nicht lösen konnte:
Sobald ich ein Video mit "raspivid -o /home/pi/video.h264 -t 30000" flackert das Bild grundsätzlich recht stark, alle Einstellungen sind so weit auf default belassen worden. Wenn ich allerdings ein Foto mache, tritt dieses Flackern nicht auf. Habt ihr vielleicht eine Idee, wie es dazu kommen kann bzw. wie man das wieder abschalten kann?

mfg Kübbi

User avatar
peba
Posts: 56
Joined: Tue Jun 12, 2012 8:16 pm
Location: Austria Korneuburg
Contact: Website

Re: Raspberry Pi Kamera - Bild flackert

Wed Aug 21, 2013 1:18 pm

Hallo,

Ich hatte ein ähnliches Problem mit der Kamera, bei mir waren Streifen im Bild. Die Ursache war, daß mein Netzteil an der Leistungsgrenze war. Ich habe dieses dann gegen eines ausgetasucht das auf jeden Fall 1 Ampere kann und das Problem war behoben.

LG,
Peter
http://bitkistl.blogspot.com

Kübbi
Posts: 11
Joined: Fri Dec 07, 2012 9:32 pm

Re: Raspberry Pi Kamera - Bild flackert

Thu Aug 22, 2013 1:55 pm

Komisch, ich nutze schon ein 2A Netzteil. Jetzt habe ich ein 1A Netzteil genommen und die Streifen sind weg :D komisch

User avatar
mline
Posts: 1433
Joined: Sun Jan 27, 2013 1:47 pm
Location: Austria, Vienna

Re: Raspberry Pi Kamera - Bild flackert

Thu Aug 22, 2013 5:17 pm

Vielleicht kann das Netzteil die Spannung nicht halten. Eventuell ist es auch nicht gut stabilisiert.
Wäre auch möglich das du die 50Hz Netzfrequenz gesehen hast...
<~~>

Kübbi
Posts: 11
Joined: Fri Dec 07, 2012 9:32 pm

Re: Raspberry Pi Kamera - Bild flackert

Thu Aug 22, 2013 9:54 pm

Ich muss zugeben, dass es nicht das teuerste Netzteil war und 50/60Hz unterstützt.

User avatar
mline
Posts: 1433
Joined: Sun Jan 27, 2013 1:47 pm
Location: Austria, Vienna

Re: Raspberry Pi Kamera - Bild flackert

Fri Aug 23, 2013 12:05 am

Kübbi wrote:nicht das teuerste Netzteil
Das sagt garnix aus. Hab einige Netzteile hier die weniger als 10€ gekostet haben und die funktionieren tadellos.
Vielleicht hast einfach nur ein schlechtes erwischt.

Am besten funktioniert bei mir das hier: http://www.conrad.at/ce/de/product/514691/
Dieses liefert 1,2A was völlig ausreichend ist da ohnehin eine Sicherung mit 1,1A auf der Pi sitzt.

Für Modell A reicht auch eins der aktuellen Handyladegeräte
<~~>

Drago
Posts: 1
Joined: Sat Aug 24, 2013 11:21 am

Re: Raspberry Pi Kamera - Bild flackert

Sat Aug 24, 2013 11:40 am

Hallo zusammen,

ich habe hier ein (fast Flach-)Steckernetzteil an dem man ein USB-Kabel einstöpselt. Das liefert nur die Mindestampere von 700 die für den RaspPi B angegeben sind.
Trotzdem funktioniert es bislang auch mit der Kamera einwandfrei.
Hoffentlich tut die geringe Stromstärke dem RaspPi sonst nix. !?

Ein seit gestern stolzer Besitzer eines RaspPi mit Kamera
Grüße
Drago

User avatar
mline
Posts: 1433
Joined: Sun Jan 27, 2013 1:47 pm
Location: Austria, Vienna

Re: Raspberry Pi Kamera - Bild flackert

Sat Aug 24, 2013 12:45 pm

Ne tut der Pi nix.

Es kann jedoch sein das eine Stromspitze einen Spannungsabfall verursacht und deine Pi dadurch instabil wird und abstürzt. Das führt eventuell zu einem korrupten Dateisystem. Man kann dieses zwar reparieren aber ich hatte es schon einige male das dadurch das System total im Eimer war...

Wenn du das vermeiden willst solltest du schon ein Netzteil einsetzen welches mindestens die 1,1A der Sicherung schafft. Mehr Strom kann das Netzteil anbieten aber über den MicroUSB Anschluss können maximal 1,1A fliessen.
<~~>

Return to “Deutsch”