rotation
Posts: 27
Joined: Fri Feb 08, 2013 2:43 pm

Abstürze - verwendetes USB Kabel?

Fri Feb 08, 2013 2:48 pm

Hi.

Ich habe gerade meinen RPi bekommen (nur den RPi und Netzteil gekauft) und das Standard Debian aufgesetzt.
Ich gehe mit einem VNC Client rein, RPi hängt am Netzwerk.
Manchmal stürzt der RPi ab, es leuchtet nur die rote LED:
Einmal habe ich einen USB WLAN Stick angesteckt
Einmal habe ich einen Browserbenchmark laufen lassen.

Das Kabel ist ein 08/15 Kabel.
Wie wahrscheinlich ist es, dass es am Kabel liegt - es zuviel Widerstand hat?

User avatar
diereinegier
Posts: 166
Joined: Sun Dec 30, 2012 5:45 pm
Location: Bonn, Germany
Contact: Website

Re: Abstürze - verwendetes USB Kabel?

Sat Feb 09, 2013 9:13 pm

Das Kabel ist als Ursache möglich, wahrscheinlicher ist aber das Netzteil die Fehlerursache.

Wenn Du ein Multimeter hast, kannst Du die Spannung zwischen den beiden TestPunkten TP1 und TP2 messen. Mit 4,75 V bis 5,25 V im Betrieb bist Du auf der sicheren Seite.

Wenn Du Dir Ärger ersparen willst, kaufst Du Dir am besten einen Powered USB-Hub aus der Kompatibilitätsliste aus eLinux.org und steckst USB-Peripherie wirklich nur in den Hub.
Download my repositories at https://github.com/GeorgBisseling

retsifp
Posts: 2
Joined: Sat Sep 01, 2012 9:12 am

Re: Abstürze - verwendetes USB Kabel?

Tue Feb 12, 2013 7:13 pm

Hast du den WLAN-Stick an einem USB-Hub mit eigener Stromversorgung?
Wenn nein, dann mach das, sonst wird der RPi nie stabil funktionieren.

Mindsweeper
Posts: 1
Joined: Wed Feb 13, 2013 1:52 pm

Re: Abstürze - verwendetes USB Kabel?

Thu Feb 14, 2013 6:55 am

Die USB-Ports von meinem Raspi sind standesgemäß mit zwei Mini-Sticks belegt: einem Edimax EW-7811Un (WLan) und dem Empfänger der Rapoo 5G Wireless Super Mini Mouse. Bisher läuft alles stabil.

drscheme
Posts: 20
Joined: Thu Feb 14, 2013 8:33 am

Re: Abstürze - verwendetes USB Kabel?

Thu Feb 14, 2013 11:11 am

retsifp wrote:Hast du den WLAN-Stick an einem USB-Hub mit eigener Stromversorgung?
Wenn nein, dann mach das, sonst wird der RPi nie stabil funktionieren.
Ist der Grund der USB-Hub oder zu geringe Stromversorgung? Ich habe meinen WLAN-Stick am RPi direkt angeschlossen und habe mittlerweile auch den Eindruck, dass meine Probleme daher rühren können.

WeUsePis
Posts: 96
Joined: Mon Dec 31, 2012 4:02 pm
Location: Upstate New York
Contact: Website

Re: Abstürze - verwendetes USB Kabel?

Thu Feb 14, 2013 12:52 pm

Meistens ist es die mangelnde Stromversorgung, die den Pi zum Absturz bringt. Der Pi kann bis zu 700 mA für sich selbst ziehen (normalerweise etwa nur die Hälfte). Wenn das Netzteil dann nur 1A @ 5V bringt, bleibt halt nicht mehr viel für den Rest übrig. Also, entweder stärkeres Netzteil oder halt eine Hub mit eigener Stromversorgung anschließen. Ich benutze einen IOGear 7 port MiniHub (GUH227). Von den günstigeren Hubs hat der das stärkste Netzteil (3,7 A) und der Hub funktioniert soweit einwandfrei, habe aber noch nicht viel mehr als eine drahtlose Logitech Maus/Tappse Kombo angeschlossen und die mittlerweile auch nicht mehr, da ich jetzt den Monoprice KCF-131DA DVI KVM benutze (schaltet auch Audio, USB und hat PS/2-> USB Konverter eingebaut).

War jetzt mehr Info als nötig, sorry. Also, Hub oder stärkeres Netzteil sollte das Problem beheben.
Our Pi Blog - http://weusepis.wordpress.com/

User avatar
Hiswif
Posts: 664
Joined: Sat Oct 13, 2012 11:54 am
Contact: Website

Re: Abstürze - verwendetes USB Kabel?

Fri Feb 15, 2013 12:16 am

Heho.

Das Problem ist schon seit längerem bekannt und hier im Forum auch schon des Öfteren diskutiert wurden. Schaut dazu einfach mal hier:

http://www.raspberrypi.org/phpBB3/viewt ... 67#p209967
Von den günstigeren Hubs hat der das stärkste Netzteil (3,7 A)
Hub oder stärkeres Netzteil sollte das Problem beheben.
Bringt dir für den Pi allein erstmal nicht wirklich nen Vorteil zu nem 2A Netzteil, selbst wenn du den Pi vom Hub her versorgst. Erst wenn die restlichen Verbraucher wirklich um die 2,6 A ziehen ergibt das Sinn. Also nicht das wir uns jetzt falsch verstehen. Der Hub mit externer Stromversorgung macht für den WLan Stick absolut Sinn und ist auch absolut zu empfehlen!!! Nur ein Stärkeres Netzteil am Pi bringt absolut nichts, alles was über 1,1 A ist verpufft.

MFG

His
http://technikegge.blogspot.de

WeUsePis
Posts: 96
Joined: Mon Dec 31, 2012 4:02 pm
Location: Upstate New York
Contact: Website

Re: Abstürze - verwendetes USB Kabel?

Fri Feb 15, 2013 12:55 pm

Meinte das auch nur in Bezug auf den Hub. Wenn man sich schon einen neuen Hub zulegt, dann auch einen, der nicht gleich bei der ersten USB-Festplatte schlapp macht. Ich habe das Netzteil am Pi drangelassen, also an mangelnder Stromversorgung sollte es dann nicht mehr liegen. Haben den Pi im 24x7-Betrieb und selbst bei der dynamischen Taktung auf 1GHz funktioniert alles einwandfrei. Das Netzteil für den Pi bringt [email protected]
Our Pi Blog - http://weusepis.wordpress.com/

User avatar
Hiswif
Posts: 664
Joined: Sat Oct 13, 2012 11:54 am
Contact: Website

Re: Abstürze - verwendetes USB Kabel?

Fri Feb 15, 2013 5:17 pm

Ah ok, das ergibt Sinn. Hatten hier nur schon einige die sich für den Pi nen 5A Netzteil zugelegt haben weil sie dachten das es dann mit USB besser klappt. Wollt nur drauf hinweisen das dies natürlich falsch ist.
http://technikegge.blogspot.de

Return to “Deutsch”