Page 1 of 1

Ruckeln XBMC bei HD Mitschnitten der öffentlich-rechtlichen

Posted: Tue Jan 15, 2013 8:16 am
by mouseclicker
Hallo zusammen,

hat jemand das gleiche Problem oder vielleicht eine Lösung zu folgendem Problem? Während mein RaspBMC im Grunde super funktioniert und eine Menge Formate bis 1080p sauber abspielt, habe ich ausgerechnet bei den HD Mitschnitten der öffentlich-rechtlichen Sender (ARD, ZDF, 3sat, Arte in 720p) bei bewegten Szenen ein massives Flackern. Das äußert sich so, dass der bewegte Teil (z.B. eine gehende Person) aussieht als ob der sich bewegende Bereich zwischen zwei Frames ein Stück versetzt wird, also z.B. die Person auf und ab hüpft.

Es liegt nicht am HDMI/Bildschirm, da habe ich mehrere ausprobiert. Die gleiche Datei lässt sich auch mit vlc oder anderen Playern auf einem PC störungsfrei abspielen. Leider machen genau die den Löwenanteil meiner Sammlung aus :( Ich schneide diese per SAT-Receiver als .ts Datei mit, schneide sie mit SmartCutter und wandel sie dann ins mkv-Format.

Re: Ruckeln XBMC bei HD Mitschnitten der öffentlich-rechtlic

Posted: Tue Jan 15, 2013 11:33 am
by thradtke
mouseclicker wrote:Ich schneide diese per SAT-Receiver als .ts Datei mit, schneide sie mit SmartCutter und wandel sie dann ins mkv-Format.
.ts ist doch mpeg2, oder? Könntest Du nicht die entsprechende Linzenz kaufen und die Dateien direkt abspielen? Oder habe ich dich falsch verstanden?

Re: Ruckeln XBMC bei HD Mitschnitten der öffentlich-rechtlic

Posted: Tue Jan 15, 2013 12:56 pm
by WeUsePis
Ist das ein Problem nur mit den ÖR? Mitschnitte von privaten Sendern funktionieren einwandfrei?
Wo kommen die Daten her? Von einem Netzwerkserver oder direkt von einer Festplatte, die am Pi angeschlossen ist? Ein Grund für Ruckeln ist fehlender Datenstrom, da werden dann Frames fallengelassen.

Re: Ruckeln XBMC bei HD Mitschnitten der öffentlich-rechtlic

Posted: Tue Jan 15, 2013 2:03 pm
by mouseclicker
Die öffentlich-rechtlichen senden die .ts Streams der HD-Sender H.264-codiert, das sollte der Pi hardwaremäßig können ohne Zusatzcodec.

DIe Dateien liegen auf einer lokal angeschlossen USB-Platte. Wenn es ein Problem der Datenrate wäre, würde das Problem auch bei höheraufgelösten Videos auftreten, die funktionieren aber. Es ist ja auch nicht so dass die Framerate einbricht, sondern dass Artefakte im Bild auftreten. Private Sender habe ich noch nicht probiert, auf diesen CI+-Mist habe ich keine Lust.

Ich vermute eher, dass es irgendeine spezielle Encoding-Option ist, die bei diesen Sendern verwendet wird. Mein Philips BluRay Player hat auch ein Jahr gebraucht bis er das nach Firmware-Update abspielen konnte. Zum Beispiel CABAC=yes ist so ein potentieller Kanditat. Vermutlich ist das nicht mal ein spezielles Pi-Problem, sondern ein generelles XBMC-Problem. Kann man dessen Player auch als "normale" Anwendung installieren irgendwo, z.B. unter Windows?

Danke schon mal für die Hinweise. Nachdem doch viele den Pi als Mediaplayer einsetzen kann ich mir kaum vorstellen, dass ich der einzige bin mit dem Problem (wenn es denn ein allgemeines Problem ist).