Page 1 of 1

python3-cheetah wird benötigt, aber nicht gefunden

Posted: Wed Sep 02, 2020 12:46 pm
by WolfgangZenner
Hallo,
ich habe eine Wetterstation WH1080 und möchte jetzt WeeWX installieren.
Dieses Programm benötigt python3-cheetah, das es offensichtlich für Raspbian nicht gibt.
Kann ich die Package irgendwoher bekommen und installieren, oder wird diese irgendwann nachgeliefert?
mfg
Wolfgang Zenner

Re: python3-cheetah wird benötigt, aber nicht gefunden

Posted: Wed Sep 02, 2020 12:55 pm
by smartifahrer
Schon mal folgendes probiert?

Code: Select all

sudo apt-get install python3-cheetah

Re: python3-cheetah wird benötigt, aber nicht gefunden

Posted: Wed Sep 02, 2020 1:46 pm
by mline
Wenn du pip nutzt solltest du die meisten Packages für python finden. Viele davon sind nicht in den Paketquellen für Debian.


Falls du pip nicht installiert hast:
für python 3

Code: Select all

sudo apt-get install python3-pip

danach installierst du cheetah mit

Code: Select all

sudo pip3 install cheetah
bzw. gibt es wohl auch eine aktuellere Version

Code: Select all

sudo pip3 install cheetah3
weiß nicht welches genau von WeeWX gefordert wird

Re: python3-cheetah wird benötigt, aber nicht gefunden

Posted: Wed Sep 02, 2020 9:27 pm
by WolfgangZenner
Hallo,
Ausgabe der Installation von cheetah:
pi@Raspi2-52-TV:~ $ sudo pip3 install cheetah
Collecting cheetah
Downloading https://files.pythonhosted.org/packages ... 4.4.tar.gz (190kB)
100% |████████████████████████████████| 194kB 569kB/s
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "/tmp/pip-build-rh7ce_gl/cheetah/setup.py", line 10, in <module>
import SetupTools
File "/tmp/pip-build-rh7ce_gl/cheetah/SetupTools.py", line 50
except DistutilsPlatformError, x:
^
SyntaxError: invalid syntax

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-rh7ce_gl/cheetah/
pi@Raspi2-52-TV:~ $

Re: python3-cheetah wird benötigt, aber nicht gefunden

Posted: Thu Sep 03, 2020 7:29 am
by DerKleinePunk
sudo pip3 install cheetah3 sollte besser sein der zieht die version für Python 2
https://cheetahtemplate.org/ da sind ganz andere Versionsnummern als 2.4.4 nämlich mit 3 vorne