Ksigh
Posts: 8
Joined: Tue Aug 18, 2020 2:16 pm

32bit Programme (armhf) auf 64bit Raspberry OS installieren

Mon Aug 31, 2020 7:15 pm

Hallo,

hat schon jemand Erfahrung damit Programme (in meinem Fall Citrix Workspace App) für 32 bit Linux (armhf) auf dem "neuen" 64bit Raspberry OS zu installieren?
Ich habe schon im Internet gesucht und bin über multiarch gefallen. Dann habe ich mich mit dpkg und apt beschäftigt, dass apt eigentlich die Abhängigkeiten auflösen sollte, aber das bekomme ich nicht hin.
Hier meine letzten Versuche:

Code: Select all

sudo apt install ./icaclient_20.06.0.15_armhf.deb
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 icaclient:armhf : Hängt ab von: libice6:armhf (>= 1:1.0.0) ist aber nicht installiert
                   Hängt ab von: libgtk2.0-0:armhf (>= 2.12.0) ist aber nicht installiert
                   Hängt ab von: libsm6:armhf ist aber nicht installiert
                   Hängt ab von: libx11-6:armhf ist aber nicht installiert
                   Hängt ab von: libxext6:armhf ist aber nicht installiert
                   Hängt ab von: libxmu6:armhf ist aber nicht installiert
                   Hängt ab von: libxpm4:armhf ist aber nicht installiert
                   Hängt ab von: libasound2:armhf ist aber nicht installiert
                   Hängt ab von: libstdc++6:armhf ist aber nicht installiert
                   Hängt ab von: libidn11:armhf ist aber nicht installiert
                   Hängt ab von: zlib1g:armhf ist aber nicht installiert
                   Empfiehlt: libglib2.0-0:armhf (>= 2.12.0) ist aber nicht installiert
                   Empfiehlt: libgstreamer-plugins-base0.10-0:armhf (>= 0.10.15) ist aber nicht installiert
                   Empfiehlt: libgstreamer0.10-0:armhf (>= 0.10.15) ist aber nicht installiert
                   Empfiehlt: libspeex1:armhf ist aber nicht installiert
                   Empfiehlt: libvorbis0a:armhf ist aber nicht installiert
                   Empfiehlt: libvorbisenc2:armhf ist aber nicht installiert
                   Empfiehlt: gstreamer1.0-libav:armhf (>= 1.2.0) ist aber nicht installiert
                   Empfiehlt: gstreamer1.0-plugins-bad:armhf (>= 1.2.0) ist aber nicht installiert
                   Empfiehlt: libwebkit2gtk-4.0-37:armhf ist aber nicht installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

Code: Select all

pi@raspberrypi:~/Downloads/Citrix $ sudo apt --fix-broken install
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Abhängigkeiten werden korrigiert ... Fertig
Die folgenden zusätzlichen Pakete werden installiert:
  krb5-locales libgdk-pixbuf2.0-bin libgpg-error-l10n uuid-runtime
Die folgenden Pakete werden ENTFERNT:
  icaclient:armhf
Die folgenden NEUEN Pakete werden installiert:
  krb5-locales libgdk-pixbuf2.0-bin libgpg-error-l10n uuid-runtime
0 aktualisiert, 4 neu installiert, 1 zu entfernen und 0 nicht aktualisiert.
1 nicht vollständig installiert oder entfernt.
Es müssen 311 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 46,3 MB Plattenplatz freigegeben.
Möchten Sie fortfahren? [J/n] j
Holen:1 http://deb.debian.org/debian buster/main arm64 uuid-runtime arm64 2.33.1-0.1 [93,9 kB]
Holen:2 http://deb.debian.org/debian buster/main arm64 krb5-locales all 1.17-3 [95,4 kB]
Holen:3 http://deb.debian.org/debian buster/main arm64 libgdk-pixbuf2.0-bin arm64 2.38.1+dfsg-1 [24,0 kB]
Holen:4 http://deb.debian.org/debian buster/main arm64 libgpg-error-l10n all 1.35-1 [97,6 kB]
Es wurden 311 kB in 0 s geholt (1.469 kB/s).
(Lese Datenbank ... 113792 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von icaclient:armhf (20.06.0.15) ...
Vormals nicht ausgewähltes Paket uuid-runtime wird gewählt.
(Lese Datenbank ... 113092 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../uuid-runtime_2.33.1-0.1_arm64.deb ...
Entpacken von uuid-runtime (2.33.1-0.1) ...
Vormals nicht ausgewähltes Paket krb5-locales wird gewählt.
Vorbereitung zum Entpacken von .../krb5-locales_1.17-3_all.deb ...
Entpacken von krb5-locales (1.17-3) ...
Vormals nicht ausgewähltes Paket libgdk-pixbuf2.0-bin wird gewählt.
Vorbereitung zum Entpacken von .../libgdk-pixbuf2.0-bin_2.38.1+dfsg-1_arm64.deb ...
Entpacken von libgdk-pixbuf2.0-bin (2.38.1+dfsg-1) ...
Vormals nicht ausgewähltes Paket libgpg-error-l10n wird gewählt.
Vorbereitung zum Entpacken von .../libgpg-error-l10n_1.35-1_all.deb ...
Entpacken von libgpg-error-l10n (1.35-1) ...
krb5-locales (1.17-3) wird eingerichtet ...
uuid-runtime (2.33.1-0.1) wird eingerichtet ...
Lege Gruppe »uuidd« (GID 118) an ...
Fertig.
Warnung: Auf das von Ihnen angegebene Home-Verzeichnis /run/uuidd kann nicht zugegriffen werden: No such file or directory
Lege Systembenutzer »uuidd« (UID 111) an ...
Lege neuen Benutzer »uuidd« (UID 111) mit Gruppe »uuidd« an ...
Erstelle Home-Verzeichnis »/run/uuidd« nicht.
Created symlink /etc/systemd/system/sockets.target.wants/uuidd.socket → /lib/systemd/system/uuidd.socket.
libgdk-pixbuf2.0-bin (2.38.1+dfsg-1) wird eingerichtet ...
libgpg-error-l10n (1.35-1) wird eingerichtet ...
Trigger für mime-support (3.62) werden verarbeitet ...
Trigger für gnome-menus (3.31.4-3) werden verarbeitet ...
Trigger für systemd (241-7~deb10u4) werden verarbeitet ...
Trigger für man-db (2.8.5-2) werden verarbeitet ...
Trigger für desktop-file-utils (0.23-4) werden verarbeitet ...

Code: Select all

sudo apt install ./icaclient_20.06.0.15_armhf.deb
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Hinweis: »icaclient:armhf« wird an Stelle von »./icaclient_20.06.0.15_armhf.deb« gewählt.
Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
nicht erstellt wurden oder Incoming noch nicht verlassen haben.
Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 icaclient:armhf : Hängt ab von: libgtk2.0-0:armhf (>= 2.12.0) soll aber nicht installiert werden
                   Empfiehlt: gstreamer1.0-libav:armhf (>= 1.2.0) soll aber nicht installiert werden
                   Empfiehlt: gstreamer1.0-plugins-bad:armhf (>= 1.2.0) soll aber nicht installiert werden
                   Empfiehlt: libwebkit2gtk-4.0-37:armhf soll aber nicht installiert werden
E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.

Kann mir jemand helfen?

Danke und Gruß
Kshig

smartifahrer
Posts: 1058
Joined: Sat Feb 13, 2016 8:10 am

Re: 32bit Programme (armhf) auf 64bit Raspberry OS installieren

Tue Sep 01, 2020 7:00 am

Die 64-Bit Version von Raspberry os ist noch lange nicht fertig. Somit kann es gut sein das noch einige Pakete fehlen oder was nicht funkt.

Return to “Deutsch”