Meti
Posts: 5
Joined: Wed Dec 19, 2012 2:17 pm

Stromprobleme

Wed Dec 19, 2012 3:01 pm

Hallo!
Ich hab gestern meinen ersten Pi bekommen und bin noch ziemlicher elektronik-Neuling.
Nach ersten Versuchen hab ich ein weisses Flackern im Bild bemerkt (ohne GUI). Also hab ich mir die Troubleshooting-Seite durchgelesen und bin auf die anscheinend recht häufigen Probleme mit der Stromversorgung gestossen.
An den Messpunkten habe ich zwischen 4,63 V mit Lan-Kabel und 4,74 V ohne Lan - also nur mit HDMI Monitor gemessen.
Ich habe den Pi an dem Netzteil vom Ipad (2,1A 5,1V laut Aufdruck) über ein microUSB Kabel vom Conrad (1,8m) angeschlossen.
Ausserdem habe ich noch einen USB Hub mit einem 5V 2,5A Netzteil am USB Port an dem sonst nur der Empfänger für die kabellose Tastatur steckt. (Habe es auch ohne probiert) Der alleine sollte doch genug sein um mehr als 4,75 V zu bekommen oder?
Nur mit dem USB Hub komme ich nur auf 4,29V.
Nur das Ipad Netzteil macht ca. 4,7V und stecke ich beide an ändert das nichts.
Die Sicherung F3 habe ich überprüft. Der Spannungsabfall war ca. 0,03V.

Kann es sein, dass das microUSB Kabel zu schlecht ist - oder zu lang? Würde es vielleicht helfen wenn ich es abschneide auf 5cm und dickere Kabel (welche?) anlöte?
Und warum wird es nicht besser wenn ich 2 Stromquellen verwende?

Vielen Dank schon mal fürs Durchlesen meiner kleinen Litanei hier!
Mfg Meti

Deva
Posts: 13
Joined: Mon Dec 10, 2012 10:09 pm

Re: Stromprobleme

Wed Dec 19, 2012 6:24 pm

Meti wrote:Hallo!
Ich hab gestern meinen ersten Pi bekommen und bin noch ziemlicher elektronik-Neuling.
Nach ersten Versuchen hab ich ein weisses Flackern im Bild bemerkt (ohne GUI). Also hab ich mir die Troubleshooting-Seite durchgelesen und bin auf die anscheinend recht häufigen Probleme mit der Stromversorgung gestossen.
An den Messpunkten habe ich zwischen 4,63 V mit Lan-Kabel und 4,74 V ohne Lan - also nur mit HDMI Monitor gemessen.
Ich habe den Pi an dem Netzteil vom Ipad (2,1A 5,1V laut Aufdruck) über ein microUSB Kabel vom Conrad (1,8m) angeschlossen.
Ausserdem habe ich noch einen USB Hub mit einem 5V 2,5A Netzteil am USB Port an dem sonst nur der Empfänger für die kabellose Tastatur steckt. (Habe es auch ohne probiert) Der alleine sollte doch genug sein um mehr als 4,75 V zu bekommen oder?
Nein. Siehe weiter unten.
Meti wrote: Nur mit dem USB Hub komme ich nur auf 4,29V.
Meine Vermutung ist das am USB Hub Ausgang "nur" 4,75 V anliegen welches immer noch innerhalb der USB Spezifikation ist.
Allerdings ist ein Spannungsabfall von 0,46 V im USB Kabel und Sicherung F3 recht hoch.
Meti wrote: Nur das Ipad Netzteil macht ca. 4,7V und stecke ich beide an ändert das nichts.
Wenn die Angabe mit den 5,1 V vom Ipad stimmen kommen wir wieder auf 0,4x V Spannungsabfall im USB Kabel + Sicherung
Der USB-Hub am Ausgang des RPI liefert keinen Strom zum RPI.
Meti wrote: Die Sicherung F3 habe ich überprüft. Der Spannungsabfall war ca. 0,03V.
Da der Spannungsabfall an der Sicherung mit 0,03 V ok ist, würde ich an dieser stelle das USB-Kabel als schuldigen hinstellen.
Meti wrote: Kann es sein, dass das microUSB Kabel zu schlecht ist - oder zu lang? Würde es vielleicht helfen wenn ich es abschneide auf 5cm und dickere Kabel (welche?) anlöte?
Sowohl kürzere als auch dickere Kabel sollten dem Problem entgegenwirken.
Mit dicker meine ich hier wirklich den Querschnitt des Leiters im Kabel und nicht etwas mit Ummantelung aufgeblähtes.
Ach das verwendete Material des Leiters spielt eine entschiedene Rolle.
Meti wrote: Und warum wird es nicht besser wenn ich 2 Stromquellen verwende?
Es werden keine 2 Stromquellen für den RPI verwendet. Der USB-HUB am Ausgang liefert nur Strom für nachfolgende Geräte.
Sollte er dennoch auch rückwärts den RPI mit Strom versorgen ist das gegen die Spezifikation von USB

p.s. Die Spannungen am Ipad Netzteil und USB-Hub sind nur Vermutungen und sollten nachgemessen werden.

Meti
Posts: 5
Joined: Wed Dec 19, 2012 2:17 pm

Re: Stromprobleme

Wed Dec 19, 2012 6:56 pm

Danke erstmal für die rasche Antwort!
Deva wrote: Es werden keine 2 Stromquellen für den RPI verwendet. Der USB-HUB am Ausgang liefert nur Strom für nachfolgende Geräte.
Sollte er dennoch auch rückwärts den RPI mit Strom versorgen ist das gegen die Spezifikation von USB

p.s. Die Spannungen am Ipad Netzteil und USB-Hub sind nur Vermutungen und sollten nachgemessen werden.
Ziehe ich den microUSB Stecker raus, so läuft der Pi weiter. Daher nehme ich an, dass der Hub den Pi doch versorgt. Allerdings wie oben beschrieben nur mit 4,29V.
Als ich die F3 getestet habe (genau nach Anleitung - also ohne SD Karte und sonstigen angeschlossenen Geräten) lagen da etwas über 5,0 V an.

Ach ja ich habe hier 0,22 mm2 Kupferlitzen. Würden die reichen um ein etwa 1,5m langes Kabel zu basteln aus den Anschlüssen des jetzigen Kabels? Oder sollte ich es mal mit einem halbem Meter versuchen?

thsBavR10
Posts: 233
Joined: Sat Jul 21, 2012 3:11 pm

Re: Stromprobleme

Wed Dec 19, 2012 7:03 pm

Warum soll denn der Spannungsabfall über F3 eigentlich ohne SD-Karte und Geräte gemessen werden ?
Das verfälscht doch das Ergebnis, weil der Spannungsabfall im Betrieb der entscheidende ist. Ohne SD_Karte starte der PI nicht.
Ich habe bisher immer im Betrieb den Spannungsabfall gemessen, nur das macht für mich Sinn.

Wenn Du allerdings mit einem 'guten' Messgerät (dass auch reproduzierbar noch 0,1 Ohm messen kann) den Widerstand von F3 messen willst, dann natürlich ohne Stromversorgung.

Meti
Posts: 5
Joined: Wed Dec 19, 2012 2:17 pm

Re: Stromprobleme

Wed Dec 19, 2012 7:16 pm

thsBavR10 wrote:Warum soll denn der Spannungsabfall über F3 eigentlich ohne SD-Karte und Geräte gemessen werden ?
Das verfälscht doch das Ergebnis, weil der Spannungsabfall im Betrieb der entscheidende ist. Ohne SD_Karte starte der PI nicht.
Ich habe bisher immer im Betrieb den Spannungsabfall gemessen, nur das macht für mich Sinn.

Wenn Du allerdings mit einem 'guten' Messgerät (dass auch reproduzierbar noch 0,1 Ohm messen kann) den Widerstand von F3 messen willst, dann natürlich ohne Stromversorgung.
Das stand hier: http://elinux.org/R-Pi_Troubleshooting# ... r_problems
Mit Sd Karte (und sonst nichts) ist der Spannungsabfall von 4,88 auf 4,73 also 0,15 V.
Den Widerstand kann ich mit meinem 19€ Multimeter nicht wirklich messen. Da Schwankt es irgendwo um 1 bis 3 Ohm.

thsBavR10
Posts: 233
Joined: Sat Jul 21, 2012 3:11 pm

Re: Stromprobleme

Wed Dec 19, 2012 8:48 pm

O.K. ich habe das nochmal nachgelesen. Die Empfehlung verstehe ich so, dass man, wenn der Spannungsabfall
zu hoch sein sollte, danach mit weniger angeschlossenen Einheiten nochmal messen sollte.

Wenn allerdings der Spannungsabfall wie bei Deinem Pi im Betrieb nur 0,15 V beträgt, kann man die
Sicherung F3 als Ursache ausschliessen. Sofern die vom Netzteil geleiferte Spannung hoch genug ist,
ist der Ansatz mit einem besseren Kabel wirklich zielführend.
Bei dem Querschnitt von 0,22mm2 und einer Länge von 1,5 m beträgt der Widerstand 0,13 Ohm
(http://www.leds.de/Leitungswiderstand/). Damit dürfte auch die längere Variante in Ordnung sein.

Yggdrasil
Posts: 138
Joined: Sun Aug 26, 2012 8:45 pm

Re: Stromprobleme

Wed Dec 19, 2012 10:18 pm

Hallo,

mit den zwei parallelen Spannungsquellen kannst die anliegende Spannung nicht erhöhen. Das zweite Netzteil würde nur etwas bringen, wenn die Spannung unter Last einbrechen würde, aber das ist hier ja nicht der Fall.

Ich würde auch das Kabel herausschneiden und die Stecker mit zwei dickeren Versorgungsleitungen verbinden. Ich hatte auch ein schlechtes Kabel mit viel zu hohem Widerstand und es so „repariert“ ;-)

Meti
Posts: 5
Joined: Wed Dec 19, 2012 2:17 pm

Re: Stromprobleme

Thu Dec 20, 2012 5:29 am

Gut Danke! Ich werde probieren das Kabel umzubauen. Geht aber erst am Samstag - jetzt geh i schifahren :)
Ich werde euch dann berichten ob es etwas gebracht hat!
Mfg Meti

Meti
Posts: 5
Joined: Wed Dec 19, 2012 2:17 pm

Re: Stromprobleme

Sat Dec 22, 2012 4:12 pm

Hallo! So nun bin ich vom Urlaub zurück und hab mich gleich mal auf mein Kabel gestürzt.
Mein Selfmade Kabel ist jetzt ca. 70cm lang und die Spannung an TP1 - TP2 ist jetzt beim booten 4,83 V (+-0,01).

Vielen Dank nochmal für eure Hilfe!

Mfg Meti

DominikKu
Posts: 1
Joined: Fri Jan 22, 2016 3:28 pm

Re: Stromprobleme

Fri Jan 22, 2016 3:42 pm

Hi zusammen,

ich hoffe dieser Beitrag kann wiederbelebt werden. Ich habe das gleiche Problem mit meinem Raspberry Pi, muss ich mir mein Spannungskabel jetzt auch selbst bauen?.... :shock:

RetMan
Posts: 28
Joined: Fri Jan 01, 2016 4:17 pm

Re: Stromprobleme

Sat Jan 23, 2016 2:03 pm

Moin,
persönlich halte ich nicht viel vom Basteln (obwohl, ich bin immer dabei), spare Material und meine Zeit und verwende gebrauchsfertige Steckernetzteile.

Nur z. Bsp. zum Vergleich siehe:
"The Pi Hut EU Micro USB Power Supply for the Raspberry Pi (5V 2A)."
Gleichwertige Geräte gibt es auch im "lokalen Handel".

Have a nice day.

Return to “Deutsch”