Paluten
Posts: 1
Joined: Tue May 07, 2019 6:13 pm

Raspi 2 startet nicht

Tue May 07, 2019 6:32 pm

Hallo,


mein Raspberry Pi 2 startet leider nicht... Ich wollte den Treiber von einen Display auf meinem zero installieren, habe
aber keine passende Tastatur. Nun habe ich die SDKarte kurzerhand in meinen Raspi 2 gesteckt und dieser startet nicht.
Es ist noch nicht einmal das grüne Lämpchen an. Eigentlich habe ich auf der Karte nur einmal Raspbian installiert und
den Zero einmal gestartet. Das lief dann Perfekt. Hat aber nix gebracht, weil keine Tastatur. So hab ich ihn wieder ausgemacht
und die Card in den zweier gesteckt. der hatte nur das rote Lämpchen an und mein Fernseher sagte: "HDMI 3 KEIN SIGNAL.
Bei den anderen HDMI Ports das gleiche.

Kann mir bitte jemand helfen, damit ich keinen extra Adapter bestellen muss, oder geht das nicht weil der zero die SD
auf sich personalisiert oder verschlüsselt hat? Oder muss ich die Karte neu installieren und zuerst in den 2er stecken?



LG Einer der sich für Paluten ausgibt

User avatar
mahjongg
Forum Moderator
Forum Moderator
Posts: 12254
Joined: Sun Mar 11, 2012 12:19 am
Location: South Holland, The Netherlands

Re: Raspi 2 startet nicht

Tue May 07, 2019 7:44 pm

Ihr RPI-Start ist wahrscheinlich darauf zurückzuführen, dass Sie Ihr startfähiges Image auf Ihre SD-Karte nicht gut geschrieben haben. Andernfalls führt Ihr PI nichts aus und generiert kein Video. Ich habe alle verfügbaren Informationen in einer "sticky" post zusammengefasst, (the boot problem sticky, in trouble shooting, here: viewtopic.php?f=28&t=58151 ) die Sie mit Google Translate lesen können.

https://translate.google.nl/translate?s ... 6t%3D58151

User avatar
mline
Posts: 1307
Joined: Sun Jan 27, 2013 1:47 pm
Location: Austria, Vienna

Re: Raspi 2 startet nicht

Tue May 07, 2019 9:31 pm

Wenn ich deinen Post richtig deute, hast du die Pi Zero nicht mit dem Befehl

Code: Select all

sudo halt
sauber beendet sondern einfach das Netzteil ausgesteckt.

Du schreibst ja du konntest die Treiber nicht installieren (mit SSH wäre das ja kein Problem) und das du keine passende Tastatur hattest. Also konntest du das System nicht sauber herunterfahren.

Ich vermute also, mit dem Ausstecken hast du das Dateisystem auf der Speicherkarte zerstört und musst dieses nun entweder reparieren ( https://wiki.ubuntuusers.de/Dateisystem ... er-Konsole klappt allerdings nicht immer) oder ein neues Image auf die Speicherkarte schreiben und von Vorne anfangen.

Für die Zukunft:
Wenn du eine Pi Zero W hast, kannst du schon direkt nach dem Schreiben des Images auf die Speicherkarte die WLAN-Konfiguration festlegen und SSH aktivieren, wenn du auf der Partition "boot" zwei Dateien anlegst. Hier eine Anleitung:
https://www.raspberrypi.org/documentati ... eadless.md
Falls du eine Zero ohne WiFi hast, wäre es besser, wenn du die Updates/Konfiguration erst in einer anderen Pi machst und erst wenn alles fertig ist und funktioniert die Karte in die Zero gibst.


#############

Kann aber auch sein, dass die Speicherkarte einfach nur nicht richtig sitzt oder mit deiner Pi 2 nicht funktioniert. Wenn die Karte nicht erkannt wird und es keine lesbare boot-Partition gibt, passiert exakt genau das was du beschrieben hast: nix
<~~>

Return to “Deutsch”