lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

VPN-verbindung steht aber kein Ping

Thu Jun 07, 2018 9:26 am

Hallo liebe Leute :)

hab mich mal wieder an mein kleines Netzwerk gesetzt und ein ziemlich komisch Problem festgestellt.

Ich habe mir ein VPN eingerichtet und mich mit meinem Handy verbunden. Auf dem Telefon funktioniert auch alles.

Hab mir ein neues Key erstellt und auf meinen Laptop geschoben und dort das Problem das ich auf keinen meiner PI's über ssh Zugriff habe. eine IP bekomme ich und am Handy läuft es auch. woran kann es liegen?

Beste Grüße
Jeff :)

User avatar
DoM!niC
Posts: 19
Joined: Thu Jul 07, 2016 2:05 am
Location: In da Server Storage ^^ @Germany
Contact: Website Facebook Skype

Re: VPN-verbindung steht aber kein Ping

Thu Jun 07, 2018 8:57 pm

Hey ich werde dir gern helfen :D

Ich hab selbst zwei VPN Netzwerke mit OpenVPN am laufen einmal mit dem TUN Protokoll und einmal als TAP. Mein Netzwerk mit TUN ist ebenfalls für mein Smartphone mit Android oder andere Geräte angedacht, um meine IP getunnelt zu bekommen & alle relevanten Einschränkungen durch ggf. Hotspot Einstellungen zu umgehen. Außerdem habe ich zu meinen lokalen Netzwerk kompletten Zugriff, um extern auf relevante Dienste wie SSH / Remote whatever zugreifen zu können.

Am besten du postest deine Einstellungen mal hier rein als Code, damit kann man am Ende mehr aussagen & wichtig wäre auch welchen Client du am Handy verwendest.
DoM!niC Service's
Server / Network Developing
E-Mail: [email protected]
http://www.dom1nic.eu

lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

Re: VPN-verbindung steht aber kein Ping

Fri Jun 08, 2018 5:53 am

Am Handy funktioniert es. Komischer finde ich nur wenn ich mich mit meinem Laptop (auf dem Ubuntu 1804 läuft) verbinden will macht er das auch aber ich kann mit dem PC nix anpingen und bekomme auch so kein Netz. Außer ich habe parallel noch mein Handy in dem VPN. Dann kann ich das Handy anpingen.

Welche genau brauchst du?

lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

Re: VPN-verbindung steht aber kein Ping

Fri Jun 08, 2018 1:55 pm

also hier meine debug.txt

sollte eigentlich alles drin stehen

Code: Select all

:::					:::
::		PiVPN Debug		 ::
:::					:::
::	Latest Commit			 ::
:::					:::
commit b7c28af844d7a0fe0bbca5bf867c6f41863d2226
Merge: 8adbff7 d569034
Author: redfast00 <[email protected]>
Date:   Tue May 29 22:38:46 2018 +0200

    Merge pull request #541 from pivpn/test
    
    Merge test branch into master
:::					:::
::	Recursive list of files in	 ::
::	/etc/openvpn/easy-rsa/pki	 ::
:::					:::
/etc/openvpn/easy-rsa/pki/:
ca.crt
crl.pem
Default.txt
Hussler.ovpn
index.txt
index.txt.attr
index.txt.attr.old
index.txt.old
issued
jeffbox.ovpn
private
serial
serial.old
SmartphoneSamsungS8.ovpn
ta.key

/etc/openvpn/easy-rsa/pki/issued:
Hussler.crt
jeffbox.crt
server_Xz1oDMIE0Owqc03q.crt
SmartphoneSamsungS8.crt

/etc/openvpn/easy-rsa/pki/private:
ca.key
Hussler.key
jeffbox.key
server_Xz1oDMIE0Owqc03q.key
SmartphoneSamsungS8.key
:::					:::
::	Output of /etc/pivpn/*		 ::
:::					:::
:: START /etc/pivpn/DET_PLATFORM ::
Debian
:: END /etc/pivpn/DET_PLATFORM ::
:: START /etc/pivpn/INSTALL_PORT ::
11940
:: END /etc/pivpn/INSTALL_PORT ::
:: START /etc/pivpn/INSTALL_PROTO ::
udp
:: END /etc/pivpn/INSTALL_PROTO ::
:: START /etc/pivpn/INSTALL_USER ::
linaro
:: END /etc/pivpn/INSTALL_USER ::
:: START /etc/pivpn/NO_UFW ::
1
:: END /etc/pivpn/NO_UFW ::
:: START /etc/pivpn/pivpnINTERFACE ::
eth0
:: END /etc/pivpn/pivpnINTERFACE ::
:: START /etc/pivpn/setupVars.conf ::
pivpnUser=linaro
UNATTUPG=
pivpnInterface=eth0
IPv4dns=
IPv4addr=192.168.1.54
IPv4gw=192.168.1.1
pivpnProto=udp
PORT=11940
ENCRYPT=2048
APPLY_TWO_POINT_FOUR=true
DOWNLOAD_DH_PARAM=
PUBLICDNS=
OVPNDNS1=1.1.1.1
OVPNDNS2=1.0.0.1
:: END /etc/pivpn/setupVars.conf ::
:: START /etc/pivpn/setupVars.conf.update.bak ::
pivpnUser=linaro
UNATTUPG=unattended-upgrades
pivpnInterface=eth0
IPv4dns=meine-öffentliche-adresse
IPv4addr=192.168.1.54
IPv4gw=192.168.1.1
pivpnProto=udp
PORT=1194
ENCRYPT=2048
APPLY_TWO_POINT_FOUR=true
DOWNLOAD_DH_PARAM=
PUBLICDNS=
OVPNDNS1=1.1.1.1
OVPNDNS2=1.0.0.1
:: END /etc/pivpn/setupVars.conf.update.bak ::
:: START /etc/pivpn/TWO_POINT_FOUR ::
:: END /etc/pivpn/TWO_POINT_FOUR ::
:::					:::
:: /etc/openvpn/easy-rsa/pki/Default.txt ::
:::					:::
client
dev tun

proto udp
remote meine-öffnetliche-adresse 11940
resolv-retry infinite
nobind
persist-key
persist-tun
remote-cert-tls server
tls-version-min 1.2
verify-x509-name server_Xz1oDMIE0Owqc03q name
cipher AES-256-CBC
auth SHA256
compress lz4
verb 3
:::					:::
::	Debug Output Complete		 ::
:::					:::

User avatar
DoM!niC
Posts: 19
Joined: Thu Jul 07, 2016 2:05 am
Location: In da Server Storage ^^ @Germany
Contact: Website Facebook Skype

Re: VPN-verbindung steht aber kein Ping

Sat Jun 09, 2018 8:36 pm

Der PC ist aber auch im VPN verbunden oder ?

Wenn nicht musst, musst du den Pi als Gateway verwenden und IPForward v4 aktivieren, wenn PiVPN das nicht schon bereits getan hat um den Traffic zu routen. (dazu musst du kein VPN Client extra installieren)

Also ich bin jetzt kein Fan von fertigen Scripten, warum baust du den Server nicht fix von alleine mit einen simplen Auth Script ohne relevanten CRT Kram für jedes Gerät, also klar ist das die sicherste Methode aber eben auf die Masse gesehen sehr aufwendig.

Das Problem wird wohl eher am Routing liegen....

Check mal ob in der Server Config vorab dieser Befehl irgendwo steht.

Code: Select all

client-to-client

Wenn das nicht hilft, teste folgendes.... versuche mal eine feste IP festzulegen via CCD Ordner....
ergänze dies mal in deiner Server Config

Code: Select all

client-config-dir /etc/openvpn/ccd
Wenn du jeden Benutzer eine feste IP vergeben willst schaust in den ccd Ordner oder erstellst diesen, dort erstellst du leere Datei mit dem loginname (clientname) und öffnest diese mit einem Editor & fügst diese Zeile ein ifconfig-push 10.0.0.2 255.255.255.0 & speicherst.

Du musst aber die IP anpassen für dein Subnetz was du in deiner OpenVPN Server Config (pivpn.conf) einstellst. (Zeile mit server 10.0.0.0 255.255.255.0 ist damit gemeint)
DoM!niC Service's
Server / Network Developing
E-Mail: [email protected]
http://www.dom1nic.eu

lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

Re: VPN-verbindung steht aber kein Ping

Mon Jun 11, 2018 4:33 am

Ja also ich hab das Wochenende nochmal rumprobiert und ich hab es nur auf dem Telefon zum laufen bekommen. Werde mir heute abend mal ein Frisches OpenVPN aufsetzen.

Return to “Deutsch”