lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

PiVPN

Tue May 29, 2018 6:21 am

Hallo Leute

ich habe ein mittelschwere Problem und weis nichtmehr wirklch weiter.

Habe vor einiger zeit einen Pi gekauft und einen SMB-Dienst instliert. Alles OK

Paar wochen später habe ich von PiHole gehört. Damit auseinander gesetzt und intsalliert. Alles geht.

jetzt hab ich vor mir ein VPN aufzubauen und habe mich für PiVPN entschieden. Installation funktioniert, Er hört auf alle Ports die er soll und erstall auch die zertifikate richtig. Nun auf der Fritzbox angemeldert öffne ich die den Ports und leite diese an den definierten port für das PiVPN. Führe ich nun einen Port-check auf den port aus dann ist dieser aber nach außen immer noch geschlossen. Bin schon seit Tagen am probieren und tüfteln komme aber nichtmehr vorran.

Habe Testweise auch mal port 80 geöffnet und einen check darauf gemacht, dieser wurde mir dann auch korrekt, offen, angezeit.

Gruß
Jeff

MaxTheSpy
Posts: 116
Joined: Sat May 26, 2018 11:58 pm

Re: PiVPN

Tue May 29, 2018 7:31 pm

From google translate and my limited understanding of German, You may have to configure your WIFI router to allow IP Forwarding.
Ask Me About:
Plex Media Server (PMS)
RasPlex

antiager
Posts: 2
Joined: Tue May 29, 2018 9:59 pm

Re: PiVPN

Tue May 29, 2018 10:19 pm

Hast du in der Fritzbox eine Route gesetzt?

Wenn dein VPN bsbw. mit den Ips 10.0.0.0 255.255.255.0 arbeitet

musst du eine entsprechende Route in der Fbox setzen Gateway ist dann die IP des PI.

MfG RO

lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

Re: PiVPN

Wed May 30, 2018 4:38 am

Sorry bad english incomming:
yes i think i allowed the ip forwarding on port 1194 on my router, but if i check this, the tool say:"the port 1194 on your public ip is closed"

smartifahrer
Posts: 881
Joined: Sat Feb 13, 2016 8:10 am

Re: PiVPN

Wed May 30, 2018 7:55 am

Schau mal in den Einstellungen der Fritzbox nach Fernwartung und deaktiviere sie. AVM bietet auch ein DDNS dienst in Kombination mit eiem VPN Zugang auf der Frizbox an. Dieser VPN-Zugang eventuell aktiv (Default?) und verhindert so deine VPN Port Freigabe. Wenn du den eingebauten VPN-Zugang deaktiviertst so sollte deiner funktioniren.
Hatte die Tage das gleiche Problem. Leider kann ich dir nicht gerade sagen wo du die Einstellungen findest.

lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

Re: PiVPN

Wed May 30, 2018 8:15 am

Alles klar danke für die hilfe, ich weis das diese funktion noch aktiv ist. Ich schau heute abend mal und würde mich dann nochmal melden und vorerst danke :)

lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

Re: PiVPN

Wed May 30, 2018 2:00 pm

Also der eingebaute VPN zugang ist deaktiviert und es ändert sich nix :(

lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

Re: PiVPN

Wed May 30, 2018 2:03 pm

antiager wrote:
Tue May 29, 2018 10:19 pm
Hast du in der Fritzbox eine Route gesetzt?

Wenn dein VPN bsbw. mit den Ips 10.0.0.0 255.255.255.0 arbeitet

musst du eine entsprechende Route in der Fbox setzen Gateway ist dann die IP des PI.

MfG RO
öffnet das meinen port?

smartifahrer
Posts: 881
Joined: Sat Feb 13, 2016 8:10 am

Re: PiVPN

Wed May 30, 2018 2:21 pm

Hat dein Pi auch eine Feste IP?
In der Fritzbox musst du unter "Internet" -> "Freigaben" im Tab "Portfreigaben" auf den Button "Gerät für Freigaben hinzifügen" klicken und den Pi im Dialog unter Gerät auswählen bzw. seine IP eingeben. Darunter sind die Freigaben aufgelistet (leer) und dort kannst du die Freigaben einrichten. Die Ports (1194) sollten intern = extern sein, ist einfacher. Wichtig ist auch das Protokoll UDP.
Und immer schön auf auf "Ok" und Übernehmen Klicken ;-)

Wichtig wäre zu wissen was du eingestellt hat.

https://www.kuketz-blog.de/pivpn-raspbe ... -pi-teil3/

MaxTheSpy
Posts: 116
Joined: Sat May 26, 2018 11:58 pm

Re: PiVPN

Wed May 30, 2018 6:56 pm

This may help you with a static IP. Its taken from my HowTo found here


Step 9 - On RPi
Now to make a static IP address so it will stay the same so you just have to connect the one time. You need to find your IP, to do so complete the following in terminal:

Code: Select all

hostname -I
Copy your IP address or write it down and now we will add it to the cmdline.

Code: Select all

sudo nano /boot/cmdline.txt
now add the following to the cmdline.txt file at the end

Code: Select all

ip=YOUR IP HERE
now to save and exit: CTRL+X then y then enter.
Ask Me About:
Plex Media Server (PMS)
RasPlex

lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

Re: PiVPN

Thu May 31, 2018 4:57 am

Portfreigabe auf port 1194 mit dem protokol udp hab ich bei mir schon eingestellt, ja er hat auch eine feste ip, ich habe auf ihm ja auch den dhcp als pihole laufen. hab testweise http auf port 80 geöffnet und da funktionierte es auch. port 1194 will aber nicht.

i got the portforwarding on port 1194 with the protokol udp with the protocol udp, yes the pi have a static ip, it is the dhcp as pihole. for some tests i open port 80 for http and this was working, but port 1194 wont to work.

lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

Re: PiVPN

Thu May 31, 2018 5:01 am

smartifahrer wrote:
Wed May 30, 2018 2:21 pm
Hat dein Pi auch eine Feste IP?
In der Fritzbox musst du unter "Internet" -> "Freigaben" im Tab "Portfreigaben" auf den Button "Gerät für Freigaben hinzifügen" klicken und den Pi im Dialog unter Gerät auswählen bzw. seine IP eingeben. Darunter sind die Freigaben aufgelistet (leer) und dort kannst du die Freigaben einrichten. Die Ports (1194) sollten intern = extern sein, ist einfacher. Wichtig ist auch das Protokoll UDP.
Und immer schön auf auf "Ok" und Übernehmen Klicken ;-)

Wichtig wäre zu wissen was du eingestellt hat.

https://www.kuketz-blog.de/pivpn-raspbe ... -pi-teil3/
Nach dieser Anleitung bin ich auch vorgegangen. Ich vermute einfach das eine funktion in meiner Fritzbox den Port belegt. Nun frag ich mich aber welche da ich diese mir gekauft, mit meinem alten Router ersetzt hab, den dhcp ausgeschalten (das macht der pihole) und den vpn einrichten wollte.

smartifahrer
Posts: 881
Joined: Sat Feb 13, 2016 8:10 am

Re: PiVPN

Thu May 31, 2018 8:19 am

Hast du auf der Fritzbox noch ein Port Freigaben für ein anderes Gerät eingerichtet? Es gib da eine Option mit der alle Ports auf ein Gerät umgeleitet werden. Das trifft auch dann zu wenn du einzelne Ports an anderer Stelle definiert hast. War aktuell das Problem an einer Fixbox die ich eingerichtet habe.
Vielleicht hilft auch mal ein Neustart der Fritzbox.

lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

Re: PiVPN

Thu May 31, 2018 8:28 am

Also mein PI ist momentan der einzige der eine Portfreigabe bekommen hat. 1194udp/tcp

lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

Re: PiVPN

Tue Jun 05, 2018 3:39 pm

Also ich habe jetzt auch meinen einen 2. Pi mit PiVPN aufgesetzt und das selbe Problem.

Kann es daran liegen das noch ein switch dazwischen hängt?!

lazyjeff
Posts: 14
Joined: Tue May 29, 2018 6:08 am

Re: PiVPN

Tue Jun 05, 2018 4:17 pm

läuft kann geschlossen werden.

Robin Westpole
Posts: 28
Joined: Sat Apr 28, 2018 8:57 am

Re: PiVPN

Thu May 09, 2019 8:31 am

Hi

Kannst du bitte posten, wie du es zum laufen gebracht hast? Glaube ich habe so ziemlich das selbe Problem...
Raspberry Modell 3b+

Return to “Deutsch”