workuhol
Posts: 6
Joined: Fri Apr 13, 2018 10:50 am

Autostartproblem

Fri Apr 13, 2018 2:09 pm

Hi Leute
Ich bin ein Anfänger. Ich habe bei einer Geschäftsauflösung, 5 TFT Monitore 17" bekommen und wollte mir Bilderrahmen basteln.
Dazu möchte ich einen Raspberry 3 nehmen und nach dem Booten einen Bildschirmschoner laufen lassen der mir die Bilder von einem eingesteckten USB Stick holt und auf dem Monitor anzeigt.
Ich bin nach der Beschreibung von Pimylifeup https://pimylifeup.com/raspberry-pi-photo-frame/ vorgegangen und bin schon gefühlte 30 mal auf die Schnauze gefallen.

Im Prinzip brauche ich ein Betriebssystem, (vorhanden)

Code: Select all

sudo apt-get update
sudo apt-get upgrade
als nächstes öffne ich die Datei lightdm

Code: Select all

sudo nano /etc/lightdm/lightdm.conf
und verhindere das der Monitor nicht Schwarz wird, nach nicht benutzen.

Code: Select all

xserver-command=X -s 0 –dpms
Dann brauche ich ein Bidanzeige-Programm (feh)

Code: Select all

sudo apt-get install feh
und einen Befehl mit allen Parametern die ich brauche

Code: Select all

DISPLAY=:0.0 XAUTHORITY=/home/pi/.Xauthority /usr/bin/feh --quiet --preload --randomize --full-screen --reload 60 -Y --slideshow-delay 15.0 /media/pi/USBStick/Slideshow
Im Ordner Slideshow auf dem USBStick liegen die Bilder. Bis hierher klappt alles.

Jetzt lege ich mir eine Datei an,

Code: Select all

sudo nano /home/pi/start-picture-frame.sh
in dem ich den Befehl speichere.

Code: Select all

#!/bin/bash
DISPLAY=:0.0 XAUTHORITY=/home/pi/.Xauthority /usr/bin/feh -q -p -Z -F -R  60 -Y -D 15.0 /media/media/pi/USBStick/Slideshow
Ich probiere die Datei mit

Code: Select all

bash /home/pi/start-picture-frame.sh
Auch das funktioniert.

Jetzt kommt mein Problem. Ich öffne die Datei rc.local und schreibe VOR EXIT0

Code: Select all

sleep 10
bash /home/pi/start-picture-frame.sh &
Ich teste die Datei mit

Code: Select all

sudo sh -vx /etc/rc.local

und nichts geht mehr. Es kommt die Fehlermeldung: feh: No loadable images specified.
Ich habe schon viele Websites abgegrast und habe nichts oder nichts konkretes gefunden, obwohl das schon ein bekanntes
Problem sein muß.
Es kann doch nicht so schwer sein einen Befehl in eine Datei zu schreiben und die dann beim Starten des Pi's auszuführen.

Kann mir jemand sagen was ich falsch mache.

Gruß Workuhol

User avatar
DerKleinePunk
Posts: 33
Joined: Thu Feb 23, 2017 9:18 am
Location: Germany
Contact: Website

Re: Autostartproblem

Sat Apr 14, 2018 6:54 am

Mal ne blöde frage was hast du da für ein Betriebssystem drauf ?
Noch kein Systemd als Startmanager (sorry weiß nicht wie das richtigen nennen soll)

https://wiki.debianforum.de/Autorestart ... /erstellen
Zum Beispiel

Das zweite was ich denke ist das feh beim Test jetzt als root aus geführt wird und der dürfte keine Xorg Config haben.

Ich kann auch völlig falsch liegen.
PI 2 und PI 3 1GB Raspbian Strech
Der Wandel von Atom zum Bit ist unwiderruflich und nicht mehr aufzuhalten.
Nicholas Negroponte

ghans
Posts: 7792
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany

Re: Autostartproblem

Sat Apr 14, 2018 7:10 am

feh muss nach X mit der Desktopumgebung gestartet werden, nicht in der rc.local. feh ist davon abhängig, dass X bereits läuft. Die Desktopumgebung hat natürlich ihren eigenen Autostartmechanismus. Soweit ich mich entsinnen kann war es ein Ordner, in dem .desktop Dateien abgelegt werden. Alle diese .desktop Dateien werden dann
beim Start des Desktops ausgeführt.

ghans
• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere site:raspberrypi.org

workuhol
Posts: 6
Joined: Fri Apr 13, 2018 10:50 am

Re: Autostartproblem

Sat Apr 14, 2018 10:21 am

Hi Leute.
Danke für die schnelle Antwort. Ich hab das aktuellste Betriebsystem drauf.
Die Antwort von ghan leuchtet mir ein, weil bei diesem Betriebsystem ein Desktop-
Oberfläche vorhanden ist . Also muß ich zuerst feh starten. Ich dachte das ich das nicht
muß, so wie bei Windows. Da leg ich was in den Startordner und es wird automatisch
Gestartet.
Ich vergaß das Raspberry ein einfaches Betriebsystem ist.
Mit den .desktop Dateien muss ich mich noch einlesen . Ich hab mich so auf die rc.local
Eingeschossen.
Das heißt also das ich zuerst auf den Desktop booten MUSS um dann weiter zu machen.

Aber was ist mit dem X. Ich hab keine Ahnung von was du redest. Ich hab das
auch noch nicht gelesen.

Vielen Dank
Gruß
Workuhol

smartifahrer
Posts: 603
Joined: Sat Feb 13, 2016 8:10 am

Re: Autostartproblem

Sat Apr 14, 2018 11:01 am

Ich vergaß das Raspberry ein einfaches Betriebsystem ist.
Das ist sehr falsch gedacht!
Das Betriebsystem vom Raspberry nennt sich Rasbian. Es handelt sich hierbei um eine Debian Linux Distribution die fertig eingerichtet und alles mit bringt ws zum betrieb des Raspberry Pi gebraucht wird. Ubuntu und viele andere Linux Distribution basieren auch auf Debian. Ein Raspberry Pi mag nich so viel Rechenleistung wie ein Windows PC haben, aber aufgrund der verfügbaren Software (und Hardware) würde ich den Pi und Linux PCs als mächtiger betrachten als Windows in allen Variationen.

Mit X meinte ghans das X-Windows-System. Dies ist die Software die den Grundstock für den Grafischen Desktop ermöglicht (Grafikfunktionen). Zusammen mit einem Windowsmanager (Optik) der darauf aufsetzt und X ergänzt wir dann die Fertige Grafische Oberfläche vom Pi ähnlich dem was du von Windows oder OSX kennst. Der große Unterschied zu Windows ist, das die Grafische Oberfläche nicht fester untrennbarer Bestandteil des Betriebsystem ist und somit immer gestartet wird und Rechenleistung verbrät sonder wie zu zeiten von DOS + Windows 1 bis Windows 98 eigenständig instaliert und gestartet wird.
https://de.wikipedia.org/wiki/X_Window_System
https://de.wikipedia.org/wiki/Fenstermanager

X-Windows-Systeme können ihre Ausgaben auch einfach über ein Netwerk senden. Etwas zu dem die Windows Welt erst viele Jahre später fähig war.

Die Grafische Öberfläche basiert übrigens auf dem LXDE Windowsmanager https://lxde.org/

workuhol
Posts: 6
Joined: Fri Apr 13, 2018 10:50 am

Re: Autostartproblem

Sat Apr 14, 2018 12:15 pm

Danke smartifahrer
Das heißt also um feh in rc.local zu starten, brauche ich eine andere Linux
Version ohne Desktop. Sehe ich das richtig.
Dann müsste doch alles funktionieren.

Gruss
Workuhol

smartifahrer
Posts: 603
Joined: Sat Feb 13, 2016 8:10 am

Re: Autostartproblem

Sat Apr 14, 2018 1:59 pm

Nein, einfach den Desktop nicht starten :D
Mit raspi-config last es sich einstellen das der Pi bein starten nicht den Desktop lädt
https://www.raspberrypi.org/documentati ... -config.md

Ich würde dir empfehlen bei Rasbian zu bleiben. Wenn du kein Desktop (Libeoffice, Browser, ...) brauchst kanst du auch Rasbian Lite nehmen. Das benötigt weniger speicherplatz, kann aber sonst auch alles was das große Rasbian kann. Auserdem kannst du was fehlt jederzeit nachinstalieren. Den Desktop nachinstallieren ist aber aufwendig.
Bist du sicher das du nicht do den Dektop brauchst?

In deinem 1. Post hast du
Fehlermeldung: feh: No loadable images specified
geschrieben. Ich würde das so lesen das feh funktioniert aber die Bilder nicht finden kann. Z.B. weil zu diesem Zeitpunkt der USB-Stick noch nicht eingebunden ist.

workuhol
Posts: 6
Joined: Fri Apr 13, 2018 10:50 am

Re: Autostartproblem

Sat Apr 14, 2018 3:41 pm

Ok. Das heisst also für mich, ich muss das einbinden des USB Sticks, in der rc.local
Vor dem Aufruf meiner Datei platzieren oder gibt es eine andere Möglichkeit?
Das mit dem booten ohne den Desktop hab ich schon probiert. Das kann man ja unter Einstellungen ändern. Gleich unter dem Fenster in dem man den Anmeldenamen ändert,
Kann man auswählen: Desktop oder RCI oder wie das heisst. Funktioniert aber nicht.
Noch etwas. Ich bediene den Raspberry via Putty.

Gruß
Workuhol

ghans
Posts: 7792
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany

Re: Autostartproblem

Sun Apr 15, 2018 6:48 am

feh ist genauso wie der Desktop von X abhängig. Deswegen sollst du feh zusammen mit/nach dem Desktop starten.

Wenn du den Desktop deaktivierst deaktivierst du auch X. Wenn du eine Version Raspbians ohne Desktop benutzt fehlt auch X. In beiden Szenarien kann und wird feh nicht starten.

Hier ist eine Anleitung, wie man den Autostart von graphischen Programmen wie feh korrekt einrichtet:
viewtopic.php?t=139224

ghans
• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere site:raspberrypi.org

workuhol
Posts: 6
Joined: Fri Apr 13, 2018 10:50 am

Re: Autostartproblem

Sun Apr 15, 2018 2:46 pm

Hallo Leute.
Ich hab das jetzt so gemacht wie es in der Anweisung

Code: Select all

https://www.raspberrypi.org/forums/viewtopic.php?t=139224
Stand. Meine .sh hab ich mit

Code: Select all

@/path/to/your/script.sh
nach

Code: Select all

nano ~/.config/lxsession/LXDE-pi/autostart
Geschrieben. Hat aber nicht funktioniert.
Ich ging dann davon aus das der USB-Stick noch nicht angehängt war und hab
Den USB-Stick nach der Anweisung von

Code: Select all

https://jankarres.de/2013/01/raspberry-pi-usb-stick-und-usb-festplatte-einbinden/
eingebunden.
Raspberry gebootet. System startet im Abgesicherten Modus und ich kann nichts mehr
Bedienen.
Also alles wieder von vorne.

Gruss

Workuhol

ghans
Posts: 7792
Joined: Mon Dec 12, 2011 8:30 pm
Location: Germany

Re: Autostartproblem

Sun Apr 15, 2018 3:18 pm

Seitdem Raspbian systemd benutzt muss man anstatt von

Code: Select all

UUID=3241-40CE /media/usbstick/ vfat utf8,uid=pi,gid=pi,noatime 0
eher

Code: Select all

UUID=3241-40CE /media/usbstick/ vfat utf8,uid=pi,gid=pi,nofail,x.systemd.automount 0
schreiben. Besonders die Option nofail ist wichtig, sonst bricht der Bootvorgang ab wenn der Stick nicht eingesteckt ist.

ghans
• Don't like the board ? Missing features ? Change to the prosilver theme ! You can find it in your settings.
• Don't like to search the forum BEFORE posting 'cos it's useless ? Try googling : yoursearchtermshere site:raspberrypi.org

workuhol
Posts: 6
Joined: Fri Apr 13, 2018 10:50 am

Re: Autostartproblem

Mon Apr 16, 2018 10:44 am

Hi Leute

Ich habs hingekriegt. Ich hab das System neu aufgesetzt und ZUERST den USB Stick eingebunden.
Dann hab ich mit dem Link von ghan meine .sh Datei in den Desktop start eingefügt aber das hat
nicht funktioniert. Also, wie nach der Anleitung in den RC.LOCAL und das wars.

Funktioniert astrein.
Vielen Dank für eure Hilfe smartifahrer und ghan.

Falls jemand das ganze Projekt braucht
[email protected]

gruß workuhol

PS: warum muß man mehrmals Updaten und Upgrade
Ich habs 3 mal machen müssen bis kam 0 dateien heruntergeladen.

Return to “Deutsch”

Who is online

Users browsing this forum: No registered users and 4 guests