saschawaas
Posts: 14
Joined: Fri Jul 20, 2012 8:42 am

Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 7:29 am

Hallo beisammen,
ich habe ein Problem mit dem Kamera Modul. An einem Raspberry Pi 3 B läuft es ohne Probleme, ich kann Fotos und Videos aufnehmen.
An einem Raspberry Pi Zero W bekomme ich das Modul jedoch nicht dazu, irgendwas aufzunehmen.
Ich bekomme immer die folgende Fehlermeldung:

$ raspistill -o test1.jpg

mmal: No data received from sensor. Check all connections, including the Sunny one on the camera board

Wie gesagt, an einem Pi 3 B geht alles. Ich habe es auch schon mit einem zweiten Pi Zero W probiert, gleiches Ergebnis.

Ich denke, dass ich das Modul richtig angeschlossen habe (natürlich mit dem passenden Kabel für den Pi Zero W), da ich habe ich schon zig Tutorials durchgesehen.
Ich habe auch schon ein zweites Kabel probiert. Hat auch nix gebracht.
An der Stromversorgung wird es auch nicht liegen, weil ich das gleiche Netzteil wie auch beim Pi 3 B verwendet habe.
Ich habe natürlich das Modul in raspi-config eingeschaltet und einen Reboot gemacht. Ansonsten geht alles beim Pi Zero W, nur das Kamera Modul geht hier nicht.

sudo apt-get update
sudo apt-get upgrade
sudo rpi-udpate
habe ich auch gemacht

vcgencmd get_camera
liefert
supported = 1, detected = 1

Ich habe fast die Vermutung, dass der Pi Zero W hier zu schwach ist für das Kamera Modul.

Gibt es hier im Forum irgendjemanden, der das Kamera Modul erfolgreich am Pi Zero W laufen hat?

Danke schon mal für alles Antworten.

smartifahrer
Posts: 599
Joined: Sat Feb 13, 2016 8:10 am

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 8:46 am

Hallo, ich habe das Kamera Modul am meinen Zero W laufen.
Schau mal im englisch sprachigen Teil des Forums bzw. frag dort mal auf englisch.
viewforum.php?f=43

User avatar
mline
Posts: 1119
Joined: Sun Jan 27, 2013 1:47 pm
Location: Austria, Vienna

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 8:58 am

saschawaas wrote:
Wed Feb 14, 2018 7:29 am
Gibt es hier im Forum irgendjemanden, der das Kamera Modul erfolgreich am Pi Zero W laufen hat?
Ja, hier!

Hast du das Flachbandkabel auch ganz in die dafür vorgesehenen Buchsen geschoben? Die Kontakte dürfen kaum zu sehen sein.
Hier ein Foto meiner funktionierenden Pi Zero W + Camera Module v2

Image
<~~>

saschawaas
Posts: 14
Joined: Fri Jul 20, 2012 8:42 am

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 9:21 am

Ja, habe ich. Ich habe mich auch vorher immer entladen.

Keine Ahnung, was ich da falsch mache.

Also ich verstehe dich richtig: Bei dir geht es? Auch schon länger? Dann würde ja grundsätzlich Hoffnung bestehen, dass es überhaupt geht.

Ich habe einige Seiten im Internet gefunden, bei denen es so 1 Monat lang ging und dann plötzlich nicht mehr. Bei manchen ging es auch gar nicht.

Danke aber für deine Antwort.

saschawaas
Posts: 14
Joined: Fri Jul 20, 2012 8:42 am

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 9:24 am

Ich habe es jetzt auch mal mit meinem alten Pi (erste Edition Model B) probiert. Da geht es auch nicht (und ja, ich habe das Kabel in den richtigen Anschluss gesteckt und auch ganz rein gesteckt). An meinem Raspberry Pi 3 B geht es immer noch. Bin schon am verzweifeln....

saschawaas
Posts: 14
Joined: Fri Jul 20, 2012 8:42 am

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 9:48 am

Da es ja hier einige zu geben scheint, bei denen es geht suche ich nun woanders. Kann mir jemand, der Leute bei denen es geht schreiben, wo er das Anschlusskabel gekauft hat? Evtl. liegt es ja nur am Kabel. Da habe ich nur eines (für den Pi Zero W) zum ausprobieren.

User avatar
mline
Posts: 1119
Joined: Sun Jan 27, 2013 1:47 pm
Location: Austria, Vienna

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 9:55 am

Hab wie man am Foto sieht das original Kabel aus dem Gehäuse-Set für die Zero.

Da es an der Pi 3 ja offensichtlich funktioniert muss das Problem wohl eher an der Zero bzw dem Adapterkabel für die Zero zu suchen sein. Kennst du jemanden der auch ne Zero hat die du dir für Tests mal ausleihen kannst?
<~~>

saschawaas
Posts: 14
Joined: Fri Jul 20, 2012 8:42 am

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 10:00 am

Habe selber 2 Pi Zero W. Und bei beiden geht es nicht. Dass alle beide kaputt sind, glaube ich nicht. Kann es aber natürlich nicht ausschließen.
Ansonsten geht bei beiden alles. Leider kenne ich keinen, der einen Pi Zero W hat. Ich werde mit jetzt mal ein anderes Kabel für den Pi Zero W bestelllen und damit testen. Noch einen Pi Zero W mag ich nicht kaufen.....

saschawaas
Posts: 14
Joined: Fri Jul 20, 2012 8:42 am

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 10:10 am

Danke für den Hinweis in das englischsprachige Forum.
Das hier schaut vielversprechend aus: viewtopic.php?f=43&t=160611
Das werde ich mir mal ansehen.

smartifahrer
Posts: 599
Joined: Sat Feb 13, 2016 8:10 am

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 10:16 am

Ich habe auch das Kabel aus dem Gehäuse-Set im Einsatz. Untersuche das Kabel mal mit einer Lupe auf Risse an den Leiterbahnen. Vielleicht hast du ein Kabelbruch. Hast du das Kabel mal geknickt?

saschawaas
Posts: 14
Joined: Fri Jul 20, 2012 8:42 am

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 10:33 am

Das Kabel habe ich schon untersucht. Einen Knick habe ich nicht drin. Und die Leiterbahnen sehen auch gut aus.

User avatar
mline
Posts: 1119
Joined: Sun Jan 27, 2013 1:47 pm
Location: Austria, Vienna

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 11:22 am

saschawaas wrote:
Wed Feb 14, 2018 10:10 am
Danke für den Hinweis in das englischsprachige Forum.
Das hier schaut vielversprechend aus: viewtopic.php?f=43&t=160611
Das werde ich mir mal ansehen.
Als der Beitrag verfasst wurde, gabs Pi Zero W noch garnicht. Ausprobieren kannst es ja mal aber ich glaube (hoffe) nicht, das sie bei dieser Revision nicht den selben Fehler gemacht haben :D
<~~>

saschawaas
Posts: 14
Joined: Fri Jul 20, 2012 8:42 am

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 12:20 pm

Oh. Danke für den Hinweis.

User avatar
mline
Posts: 1119
Joined: Sun Jan 27, 2013 1:47 pm
Location: Austria, Vienna

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 1:07 pm

Sind eigentlich alle 3 Produkte original von der Raspberry Pi Foundation?

Also RPi vermutlich schon https://www.raspberrypi.org/products/ra ... pi-zero-w/
Kamera https://www.raspberrypi.org/products/camera-module-v2/ bzw. das alte Modul jeweils auch als NoIR verfügbar
Gehäuse mit kurzem (Adapter-)Flachbandkabel https://www.raspberrypi.org/products/ra ... zero-case/ zu sehen auf meinem Foto oben.
<~~>

saschawaas
Posts: 14
Joined: Fri Jul 20, 2012 8:42 am

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 1:11 pm

Keine Ahnung. Habe alle Pi-Sachen bis jetzt hier gekauft: https://shop.pimoroni.de/

Also, es sind keine China-Klone oder so.

User avatar
mline
Posts: 1119
Joined: Sun Jan 27, 2013 1:47 pm
Location: Austria, Vienna

Re: Kamera Modul Problem mit Pi Zero W

Wed Feb 14, 2018 1:36 pm

Poste doch bitte mal Links zu allen Produkten
<~~>


smartifahrer
Posts: 599
Joined: Sat Feb 13, 2016 8:10 am

Re: Kamera Modul Problem mit Pi Zero W

Thu Feb 15, 2018 12:35 pm

Hatte versehentlich den falschen Link eingefügt. Es sollte der Link zum "Camera board" sein. Also die Themen Übersicht.
viewforum.php?f=43

saschawaas
Posts: 14
Joined: Fri Jul 20, 2012 8:42 am

Re: Kamera Modul Problem mit Pi Zero W

Thu Feb 15, 2018 1:08 pm

Ok. Danke.

saschawaas
Posts: 14
Joined: Fri Jul 20, 2012 8:42 am

Re: Kamera Modul Problem mit Pi Zero W

Mon Feb 19, 2018 1:25 pm

So nun habe ich nochmals einen neuen Pi Zero W gekauft und siehe da. Es geht. Schon komisch, dass 2 der Pi Zero Ws kaputt waren.....
Naja, hauptsache es geht nun.

Return to “Deutsch”

Who is online

Users browsing this forum: No registered users and 12 guests