criostage
Posts: 7
Joined: Wed Jan 30, 2013 2:00 pm

Problemas com Raspberry pi

Mon Feb 04, 2013 12:55 pm

Bons dias a todos,

Gostaria de pedir um pouco de ajuda a solucionar um problema com o Raspberry Pi que tenho tido com o meu. O que acontece é, ligo o raspberry pi com o cabo de rede, cartão SDHC com Raspbian e a fonte de alimentação claro e apartir daqui ele arranca com o sistema operativo que está cartão, ora passados entre +- 30Min~13Horas (medi estes tempos com um programa uprecords-cgi, que gere e mostra quais os tempos mais altos de uptime) o Raspberry pi desliga-se ficando apenas com a luz de power sempre ligada. O raspberry pi volta ao normal após o desligar da corrente e voltar a ligar e aguenta-se por mais uns tempinhos assim.

Eu já tinha postado nos forums ingleses e eles disseram-me que poderia ser problemas com o adaptador de corrente. Seguindo esta pista comprei e devolvi uns quantos adaptadores de corrente ... mas infelizmente a minha situação mantem-se, Alguns adaptadores que usei ...
  • Alguns de linha branca de 5v e 1a~1.5a
  • Duracel Travel Charger 5v 1A
  • Carregador do meu telemovel Samsung Galaxy Nexus 5V 1A
  • Carregador do meu tablet ZTE V9C de 5V 1.5A
A minha pergunta é existe algum que voces utilizem e que sabem que funciona? ou esta situação pode ser derivada de outra situaçao? Agradeço alguem que me possa dar uma pequena ajuda ..

Já agora uma pequena nota, eu comprei o raspberry pi para ser o meu webserver la em casa para applicações PHP (desenvolvimento e uso), não tenho assim nada para verificar a voltagem dos carregadores ou do proprio raspberry pi quando ligado.

User avatar
Montekuri
Posts: 448
Joined: Thu Sep 22, 2011 6:26 pm
Contact: Website

Re: Problemas com Raspberry pi

Mon Feb 04, 2013 2:27 pm

Tente usar outro cartão SD.
Aqui no Brasil eu uso um carregador de 5V e 1,5 A de marca nacional (COMTAC).
E uso cartões da marca DANE e SANDISK.
Uso o Raspberry Pi como media player e funciona durante horas sem parar.

criostage
Posts: 7
Joined: Wed Jan 30, 2013 2:00 pm

Re: Problemas com Raspberry pi

Mon Feb 04, 2013 2:54 pm

Montekuri wrote:Tente usar outro cartão SD.
Aqui no Brasil eu uso um carregador de 5V e 1,5 A de marca nacional (COMTAC).
E uso cartões da marca DANE e SANDISK.
Uso o Raspberry Pi como media player e funciona durante horas sem parar.
Olá Montekuri, obrigado pela sugestão mas infelizmente essa foi uma das primeiras coisas que testei porque quase todo o tipo de dispositivo (Smartphones, tablets, etc ...) usam cartões SDHC ou microSD o que torna facil trocar e ver se funciona ou não, para minha desgraça o resultado foi exactamente o mesmo.

A falha foi realmente minha porque como tenho lido muita coisa sobre problemas com a alimentação do raspberry pi, esquecime de adicionar ao post que já tinha realizado este teste. :?

pksato
Posts: 273
Joined: Fri Aug 03, 2012 5:25 pm
Location: Brazil

Re: Problemas com Raspberry pi

Mon Feb 04, 2013 9:30 pm

Ola,
Faça um teste de memoria usando o memtester (não o memtest86 ou memtest86+).
Talvez tenha que instalar,
sudo aptitude install memtester
depois rodar especificando a quantidade de memoria a ser testada, pode colocar um valor maior, que o programa se ajusta
memtester 192M

User avatar
tonyhughes
Posts: 951
Joined: Wed Dec 26, 2012 3:46 am

Re: Problemas com Raspberry pi

Mon Feb 04, 2013 9:35 pm

Are you overclocking your Pi? This can lead to SD card related problems. If so, turn your overclock off, and try again...

criostage
Posts: 7
Joined: Wed Jan 30, 2013 2:00 pm

Re: Problemas com Raspberry pi

Tue Feb 05, 2013 12:33 am

Olá pksato, eu tentei fazer o que me indicaste mas não sei porque o raspberry pi hoje não se aguenta 5min ligado (mesmo so com o cabo de power) com as mesmas fontes de alimentação que indiquei no primeiro post ... tou a axar isto cada vx mais estanho .... mas amanha vou tentar outra vez a ver se tenho mais sorte ... ando a procurar alguem que me possa emprestar um voltimetro.

Se não der em nada ligo para a RS Compoments a ver o que eles podem fazer..

Hey tonyhughes, no my raspberry pi isn't overclocked at the moment, i did tried on the day it arrived overclock it to 800Mhz to see if there was any big change in performance but ended up in reverting after it's first crash (it was in my hands no longer than 1 hour when i got it from the post office).

criostage
Posts: 7
Joined: Wed Jan 30, 2013 2:00 pm

Re: Problemas com Raspberry pi

Tue Feb 05, 2013 4:24 pm

Olá a todos,

Levei o meu raspberry pi a uma pessoa (e que percebe mais de circuitos electricos que eu) na empresa onde trabalho, e após analize e comparação com a WiKi parece que o fusivel F3 (junto a entrada microUSB) está queimado, e explica os problemas que tenho vindo a ter de ele estar constantemente a ir a baixo por falta de corrente.

Levei os transformadores que use, e os 2 primeiros (o carregador do Samsung Galaxy Nexus dá 4.98v e o carregador do ZTE da 5.09v) davam mais que suficiente para o Raspberry pi funcionar normalmente. Sendo assim vou ter de entrar em contato com o pessoal da RS a ver se tenho alguma sorte .... Agradeço a todos que tentaram ajudar qualquer das maneiras

Serginhoromanini
Posts: 1
Joined: Sun Apr 09, 2017 10:45 am

Re: Problemas com Raspberry pi

Sun Apr 09, 2017 11:05 am

Olá Criostage:

Apesar do tópico see antigo, espero ainda poder fazer o contato.
Comprei um Raspberry pi 3 b recentemente, eu estava na Europa e recebi por la, mas comprei por um site que vem da China, através de navios. Meu aparelho desligando, como o seu fazia, apos aproximadamente 30 min.
Tentei tudo que citou, será que o meu problema é o mesmo do seu? Apos tanto tempo resolved isso? Se alguem mais puder, por favor me ajudem a tentar usar meu Raspberry sem ligar e desligar sozinho.
Muito obrigado pessoal !!

Pinduk
Posts: 1
Joined: Wed Oct 11, 2017 7:41 pm

Re: Problemas com Raspberry pi

Wed Oct 11, 2017 7:45 pm

Boa tarde Pessoal

Estou com o mesmo problema citado, alguem conseguiu alguma solução?

User avatar
ozamatheus
Posts: 9
Joined: Thu Oct 05, 2017 10:24 pm
Location: hu3zil

Re: Problemas com Raspberry pi

Fri Oct 13, 2017 5:57 pm

Serginhoromanini wrote: Olá Criostage:

Apesar do tópico see antigo, espero ainda poder fazer o contato.
Comprei um Raspberry pi 3 b recentemente, eu estava na Europa e recebi por la, mas comprei por um site que vem da China, através de navios. Meu aparelho desligando, como o seu fazia, apos aproximadamente 30 min.
Tentei tudo que citou, será que o meu problema é o mesmo do seu? Apos tanto tempo resolved isso? Se alguem mais puder, por favor me ajudem a tentar usar meu Raspberry sem ligar e desligar sozinho.
Muito obrigado pessoal !!
Pinduk wrote: Boa tarde Pessoal

Estou com o mesmo problema citado, alguem conseguiu alguma solução?
O tópico é meio antigo então acho que ele se referia a um raspberry pi1 ou pi2. só pra lembrar o pi3 pede 2.5A de corrente.
Pra solucionar vcs podem retirar os overclocks, testar outra fonte ou formatar o sd ou talvez ligar ele sem estar conectado a nada exceto monitor pra acompanhar o que acontece. se resolver e nao desligar, reinicie o Pi com outra coisa ligada (teclado por exemplo) e então ligue pra testar. É o procedimento que eu sigo com PCs pra diagnostico basico mas a lógica é a mesma.
R-Pi 3 model B + 5v 3A suply ------ SSD 128gb + 5V 2A supply
BerryBoot = Retropie + OpenElec + Raspbian
Some Overclok and luck

Return to “Português”

Who is online

Users browsing this forum: No registered users and 3 guests