Page 1 of 1

Pi 3 - Jack audio only, No picture, EDID help needed

Posted: Tue May 29, 2018 8:51 pm
by ninjaEF
So, Raspberry Pi3 + Digihome 42" LED TV. + Lineage 14.1 OS (Android).

Ive got sound but only through the jack, no sound or video picture on the TV. The desktop is fine, can see all the icons, interact with the pointer, just cant see any video output. I've tried adjusting config.txt but the magic sweet combination hasnt been found despite using varioud HDMI/EDID settings.

I recall seeing on these forums , in a thread , that someone developed a tool to query the EDID blob. Can anyone help please, by referring his name to me or, help me directly to figure out what my EDID blob is for my TV

Re: Pi 3 - Jack audio only, No picture, EDID help needed

Posted: Tue May 29, 2018 9:47 pm
by drgeoff
ninjaEF wrote:
Tue May 29, 2018 8:51 pm
So, Raspberry Pi3 + Digihome 42" LED TV. + Lineage 14.1 OS (Android).

Ive got sound but only through the jack, no sound or video picture on the TV. The desktop is fine, can see all the icons, interact with the pointer, just cant see any video output. I've tried adjusting config.txt but the magic sweet combination hasnt been found despite using varioud HDMI/EDID settings.

I recall seeing on these forums , in a thread , that someone developed a tool to query the EDID blob. Can anyone help please, by referring his name to me or, help me directly to figure out what my EDID blob is for my TV
I don't understand what you mean by "The desktop is fine, can see all the icons, interact with the pointer, just cant see any video output." I think you mean that moving video does not appear on the same screen.

If you can see anything on a device connected to the HDMI socket on the RPi then adjusting HDMI/EDID settings is not going to help. The problem is with your software which, being Android, is not supported here.

Re: Pi 3 - Jack audio only, No picture, EDID help needed

Posted: Wed May 30, 2018 7:52 am
by ninjaEF
Er, why do you say that. The config.txt values are no OS specific in this case; the EDID blob is the same irrespective of "supported" OS - or not. Further, the config.txt parameters would be the same for any OS I wish to install on a Pi given this is how the Pi is configured. If you dont understand then maybe you shouldnt be posting a reply.

All I asked was for the member name who has the ability to decode EDIDs really, and Im not looking to troubleshoot android, but rather my EDID !!

EDIT: Meanwhile, a bit more effort and voila!
"edidparser"
viewtopic.php?t=103011


drgeoff wrote:
Tue May 29, 2018 9:47 pm
ninjaEF wrote:
Tue May 29, 2018 8:51 pm
So, Raspberry Pi3 + Digihome 42" LED TV. + Lineage 14.1 OS (Android).

Ive got sound but only through the jack, no sound or video picture on the TV. The desktop is fine, can see all the icons, interact with the pointer, just cant see any video output. I've tried adjusting config.txt but the magic sweet combination hasnt been found despite using varioud HDMI/EDID settings.

I recall seeing on these forums , in a thread , that someone developed a tool to query the EDID blob. Can anyone help please, by referring his name to me or, help me directly to figure out what my EDID blob is for my TV
I don't understand what you mean by "The desktop is fine, can see all the icons, interact with the pointer, just cant see any video output." I think you mean that moving video does not appear on the same screen.

If you can see anything on a device connected to the HDMI socket on the RPi then adjusting HDMI/EDID settings is not going to help. The problem is with your software which, being Android, is not supported here.

Re: Pi 3 - Jack audio only, No picture, EDID help needed

Posted: Wed May 30, 2018 8:13 am
by DougieLawson
On Raspbian you can easily read and parse edid with

tvservice -d /tmp/edid; parse-edid < /tmp/edid | less