Posts: 3
Joined: Tue Nov 07, 2017 10:31 pm

How to vnc into google's aosp android install on rpi3?

Sun Nov 12, 2017 11:47 am

I am able to

Code: Select all

adb connect <ip>
to the pi but I have no screen on it and don't know how to run apps from the command line.

I have installed droidvnc but for some strange reason there are no binaries in the folder in order to do a direct app run on command line. I look in the com. folder and there is just two empty folders of cache and code_cache with nothing in them. However it isn't a problem with the os I dont think because I tested installng the odroid app on an emulator and looking in the same folder and the were still empty however on the emulator I can click the icon from the gui and it runs fine which ofc I can't do on the headless pi.

Below is the output I got when I tried the command I found online for running an app from the command line yet there was still no server running after that iirc (was some days ago and was trying many things to no avail).

Code: Select all

$adb shell monkey -p org.onaips.vnc -c android.intent.category.LAUNCHER 1
	  bash arg: -p
	  bash arg: org.onaips.vnc
	  bash arg: -c
	  bash arg: android.intent.category.LAUNCHER
	  bash arg: 1
	args: [-p, org.onaips.vnc, -c, android.intent.category.LAUNCHER, 1]
	 arg: "-p"
	 arg: "org.onaips.vnc"
	 arg: "-c"
	 arg: "android.intent.category.LAUNCHER"
	 arg: "1"
	** SYS_KEYS has no physical keys but with factor 2.0%.
So can anyone offer me some new thoughts on how I might get a vnc server running on the google aosp android install or how else I could get a visual display with no monitor?

Return to “Android”