RAZERZ
Posts: 57
Joined: Mon Jun 13, 2016 4:56 pm

[fix] disable poppup on plugging in external device

Mon Aug 29, 2016 6:28 pm

Story time:

Hello friends, I got adb (and android thing) working on the pi and I was happy to try to use it on my phone to the pi.
I started adb and just so I didn't have to type ./adb I moved the adb file to /usr/local/bin.
Then, I issued the first command that probably everyone issues to see if their device(s) is recognized.
"adb devices" and my device showed up. So I decided to see if I could control my phone so I tested with a reboot by running "adb reboot" and it worked but since I din't confirm the "allow MTP access" dialog on my phone I constantly got a new window saying "external device connected bla bla bla..." so I wanted to disable this. Took me a while to find a solution but now that I have it, I don't want anyone going around closing a bunch of windows that open up every second so lets share it!

Fix;

Open the GUI file manager and hit in the top left corner, "edit" then click "preferences" then click "Volume management" and untick the third option.

Hope that solved your issue and good day :D

Moderators, kindly move this thread if it is in the wrong forum, thank you.
Raspberry pi 3 set up as desktop with raspbian.
I guess you can say I am not newbie with linux but I am not a master at it either.
I will always try to help you as much as I can because I know how hard it is to run into problems :D

Return to “Android”