xlar54
Posts: 50
Joined: Tue Aug 20, 2013 5:08 am

uspi library

Thu May 28, 2015 6:08 am

Hey Rst, first, thank you very much for your work on this and Circle. If you ever wonder if people actually try these things out, we definitely do!

I am having an issue with your uspi samples. Ive tried the keyboard and others, but I only get a blank screen. Pressing keys does nothing as well. I made sure to get the latest boot files from the link you provided in the git page. Replacing the kernal.img with a different one for my own project works fine. Might there be specific config file settings that needs to be set for this to boot? Also, no rainbow screen and my monitor indicates that it has a signal, so it just appears nothing is happening. I also get this same behavior compiling and running Circle. My setup is the yargato toolchain on Windows, which seems to be working on with other projects.

Thanks again!

rst
Posts: 415
Joined: Sat Apr 20, 2013 6:42 pm
Location: Germany

Re: uspi library

Thu May 28, 2015 2:08 pm

xlar54 wrote:Hey Rst, first, thank you very much for your work on this and Circle. If you ever wonder if people actually try these things out, we definitely do!
Thank you! Good to know!
I am having an issue with your uspi samples. Ive tried the keyboard and others, but I only get a blank screen. Pressing keys does nothing as well. I made sure to get the latest boot files from the link you provided in the git page. Replacing the kernal.img with a different one for my own project works fine. Might there be specific config file settings that needs to be set for this to boot? Also, no rainbow screen and my monitor indicates that it has a signal, so it just appears nothing is happening. I also get this same behavior compiling and running Circle. My setup is the yargato toolchain on Windows, which seems to be working on with other projects.
I have tried the keyboard sample with the latest firmware on a Raspberry Pi 1 Model B and Pi 2 and everything works all right. The files config.txt and cmdline.txt are normally not needed.

So this could be a toolchain issue. I'm using this toolchain on Linux. Unfortunately I haven't tried Yargato and it's difficult for me to test this with all those toolchains available out there. Perhaps I can do this later with Yargato. For now I will open an issue on GitHub for this problem to track it.

xlar54
Posts: 50
Joined: Tue Aug 20, 2013 5:08 am

Re: uspi library

Fri May 29, 2015 1:51 am

Great thanks. Ill update you if I learn anything new.

rst
Posts: 415
Joined: Sat Apr 20, 2013 6:42 pm
Location: Germany

Re: uspi library

Sun May 31, 2015 5:54 pm

xlar54 wrote:Ill update you if I learn anything new.
Thanks!

I have installed Yagarto from this installer and GNU Make and build the keyboard sample on Windows. But sorry, it is working well on the Pi 1 and Pi 2. I cannot reproduce this problem. Currently I do not know what to do about this anymore.

kriss
Posts: 66
Joined: Thu Apr 02, 2015 8:53 pm
Location: france for now ...

Re: uspi library

Thu Jun 04, 2015 8:30 am

maybe sync after write the sd is enough ?!?

Return to “Bare metal, Assembly language”