GowthamP
Posts: 8
Joined: Thu Dec 15, 2016 5:38 am

Raspberry pi bluetooth.service failure

Tue Feb 28, 2017 3:30 pm

I have created a custom linux embedded image for raspberry-pi3 for bluetooth communication between rpi and hci 05 bluetooth module connected to arduino. I tried to start bluetooth by using "systemctl start bluetooth", it fails to start repeatedly. When i put systemctl it shows that my bluetooth.service failed to load or running. If i get it up and running i can start my bluetooth in raspberry pi 3. Is this anyway related to UART which i use. Currently my raspberry has Bcm43438.service which has the following code hciattach -n /dev/ttyAMA0 bcm43xx 921600 noflow - and Brcm43438.service successfully gets loaded and it is up and running. it seems to use ttyAMA0 as it is the default one. But i am really not sure why or how it fails. Only my bluetooth.service fails to start. Even if try to manually start bluetooth by invoking the bluetoothd daemon it fails. In the systemctl image which i attached we can see that a signal Kill is received and bluetooth.service was killed. I do not know why.

I want to know why i am unable to start my bluetooth. Is there any solution to get it working on my image?

cranz3242
Posts: 4
Joined: Mon May 08, 2017 7:36 am
Location: Philippines
Contact: Website

Re: Raspberry pi bluetooth.service failure

Mon May 08, 2017 11:28 am

I too have the same problem but can not further test it bz lack of time... may i know your setup when your connecting to rpi3 board? is it thru ssh via ethernet/wifi or via a serial cable? :)
if via serial cable i encounter this problem.. I haven't tried further testing it by not using a serial cable and some modification about uart and bluetooth.

Return to “Linux Kernel”

Who is online

Users browsing this forum: No registered users and 3 guests