GowthamP
Posts: 8
Joined: Thu Dec 15, 2016 5:38 am

Yocto Pulseaudio build issue

Wed Jan 11, 2017 12:36 pm

Hi,
I am using Raspberry pi 3 model B.

I am facing build issue while building bitbake pulseaudio. Please find my configuration details:

1) Yocto : Jethro branch

2) pulseaudio.inc
RDEPENDS_pulseaudio-server += "alsa-plugins-pulseaudio-conf"

3) we are using alsa-plugins_1.0.29.bb
4) bitbake pulseaudio

ERROR: Nothing RPROVIDES 'alsa-plugins-pulseaudio-conf' (but /home/guest/openembedded-core/meta/recipes-multimedia/pulseaudio/pulseaudio_6.0.bb RDEPENDS on or otherwise requires it)
NOTE: Runtime target 'alsa-plugins-pulseaudio-conf' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['alsa-plugins-pulseaudio-conf']
ERROR: Required build target 'pulseaudio' has no buildable providers.
Missing or unbuildable dependency chain was: ['pulseaudio', 'alsa-plugins-pulseaudio-conf']



Please provide me a solution to build pulseaudio into the image.


5) Please share yours input to proceed.

YCN-
Posts: 246
Joined: Fri Jun 10, 2016 3:18 pm

Re: Pulseaudio build issue

Mon Jul 03, 2017 11:50 am

Hi,

Did you find out ? I'm facing the same issue when trying to install pulseaudio...

YCN-

YCN-
Posts: 246
Joined: Fri Jun 10, 2016 3:18 pm

Re: Pulseaudio build issue

Tue Jul 04, 2017 7:38 am

I solved this problem. In the end it has something to do with dependency, since pulseaudio and alsa will both do some changement on other packet, you have to add pulseaudio in build/conf/local.conf : DISTRO_FEATURES = "ext2 pam opengl usbhost ${DISTRO_FEATURES_LIBC} pulseaudio "

If that's not clear feel free to ask.

YCN-

SherifOmran
Posts: 10
Joined: Thu Jan 17, 2013 6:08 am

Re: Pulseaudio build issue

Mon Mar 26, 2018 2:48 pm

hello Ycn

do we need to add other dependencies for the pulseaudio to compile like Image_install_append?

thank you

SherifOmran
Posts: 10
Joined: Thu Jan 17, 2013 6:08 am

Re: Yocto Pulseaudio build issue

Tue Mar 27, 2018 12:24 pm

to add pulseaudio, we need to add the following to local.conf
IMAGE_INSTALL_append += " pulseaudio-server "
Last edited by SherifOmran on Tue Mar 27, 2018 12:26 pm, edited 1 time in total.

SherifOmran
Posts: 10
Joined: Thu Jan 17, 2013 6:08 am

Re: Yocto Pulseaudio build issue

Tue Mar 27, 2018 12:25 pm

what about the bluetooth module, could you load it someway?

Return to “Other”