DFansler
Posts: 8
Joined: Sun Aug 31, 2014 12:14 pm
Location: North Carolina, USA
Contact: Website

openvg fails to install

Thu Jan 18, 2018 1:36 am

I just reinstalled Jessie with Stretch on my Raspberry Pi. I had been using AJStarks openvg prior ( just Jessie) to reinstalling the os without problem. But now that I have installed the new OS.

I started with
sudo apt-get install libjpeg8-dev indent libfreetype6-dev ttf-dejavu-core

followed by
git clone git://github.com/ajstarks/openvg
cd openvg
make
from make I get

gcc -O2 -Wall -I/opt/vc/include -I/opt/vc/include/interface/vmcs_host/linux -I/opt/vc/include/interface/vcos/pthreads -fPIC -c libshapes.c
gcc -L/opt/vc/lib -lEGL -lGLESv2 -ljpeg -shared -o libshapes.so oglinit.o libshapes.o
Makefile:35: recipe for target 'library' failed

this is the output after already having run make previously - I think it had more statements before.

Any ideas on what I am doing wrong?
Thanks,
David

User avatar
Paeryn
Posts: 2107
Joined: Wed Nov 23, 2011 1:10 am
Location: Sheffield, England

Re: openvg fails to install

Thu Jan 18, 2018 10:57 am

You need to edit the Makefile slightly, the library names for GLESv2 and EGL changed (they had in Jessie but back then the old names were still in use as well). Where it links the files you need to change the

Code: Select all

-lGLESv2 -lEGL
to

Code: Select all

-lbrcmGLESv2 -lbrcmEGL
She who travels light — forgot something.

DFansler
Posts: 8
Joined: Sun Aug 31, 2014 12:14 pm
Location: North Carolina, USA
Contact: Website

Re: openvg fails to install

Fri Jan 19, 2018 10:23 am

Thanks so much for your quick and accurate reply. After making the suggested changes, openvg installed without a problem.
Kind regards,
David

DFansler
Posts: 8
Joined: Sun Aug 31, 2014 12:14 pm
Location: North Carolina, USA
Contact: Website

Re: openvg fails to install

Sat Jan 20, 2018 3:41 am

What do I need to put in my makefile for openvg. I am getting compile errors about not being able to find -iEGL and -lGLESv2
Thanks
David

DFansler
Posts: 8
Joined: Sun Aug 31, 2014 12:14 pm
Location: North Carolina, USA
Contact: Website

Re: openvg fails to install

Sat Jan 20, 2018 3:50 am

oh never mind. i put in the same thing you had suggested for the makefile for the installation and it works.
David

Return to “OpenVG”

Who is online

Users browsing this forum: No registered users and 2 guests