jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 23867
Joined: Sat Jul 30, 2011 7:41 pm

Re: Web shader toys don't work - too advanced for RPi4?

Wed Oct 09, 2019 4:21 pm

Some work, some don't.

We have people working on increasing the support in this area, but some of these shaders require huge amount of memory and very powerful GPU's.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

pik33
Posts: 182
Joined: Thu Sep 10, 2015 4:26 pm

Re: Web shader toys don't work - too advanced for RPi4?

Sun Oct 13, 2019 9:54 am

A strange thing.

The shader I linked in the first post works on RPi3 and doesn't work (displaying a black screen) on RPi4

User avatar
Gavinmc42
Posts: 3874
Joined: Wed Aug 28, 2013 3:31 am

Re: Web shader toys don't work - too advanced for RPi4?

Sun Oct 20, 2019 11:41 am

Try this one.
http://editor.thebookofshaders.com/
The GLSLViewer works as well.
I'm using Gentoo64 so other OS users experience might vary.

Kodelife works too but could not handle the cloud /smoke example. :(
Probably some slight difference in GLSL handling.

Anyway The Book of Shaders seems to be on my wavelength.
But it stops just when it is getting really interesting :(
Still there is enough to keep me busy for a few years.
I'm dancing on Rainbows.
Raspberries are not Apples or Oranges

Return to “OpenGLES”