kingbox1
Posts: 15
Joined: Fri Mar 29, 2019 6:21 am

OpenGL EGL not working on Pi4??

Wed Aug 14, 2019 5:59 am

Hi All
My programe is using OpenGL EGL, it works on pi3 and crashes on pi4 , it crashes at eglGetDisplay(EGL_DEFAULT_DISPLAY). I tried to build those sample code under /opt/vc which also uses EGL, however those applications output shows that it can not be run at pi4. So pi4 does not support EGL???

User avatar
PeterO
Posts: 5467
Joined: Sun Jul 22, 2012 4:14 pm

Re: OpenGL EGL not working on Pi4??

Wed Aug 14, 2019 8:31 am

This has been covered several times now...

This example got me going on the right track... https://wiki.maemo.org/SimpleGL_example

PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

pjbesl444
Posts: 4
Joined: Sat Aug 17, 2019 12:08 am

Re: OpenGL EGL not working on Pi4??

Sat Aug 17, 2019 3:19 am

Thank you very much for this pointer. Just what I was looking for.

aren2000
Posts: 2
Joined: Wed Mar 25, 2015 7:11 am

Re: OpenGL EGL not working on Pi4??

Thu Jan 16, 2020 9:30 am

pjbesl444 wrote:
Sat Aug 17, 2019 3:19 am
Thank you very much for this pointer. Just what I was looking for.
Have you solved this problem? I looked at that example and copy to my project , but it still crashed at that location。btw, i use pi4 :oops:

User avatar
PeterO
Posts: 5467
Joined: Sun Jul 22, 2012 4:14 pm

Re: OpenGL EGL not working on Pi4??

Thu Jan 16, 2020 10:04 am

I just recompiled the example on a Pi4 and it runs fine.
PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

aren2000
Posts: 2
Joined: Wed Mar 25, 2015 7:11 am

Re: OpenGL EGL not working on Pi4??

Fri Jan 17, 2020 8:19 am

PeterO wrote:
Thu Jan 16, 2020 10:04 am
I just recompiled the example on a Pi4 and it runs fine.
PeterO
thank u! :D

At last, I found out that I linked the wrong library file and it crashed

User avatar
PeterO
Posts: 5467
Joined: Sun Jul 22, 2012 4:14 pm

Re: OpenGL EGL not working on Pi4??

Fri Jan 17, 2020 8:25 am

Did you see tweet from Eben ?
https://twitter.com/EbenUpton/status/12 ... 6679391232
"@Raspberry_Pi 4 is now OpenGL ES 3.1 conformant. Thanks to all our friends at @thekhronosgroup
and @igalia for their help in getting this done."

PeterO
Discoverer of the PI2 XENON DEATH FLASH!
Interests: C,Python,PIC,Electronics,Ham Radio (G0DZB),1960s British Computers.
"The primary requirement (as we've always seen in your examples) is that the code is readable. " Dougie Lawson

rmills232
Posts: 3
Joined: Tue Dec 24, 2019 6:29 pm

Re: OpenGL EGL not working on Pi4??

Fri Feb 07, 2020 10:50 pm

PeterO wrote:
Wed Aug 14, 2019 8:31 am
This has been covered several times now...

This example got me going on the right track... https://wiki.maemo.org/SimpleGL_example

PeterO
Did anyone manage to get this working on the Rpi 3, I'm having trouble with that.

Return to “OpenGLES”