runboy93
Posts: 335
Joined: Tue Feb 28, 2017 1:17 pm
Location: Finland
Contact: Website

OpenGL warns "libGL error: MESA-LOADER: failed to retrieve device information" on Mesa 13.0.0 and later versions

Sun Sep 24, 2017 12:23 am

https://github.com/RPi-Distro/repo/issues/89

Could this be solved by updating libdrm 2.4.71 -> 2.4.73 or newer version?
https://bugs.freedesktop.org/show_bug.cgi?id=98629#c6

Debian (stretch, stable) has also been updated to newer release (2.4.74-1)
https://packages.debian.org/search?suit ... rds=libdrm

runboy93
Posts: 335
Joined: Tue Feb 28, 2017 1:17 pm
Location: Finland
Contact: Website

Re: OpenGL warns "libGL error: MESA-LOADER: failed to retrieve device information" on Mesa 13.0.0 and later versions

Mon Sep 25, 2017 3:25 pm

I know it's very minor bug, but very common to see on basically every glxinfo, anyway you could update Libdrm from 2.4.71 (updated in December 2016, past 10 months in week+)

One small bug fixed is always a start for something bigger :)

User avatar
Imperf3kt
Posts: 1201
Joined: Tue Jun 20, 2017 12:16 am
Location: Australia

Re: OpenGL warns "libGL error: MESA-LOADER: failed to retrieve device information" on Mesa 13.0.0 and later versions

Mon Sep 25, 2017 9:14 pm

Does this cause any actual issues?
I have seen the same message every single time I run my own program on the Pi and a competitor product.
As far as I can tell, nothing is affected.
User experiencing technical difficulties.


Return to “Graphics programming”

Who is online

Users browsing this forum: No registered users and 1 guest