HOWTO: Install Kodi on Raspbian


150 posts   Page 2 of 6   1, 2, 3, 4, 5, 6
by enterprise11 » Tue Mar 03, 2015 6:12 pm
Ok, this is my first post and I am a newbee on raspberry... :?:
I've done everything as posted in the tutorial to install kodi as standalone-version on raspbian 2.
Everything works fine, I can do all the settings, I can add addons, I can browse my movies etc from a harddisc, I see the preview pictures etc. etc. BUT: I can't watch a movie. Everytime I start one, it runs very (!, about 10x speed) and I have a black screen (or the menue - because everything is working fine except watching movies...)
I installed OSMC on another micro-sdhc and there are no problems. I have kodi on an android-pc, too, and it works fine... I checked the settings and didn't find anything strange.
So, what's wrong with my installation???

Best regards

Gregor
Posts: 5
Joined: Tue Mar 03, 2015 5:59 pm
Location: Germany
by gkreidl » Wed Mar 04, 2015 6:53 am
enterprise11 wrote:Ok, this is my first post and I am a newbee on raspberry... :?:
I've done everything as posted in the tutorial to install kodi as standalone-version on raspbian 2.
Everything works fine, I can do all the settings, I can add addons, I can browse my movies etc from a harddisc, I see the preview pictures etc. etc. BUT: I can't watch a movie. Everytime I start one, it runs very (!, about 10x speed) and I have a black screen (or the menue - because everything is working fine except watching movies...)
I installed OSMC on another micro-sdhc and there are no problems. I have kodi on an android-pc, too, and it works fine... I checked the settings and didn't find anything strange.
So, what's wrong with my installation???

Best regards

Gregor


Not enough GPU menory, perhaps. Add or modify in /boot/config.txt
gpu_mem=160
and reboot.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer
Posts: 5114
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany
by enterprise11 » Thu Mar 05, 2015 10:45 am
So I did, but nothing changed. After that I set the gpu_mem=512.
Same result... I'm a little bit confused.
Posts: 5
Joined: Tue Mar 03, 2015 5:59 pm
Location: Germany
by gkreidl » Thu Mar 05, 2015 11:17 am
enterprise11 wrote:So I did, but nothing changed. After that I set the gpu_mem=512.
Same result... I'm a little bit confused.


So am I! It has been working for lots of people so far.
I've installed it on two RPi 2 (and formerly on a a B) and both are really running fine (except for the closing bug which will hopefully be fixed soon).
So there must be something special in your case.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer
Posts: 5114
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany
by KilroyRock » Thu Mar 05, 2015 3:14 pm
you have your mpeg2 codec license? it would help for a lot of black screen stuff, due to the encoding. inexpensive.

http://www.raspberrypi.com/mpeg-2-license-key/
Posts: 4
Joined: Mon Mar 17, 2014 5:47 pm
by enterprise11 » Thu Mar 05, 2015 3:22 pm
No, I don't have. But it's all h264 stuff I want to play. As I said above, all works fine with OSMC on a separate card, but I would like to have the version "best of both worlds" ;-)
Update: After second reboot, I can see sometimes rotating colourful cubes instead of a black screen or my movie...
Posts: 5
Joined: Tue Mar 03, 2015 5:59 pm
Location: Germany
by marotillo » Fri Mar 06, 2015 9:11 pm
enterprise11 wrote:Ok, this is my first post and I am a newbee on raspberry... :?:
I've done everything as posted in the tutorial to install kodi as standalone-version on raspbian 2.
Everything works fine, I can do all the settings, I can add addons, I can browse my movies etc from a harddisc, I see the preview pictures etc. etc. BUT: I can't watch a movie. Everytime I start one, it runs very (!, about 10x speed) and I have a black screen (or the menue - because everything is working fine except watching movies...)
I installed OSMC on another micro-sdhc and there are no problems. I have kodi on an android-pc, too, and it works fine... I checked the settings and didn't find anything strange.
So, what's wrong with my installation???

Best regards

Gregor


Hello,

This is my first post here. Excuse my poor English, it is not my primary language

I decided to post because I have exactly the same problem:
- Everything seems to works fine except when playing a movie.
- Movie progression bar goes faster but a black screen is shown.
- Some online channels plays the sound, but not the images. Instead of images, rotating cubes are shown
- I have OSMC installed in another SD card and everything works fine using the same Raspberry 2 B
Posts: 2
Joined: Fri Mar 06, 2015 8:59 pm
by gkreidl » Fri Mar 06, 2015 10:54 pm
marotillo wrote:Hello,

This is my first post here. Excuse my poor English, it is not my primary language

I decided to post because I have exactly the same problem:
- Everything seems to works fine except when playing a movie.
- Movie progression bar goes faster but a black screen is shown.
- Some online channels plays the sound, but not the images. Instead of images, rotating cubes are shown
- I have OSMC installed in another SD card and everything works fine using the same Raspberry 2 B


Did you see any error messages during installation?

Are you on NOOBS or did you install Raspbian image directly?

How large is your video memory?
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer
Posts: 5114
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany
by marotillo » Sat Mar 07, 2015 10:21 am
Hi again,

I'm happy to say that it's working now!

The problem was the video memory. I did not add the line
Code: Select all
gpu_mem=160
in /boot/config.txt because I was not interested in playing HD videos, but it seems to be mandatory to play SD videos too.

Just for complete the information:
Did you see any error messages during installation?

No, I didn't. The installation was ok.
Are you on NOOBS or did you install Raspbian image directly?

Raspian image directly: 2015-02-16-raspbian-wheezy.img
How large is your video memory?

That was the clue. Now it is 160 and works!

Thank you very much for your help!
Posts: 2
Joined: Fri Mar 06, 2015 8:59 pm
by enterprise11 » Sat Mar 07, 2015 3:02 pm
Congratulations!
I'm still not happy with Kodi...
Where exactly did you add the line?
My last lines now look this way:

# NOOBS Auto-generated Settings:
hdmi_force_hotplug=1
config_hdmi_boost=4
overscan_left=24
overscan_right=24
overscan_top=16
overscan_bottom=16
disable_overscan=0

#gpu_mem=512


gpu_mem I tested with different numbers (160, 512, 544 etc.)
Any further suggestions?
Thanks and regards
Posts: 5
Joined: Tue Mar 03, 2015 5:59 pm
Location: Germany
by gkreidl » Sat Mar 07, 2015 4:52 pm
enterprise11 wrote:
#gpu_mem=512
gpu_mem I tested with different numbers (160, 512, 544 etc.)
Any further suggestions?
Thanks and regards


Remove the '#' in front, otherwise it has no effect.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer
Posts: 5114
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany
by enterprise11 » Sat Mar 07, 2015 5:49 pm
The # was the problem! Now everything is working fine!!!
Thanks a lot!!!!
Posts: 5
Joined: Tue Mar 03, 2015 5:59 pm
Location: Germany
by cpcbegin » Wed Mar 11, 2015 6:15 am
I install Kodi on Raspbian on a Raspberry pi 2 but I've got a different problem with keyboard and mobile as remote controller.
Using my keyboard for search something, for example:
- If I press a number key some times I get the number, a letter, the following letter and again the number, like an old mobile.
- If I press a different key trigger an action instead show the key.
If I try to use my android mobile with apps like Yatse or XBMC remote control the mobile can't connect with raspberri.
(I can control Kodi only with mouse)

I try this with OpenElec and all runs fine, but I need Kodi under Raspbian because I need a complete web browser and a complete OS.

Thanks in advance.
Trucos y recetas para raspberry pi:
http://malagaoriginal.blogspot.com.es/search/label/raspberry%20pi
User avatar
Posts: 184
Joined: Sun Mar 08, 2015 3:48 pm
Location: Costa del Sol, Spain
by gkreidl » Wed Mar 11, 2015 8:39 am
cpcbegin wrote:I install Kodi on Raspbian on a Raspberry pi 2 but I've got a different problem with keyboard and mobile as remote controller.
Using my keyboard for search something, for example:
- If I press a number key some times I get the number, a letter, the following letter and again the number, like an old mobile.
- If I press a different key trigger an action instead show the key.
If I try to use my android mobile with apps like Yatse or XBMC remote control the mobile can't connect with raspberri.
(I can control Kodi only with mouse)

I try this with OpenElec and all runs fine, but I need Kodi under Raspbian because I need a complete web browser and a complete OS.

Thanks in advance.


I've just noticed the same with keyboard text input. No idea yet, what could be done about it. (I've never used Kodi before).
For remote control via smartphone you might try to install some of the event tools from the repository. Install synaptic, search for kodi and you'll find them.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer
Posts: 5114
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany
by DirkS » Wed Mar 11, 2015 10:36 am
cpcbegin wrote:If I try to use my android mobile with apps like Yatse or XBMC remote control the mobile can't connect with raspberri.
(I can control Kodi only with mouse)

I have no problems controlling Kodi on Raspbian with Yatse.
Make sure Kodi's webserver is activated (Settings / System / Webserver).

Re keyboard. I use a wireless mini keyboard and it works fine. Can't find any relevant settings in Kodi though.
Posts: 7104
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK
by cpcbegin » Sat Mar 14, 2015 3:16 am
DirkS wrote:
cpcbegin wrote:If I try to use my android mobile with apps like Yatse or XBMC remote control the mobile can't connect with raspberri.
(I can control Kodi only with mouse)

I have no problems controlling Kodi on Raspbian with Yatse.
Make sure Kodi's webserver is activated (Settings / System / Webserver).

Re keyboard. I use a wireless mini keyboard and it works fine. Can't find any relevant settings in Kodi though.


Kodi's webserver is activated as you describe, mobile remove controls runs in kodi openelec but not in kodi raspbian :(

Re keyboard. Can you type letters using the real keyboard? again I can do this with openelec but not in raspbian.
Arrow keys runs ok on both scenarios and numbers runs like an old 'non-smart' phone. (I press one, I get a number, I press twice I get a letter, I press again I get next letter, I press again more I get the same number).
Trucos y recetas para raspberry pi:
http://malagaoriginal.blogspot.com.es/search/label/raspberry%20pi
User avatar
Posts: 184
Joined: Sun Mar 08, 2015 3:48 pm
Location: Costa del Sol, Spain
by cpcbegin » Tue Mar 17, 2015 8:57 pm
Problem #1: keyboard numbers runs like an old mobile and alphabetical keys don't run property:
Solution: Add to /etc/init.d/rc.local this line:
chmod 0777 /dev/tty0

Problem #2: apps to convert smartphones in remote control don't run:
Solution:
Yatse: changer port from 80 to 8080
XBMC Remote: press update
Trucos y recetas para raspberry pi:
http://malagaoriginal.blogspot.com.es/search/label/raspberry%20pi
User avatar
Posts: 184
Joined: Sun Mar 08, 2015 3:48 pm
Location: Costa del Sol, Spain
by DirkS » Tue Mar 24, 2015 4:39 pm
cpcbegin wrote:Problem #1: keyboard numbers runs like an old mobile and alphabetical keys don't run property:
Solution: Add to /etc/init.d/rc.local this line:
chmod 0777 /dev/tty0

This probably means that user 'kodi' is not in group 'input'
Code: Select all
sudo usermod -a -G input kodi


Thanks to forum member 'spendoza' for noticing this...
Posts: 7104
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK
by ekimyar » Thu Mar 26, 2015 10:33 pm
Has anyone been able to apt-get the Unstable packages from deb http://archive.mene.za.net/raspbian wheezy contrib unstable?
I cannot get apt-get to see that kodi offers an unstable package option. It just returns this error:
Release 'unstable' for 'kodi' was not found

I've altered my /etc/apt/source.list file to add the unstable repository, and I added the /etc/apt/preferences file for pinning.... not sure what to do next.
Posts: 5
Joined: Fri Feb 06, 2015 1:11 am
by Tom_A » Fri Mar 27, 2015 7:14 am
Latest update has broken the black screen on exit fix I just got working properly. I don't regularly exit Kodi and am mostly running off Raspbian so I can have services running in the background, but it would be nice to not have to reboot to properly exit back to lightdm. I've had the best luck launching Kodi from the login screen.
Posts: 272
Joined: Fri Dec 06, 2013 8:34 am
by gkreidl » Fri Mar 27, 2015 7:33 am
Tom_A wrote:Latest update has broken the black screen on exit fix I just got working properly. I don't regularly exit Kodi and am mostly running off Raspbian so I can have services running in the background, but it would be nice to not have to reboot to properly exit back to lightdm. I've had the best luck launching Kodi from the login screen.


Latest update of what?
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer
Posts: 5114
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany
by Tom_A » Fri Mar 27, 2015 7:59 am
I did an apt-get upgrade recently and Kodi had an update. Was hoping that it might fix the black screen problem without the need for the scripts, however it broke the script fix. I've tried turning off the scripts to see if that helped. The three lines that it was recommended to comment out have changed a bit. I tried commenting them out again, but that did not help.
Posts: 272
Joined: Fri Dec 06, 2013 8:34 am
by gkreidl » Fri Mar 27, 2015 8:12 am
Latest kodi version is dated Feb, 9th. It seems you haven't updated for quite some time.
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer
Posts: 5114
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany
by Tom_A » Fri Mar 27, 2015 3:56 pm
gkreidl wrote:Latest kodi version is dated Feb, 9th. It seems you haven't updated for quite some time.


I don't think this was a regular update to Kodi. Raspbmc I know has updates and changes occasionally that are not part of the normal Kodi and usually specific to raspberry pi issues. I checked for updates later than Feb 9th to make sure everything was ready to move to the Raspberry Pi B2, but still got another update to Kodi a few days ago over apt-get. You could try doing an apt-get yourself to check for this, but I'd recommend canceling if it does show an update to Kodi if you don't want to break the script functionality.

It was recommended to comment out the last three lines of a file to help fix the issue, however the end of the same file looks like this now:
Code: Select all
VT="$(fgconsole)"
if [ "$VT" ]; then
  sudo chvt 7
  sudo chvt "$VT"
fi
Posts: 272
Joined: Fri Dec 06, 2013 8:34 am
by gkreidl » Fri Mar 27, 2015 4:12 pm
I ran apt-get yesterday and got no new update. Can you please post the output of
apt-cache showpkg kodi
Minimal Kiosk Browser (kweb)
Slim, fast webkit browser with support for audio+video+playlists+youtube+pdf+download
Optional fullscreen kiosk mode and command interface for embedded applications
Includes omxplayerGUI, an X front end for omxplayer
Posts: 5114
Joined: Thu Jan 26, 2012 1:07 pm
Location: Germany