adzyu100
Posts: 16
Joined: Fri Jan 03, 2014 3:58 pm

Jessie can't boot to command line

Sun Jan 04, 2015 6:49 pm

Hi all,

I recently upgraded from wheezy to jessie, but I can't figure out why I can't boot directly into the command line. I've ran raspi-config at least 10 times, and it still boots into the x gui every time. Doing ctrl+alt+backspace just takes me back to the gui login screen as well. Any help would be greatly appreciated.

User avatar
DougieLawson
Posts: 39092
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Jessie can't boot to command line

Sun Jan 04, 2015 7:06 pm

Take a look at
/etc/init.d/lightdm
/etc/rc2.d/S*lightdm
and
/etc/lightdm/lightdm.conf

Those are the things that get updated when raspi-config enables boot to a GUI desktop.
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

sparticle
Posts: 26
Joined: Wed Aug 13, 2014 12:47 pm

Re: Jessie can't boot to command line

Wed Feb 11, 2015 6:08 pm

Did you find an answer to this problem. I am trying to get my Raspbian Jessie install to boot to the command line and start the desktop when I want using startx.

Cheers
Spart

User avatar
DougieLawson
Posts: 39092
Joined: Sun Jun 16, 2013 11:19 pm
Location: A small cave in deepest darkest Basingstoke, UK
Contact: Website Twitter

Re: Jessie can't boot to command line

Wed Feb 11, 2015 7:51 pm

sudo systemctl set-default multi-user.target # no graphics
sudo systemctl set-default graphical.target # GUI
Note: Any requirement to use a crystal ball or mind reading will result in me ignoring your question.

Criticising any questions is banned on this forum.

Any DMs sent on Twitter will be answered next month.
All non-medical doctors are on my foes list.

huffy2404
Posts: 5
Joined: Mon Feb 16, 2015 2:18 am

Re: Jessie can't boot to command line

Mon Feb 16, 2015 2:22 am

DougieLawson wrote:sudo systemctl set-default multi-user.target # no graphics
I used this command on a fresh wheezy image just upgraded to jessie, and now I am seeing a "Failed to start Login Service." message at boot. Since the login service has not started I am not able to login and am just presented with a flashing cursor. So, use this command with caution. Does anyone know how to undo those changes so that I will be able to log in once again?

billw
Posts: 412
Joined: Tue Sep 18, 2012 8:23 pm

Re: Jessie can't boot to command line

Mon Feb 16, 2015 2:38 pm

I had that problem a while back. I ended up resorting to removing lightdm:
$ apt-get purge lightdm
After adding "exec startxfce4" to my .xinitrc I can now use startx when I want a gui.

devtronslab
Posts: 1
Joined: Sat Feb 28, 2015 2:07 pm

Re: Jessie can't boot to command line

Sat Feb 28, 2015 2:12 pm

Removing lightdm as suggested by @billw worked for me.

Also seems to have solved a problem of the Pi failing to boot completely, prompting a command line request of either "systemctl default" or "systemctl reboot". Anyone else have this issue and know if it's related to lightdm?

prich
Posts: 12
Joined: Wed Aug 15, 2012 7:01 am

Jessie can't boot to command line

Tue Feb 09, 2016 1:35 pm

Hi,
I'd like to add my complaint under this heading. I have the same problem - upgraded to Jessie and my headless Pi will ONLY boot to GUI. None of the ideas in this area work. I have not tried to purge LightDM since that is displaying the system. Disabling LightDM left me with a blank screen from which I was forced to remove power to get the Pi working again.

I'm really annoyed that there was no warning that this would happen and there does not appear to be a way to get back to command line start.

Some forums say that Raspi-Config is available in Preferences - not so. Running raspi-config in a terminal window has no effect.

Surely there is some SIMPLE way to start at the command line.

Any help solving this problem will be greatly appreciated.

Peter

JimmyN
Posts: 1109
Joined: Wed Mar 18, 2015 7:05 pm
Location: Virginia, USA

Re: Jessie can't boot to command line

Tue Feb 09, 2016 3:00 pm

You can look in the raspi-config file and see what it uses to switch GUI/Console, and login/nologin.

Assuming you're using systemd, if you're still using init.d it's done a bit differently:

For a boot to console and no auto login (you'll have to log in at the prompt)

Code: Select all

systemctl set-default multi-user.target
ln -fs /lib/systemd/system/getty@.service /etc/systemd/system/getty.target.wants/getty@tty1.service
For a boot to console and autologin

Code: Select all

systemctl set-default multi-user.target
ln -fs /etc/systemd/system/autologin@.service /etc/systemd/system/getty.target.wants/getty@tty1.service
For a boot to desktop with no login

Code: Select all

systemctl set-default graphical.target
ln -fs /lib/systemd/system/getty@.service /etc/systemd/system/getty.target.wants/getty@tty1.service
For a boot to desktop with autologin

Code: Select all

systemctl set-default graphical.target
ln -fs /etc/systemd/system/autologin@.service /etc/systemd/system/getty.target.wants/getty@tty1.service
If you want to boot to desktop set the default to "graphical.target". If you want to boot to console set the default to "multi-user.target". If you want autologin you have to use the "autologin@.service", rather than the "getty@.service".
No matter which option you choose it needs to be linked to "getty@tty1.service" to function correctly.

prich
Posts: 12
Joined: Wed Aug 15, 2012 7:01 am

Re: Jessie can't boot to command line

Wed Feb 10, 2016 2:03 am

[quote="JimmyN"]You can look in the raspi-config file and see what it uses to switch GUI/Console, and login/nologin.

Assuming you're using systemd, if you're still using init.d it's done a bit differently:

For a boot to console and no auto login (you'll have to log in at the prompt)

Code: Select all

systemctl set-default multi-user.target
ln -fs /lib/systemd/system/getty@.service /etc/systemd/system/getty.target.wants/getty@tty1.service
Thanks JimmyN. The above has certainly given me a command line interface with a login prompt. There is however a problem.

Interspersed with the login prompt I get the following on screen:

Code: Select all

Raspbian GNU/Linux 8 RASPY21 tty1

RASPY21 login: [   21.722912] cfg80211: Calling CRDA to update world regulatory domain
..
about every 3 sec?
..
[   43.722941] cfg80211: Calling CRDA to update world regulatory domain
[   46.922955] cfg80211: Exceeded CRDA call max attempts. Not calling CRDA
  <-- I enter login name here
Password:  <-- I enter password here
I am about to try to find out what CRDA is.

Thanks again
Peter

prich
Posts: 12
Joined: Wed Aug 15, 2012 7:01 am

Re: Jessie can't boot to command line

Wed Feb 10, 2016 3:56 am

Hi,

Found a solution to the CRDA problem

"To solve the "problem" - which actually is that the Jessie distro does not have this included, do:

Code: Select all

sudo apt-get install wireless-regdb iw crda
sudo reboot
"

This was posted by MrB2 at:
viewtopic.php?f=28&t=122067

DirkS
Posts: 10361
Joined: Tue Jun 19, 2012 9:46 pm
Location: Essex, UK

Re: Jessie can't boot to command line

Wed Feb 10, 2016 12:04 pm

prich wrote:"To solve the "problem" - which actually is that the Jessie distro does not have this included, do:
It *is* included in the Jessie image. But when you upgrade from Wheezy (where it may not be installed) it is not automagically added.

I had the same when upgrading a system from wheezy and I just installed crda to get rid of the messages.

prich
Posts: 12
Joined: Wed Aug 15, 2012 7:01 am

Re: Jessie can't boot to command line

Thu Feb 11, 2016 12:10 am

Thanks for the info DirkS.

I am not familiar enough with the contents of the image to know down to that level. However, it would appear that CRDA was required, did not exist in the old version and was not included in the upgrade.

Thanks to all for the info provided which enabled a solution to my problem.

Peter

Return to “Raspberry Pi OS”