Nathan Phillips
Posts: 3
Joined: Fri Nov 28, 2014 1:06 pm

X starts at boot after upgrade to Jessie

Fri Nov 28, 2014 2:01 pm

After upgrading a new and minimally altered Raspbian Wheasy standard image to Raspbian Jessie, X starts at boot. I can't for the life of me see what's causing it to start up. I need all the memory I can get free so would like to prevent this.

Code: Select all

sudo /etc/init.d/lightdm stop
does manually shut it down.
lightdm is disabled for all runlevels.
Any further clues?

plugwash
Forum Moderator
Forum Moderator
Posts: 3224
Joined: Wed Dec 28, 2011 11:45 pm

Re: X starts at boot after upgrade to Jessie

Sat Nov 29, 2014 4:15 pm

Currently upgrades from wheezy to jessie will by default switch to systemd (this is contravesial within Debian and may or may not be the case when jessie finally releases). This has the unfortunate side affect of re-enabling services that were disabled in sysvinit.

I think

service lightdm disable

Should solve your problem if this is the case.

Nathan Phillips
Posts: 3
Joined: Fri Nov 28, 2014 1:06 pm

Re: X starts at boot after upgrade to Jessie

Wed Dec 03, 2014 12:31 am

Wonderful, thank you for your help.

User avatar
mikerr
Posts: 2491
Joined: Thu Jan 12, 2012 12:46 pm
Location: UK
Contact: Website

Re: X starts at boot after upgrade to Jessie

Wed Dec 03, 2014 2:38 pm

the above didn't work for me, but this did:

Code: Select all

sudo systemctl disable lightdm.service
Android app - Raspi Card Imager - download and image SD cards - No PC required !

Nathan Phillips
Posts: 3
Joined: Fri Nov 28, 2014 1:06 pm

Re: X starts at boot after upgrade to Jessie

Wed Dec 03, 2014 3:25 pm

The best command to use is probably:

Code: Select all

sudo systemctl set-default multi-user.target
But the post above identifying that it's systemd rather than sysvinit in Jessie was the information I needed to realise this is what I needed to do.

itsmedoofer
Posts: 230
Joined: Wed Sep 25, 2013 8:43 am

Re: X starts at boot after upgrade to Jessie

Wed Dec 03, 2014 5:22 pm

Is this why the Raspi-config boot options don't work in Jessie ?

User avatar
mikerr
Posts: 2491
Joined: Thu Jan 12, 2012 12:46 pm
Location: UK
Contact: Website

Re: X starts at boot after upgrade to Jessie

Wed Dec 03, 2014 6:33 pm

raspi-config hasn't been updated to talk systemd, so many of its boot options won't work.
e.g. boot to desktop, ssh enable/disable

Options for overclocking / camera / memory split still work ok though.
Android app - Raspi Card Imager - download and image SD cards - No PC required !

itsmedoofer
Posts: 230
Joined: Wed Sep 25, 2013 8:43 am

Re: X starts at boot after upgrade to Jessie

Wed Dec 03, 2014 8:35 pm

Gotcha, thanks Mike apprecated.

sparticle
Posts: 22
Joined: Wed Aug 13, 2014 12:47 pm

Re: X starts at boot after upgrade to Jessie

Wed Feb 11, 2015 6:29 pm

Just wanted to say many thanks for this post, as I had been banging my head trying to get Jessie to boot to the command prompt.

Do you happen to know the reverse command to get it to boot the desktop automatically after disabling it with:

sudo systemctl set-default multi-user.target

Cheers
Spart

User avatar
DougieLawson
Posts: 29767
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: X starts at boot after upgrade to Jessie

Wed Feb 11, 2015 7:16 pm

sparticle wrote:
Do you happen to know the reverse command to get it to boot the desktop automatically after disabling it with:

sudo systemctl set-default multi-user.target

Cheers
Spart
sudo systemctl set-default graphical.target

There's some good docs I found here: http://fedoraproject.org/wiki/Systemd
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

Since 2012: 1B*5, 2B*2, B+, A+, Zero*2, 3B*3

Please post ALL technical questions on the forum. Do not send private messages.

sparticle
Posts: 22
Joined: Wed Aug 13, 2014 12:47 pm

Re: X starts at boot after upgrade to Jessie

Wed Feb 11, 2015 7:52 pm

That's great many thanks. Like black magic to me :)

Cheers
Spart

bullwinkle
Posts: 117
Joined: Wed Jan 09, 2013 12:14 pm

Re: X starts at boot after upgrade to Jessie

Thu Feb 12, 2015 4:05 am

Hi

I think you just need to put a 3 in the cmdline.txt file to switch to run level 3
or
systemd.unit=multi-user.target in the cmdline.txt file should work also.

I've not tested this on the Pi, but it works on my BBB.

Return to “Raspbian”

Who is online

Users browsing this forum: No registered users and 27 guests