ShorTie
Posts: 92
Joined: Sun May 12, 2013 3:54 pm

Arduino_IDE-1.6.7/github on the Raspberry Pi

Thu Nov 27, 2014 12:18 pm

Living in the land of ARM I found a need to write this

Code: Select all

wget https://raw.githubusercontent.com/ShorTie8/Arduino_IDE/master/Arduino_IDE_builder.bash
Although you just need the file, it most likely is best to pull the whole github

Code: Select all

git clone https://github.com/ShorTie8/Arduino_IDE
Although it was written for ARM primarily, I do believe it will work on any Linux box.
And with a little help Mac && Windows too...

What it does is use github to get all the various programs.
Compiles them and builds the IDE in 1 simple script .. :)~

You gotta run it as root !!

I've tested it on a Raspberry Pi2 and Odroid C1 and all seems well after dependency are meet.

Code: Select all

apt-get install -y mercurial subversion build-essential gperf bison ant texinfo zip automake flex libusb-dev libusb-1.0-0-dev libtinfo-dev pkg-config libwxbase3.0-dev libtool
The latest Raspbian has Java 8 already so no problems.
If it is not already installed, like on the Odroid and Debian i686, I did it as follows

Code: Select all

sudo sh -c 'echo "deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main" >> /etc/apt/sources.list'
sudo sh -c 'echo "deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main" >> /etc/apt/sources.list'
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys EEA14886
sudo apt-get update
sudo apt-get install oracle-java8-installer



The script seems to run fine on Debian i686, but with no access to x11, I could not run the final product.

Not all options are fully implemented yet, But Silence_is_Golden is enabled as it sed's through toolchain-avr on the initial git clone to silence it and make things easier to follow. So to do/un-do it, just 'rm -rf Arduino/build/toolchain-avr' and re-run the script. You can save some download time by coping all the files toolchain-avr downloads over as git clone is working if you have them.

Have A Great Day
ShorTie

Note: Older stuff is still @ my github
Last edited by ShorTie on Sun Jan 24, 2016 1:48 pm, edited 8 times in total.

bullwinkle
Posts: 117
Joined: Wed Jan 09, 2013 12:14 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Wed Jan 21, 2015 8:31 am

thanks - it works.
I had some trouble, but I found out that my .quiltrc was not set up properly so the debian/arduino patches were not applied.
cheers

NicoHood
Posts: 37
Joined: Fri Jan 23, 2015 12:28 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Fri Jan 23, 2015 12:31 pm

Hye,
I got two errors when I try to follow the instrctions.

First:
On every boot the x-server is loaded. Even if i deactivate it via raspi-config. Any idea to set it to command line again?

When I try to compile the Arduino stuff I installed all the new packages. But now I get:
build:

Code: Select all

      [jar] Building jar: /home/pi/Desktop/Arduino/Arduino-master/arduino-core/arduino-core.jar

BUILD SUCCESSFUL
Total time: 1 minute 37 seconds
cd build && ant
Buildfile: /home/pi/Desktop/Arduino/Arduino-master/build/build.xml

build:

BUILD FAILED
/home/pi/Desktop/Arduino/Arduino-master/build/build.xml:58: The following error occurred while executing this line:
Target "${platform}-build" does not exist in the project "Arduino".

Total time: 11 seconds
debian/rules:28: recipe for target 'override_jh_build' failed
make[1]: *** [override_jh_build] Error 1
make[1]: Leaving directory '/home/pi/Desktop/Arduino/Arduino-master'
debian/rules:19: recipe for target 'binary' failed
make: *** [binary] Error 2
dpkg-buildpackage: error: debian/rules binary gave error exit status 2
I used the master from github since it got merged yesterday.

bullwinkle
Posts: 117
Joined: Wed Jan 09, 2013 12:14 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Fri Jan 23, 2015 2:38 pm

Hello,

i had the same errors/issues and i found the problem related to quilt and patching. Details are here....

http://dumb-looks-free.blogspot.fr/2015 ... ebone.html

it was for a BBB, but it works on the Pi also (tested).

good luck

NicoHood
Posts: 37
Joined: Fri Jan 23, 2015 12:28 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Fri Jan 23, 2015 4:45 pm

Thanks!
I had to delete all folders and redo the steps. But it compiled and worked so far. Now I have 1.6 rc2 installed. Before I had 1.0 (updated to 1.0.5 with jessie) and the 1.6 update made no problem it seems.

For the Avrdude fix: Is it possible to create a simple link to the file in /etc ? Because I developed a special HID-Core which uses the same settings and this might not work with this fix. Or in other words: users would have to manually fix the core for this as well. Isnt there someting in linux where you create a fake file which redirects to the correct path? Wouldnt that be a better fix? Do you know how to do so?

Just the thing with the X-Server I cannot solve. If I try to quit it via logout or control alt backspace it just restarts always. And it opens at boot. How can I stop this behaviour? Do you have the same problem after the jessie upgrade?

Edit:
now my web browser crashes everytime I try to start it.

bullwinkle
Posts: 117
Joined: Wed Jan 09, 2013 12:14 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Fri Jan 23, 2015 6:08 pm

Hi
yes I confirm epiphany browser is crashing.
my desktop shuts-down fine.
When I get some time, I will look at the link for the file avrdude.conf ... but I can't make any promises.

NicoHood
Posts: 37
Joined: Fri Jan 23, 2015 12:28 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Sat Jan 24, 2015 10:21 am

I manged to get 1.6 working under wheezy.

I added jessie as 2nd repository like in this instruction:
http://raspberrypi.stackexchange.com/qu ... n-raspbian

Then I used my precompiled deb files (the one from the link above should work the same) and tried to install.
Then i got some errors. I had to use apt-get -f install several times and install the listed packages. Finally it installed.

And I also got a better fix for the avrdude problem:

Code: Select all

dpkg -i arduino-core_1.6.0_all.deb arduino_1.6.0_all.deb

# load all missing repositories, you might need to use:
apt-get -f install
apt-get -t jessie install [package]

#try to install again

# create fake directory and  symbolic link to the new config
mkdir /usr/share/arduino/hardware/tools/avr/etc/
ln -s /etc/avrdude.conf /usr/share/arduino/hardware/tools/avr/etc/avrdude.conf
All you need is someone to compile the .deb files first. This also gets the newest avr-gcc 4.8.1 whih i very nice for me, since I also compile usb firmwares with lufa.

I ill probably do a blog post about that the next days. Not sure when jessie comes out officially for raspi, maybe its not needed if it comes out soon. Any idea?

bullwinkle
Posts: 117
Joined: Wed Jan 09, 2013 12:14 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Sat Jan 24, 2015 10:43 am

good the hear you got things working....

... be sure to come back and post a link to you blog to share your notes !

I think Jessie main line is still a few months away but I haven't seen a date mentioned recently

cheers

NicoHood
Posts: 37
Joined: Fri Jan 23, 2015 12:28 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Sat Jan 24, 2015 1:51 pm

Here it is:
https://nicohood.wordpress.com/2015/01/ ... pberry-pi/

I tried with a fresh install and it should work. No problems with autologin etc anymore.

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Sat Jan 24, 2015 5:02 pm

Thanks for this. I tried the first way some time back but it failed for some reason and I didn't bother to find out why.

I am running jessie on this pi so some bits you included I already have.

One problem I found is that the symlink /usr/share/arduino/hardware/tools/@avrdude.conf to /etc/avrdude.conf errored though all looked correct. Recreating it has cured it and now running as expected.

Edit:... then it broke again

Seems that the IDE is looking in /usr/share/arduino/hardware/tools/avr/etc/ so creating a symlink there appears to have sorted it.

For reference the error was

Code: Select all

avrdude: can't open config file "/usr/share/arduino/hardware/tools/avr/etc/avrdude.conf": No such file or directory
avrdude: error reading system wide configuration file "/usr/share/arduino/hardware/tools/avr/etc/avrdude.conf"

ShorTie
Posts: 92
Joined: Sun May 12, 2013 3:54 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Wed Jan 28, 2015 12:06 pm

Thankz guys for trying this out.

Been wondering if anybody had, lol.

I upgraded the patches to fix the fuzz that dpkg doesn't like.
And added in a symlink for /usr/share/arduino/hardware/tools/avr/etc/avrdude.conf.
So hopefully all is well again.

Sorry, I was unaware of the symlink because of only testing it with the due.

Did not think this would work with wheezy because of the compile requirements of it.

I had thought of passing out precompiled binaries, but I know I do not like to use them
from 3rd parties, because you never know what is in them. So that is why I went the patch route.

I guess binaries can be found here, if that is what you want http://dumb-looks-free.blogspot.fr/2015 ... black.html , but not tested be me !!

Have A Great Day
ShorTie

PS: I was more worried how Debian had broke the upgrade of wheezy to jessie .. :?
But that appears to be fixed since I've tested it out twice, and everything else like, in the last day.

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Wed Jan 28, 2015 5:29 pm

ShorTie wrote:I upgraded the patches to fix the fuzz that dpkg doesn't like.
And added in a symlink for /usr/share/arduino/hardware/tools/avr/etc/avrdude.conf.
So hopefully all is well again.

Sorry, I was unaware of the symlink because of only testing it with the due.
I believe that it was a broken bit in platforms.txt, probably now fixed, but anyway, as long it works ;)
PS: I was more worried how Debian had broke the upgrade of wheezy to jessie .. :?
But that appears to be fixed since I've tested it out twice, and everything else like, in the last day.
My jessie seems to be working fine - but I do have an OT query ...

This weekend I was at the start of installing all the prerequisites for panStamp when I noticed I was running very short of space, I had only a few MB free on an 8GB USB stick (now copied to 16GB). I cannot see anything that could cause this other than the jessie install itself.

Is your jessie install similarly much larger than wheezy?

User avatar
DougieLawson
Posts: 30431
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Wed Jan 28, 2015 5:50 pm

/var/log and /var/cache/apt/archive are the SDCard hogs on Jessie
Microprocessor, Raspberry Pi & Arduino Hacker
Mainframe database troubleshooter
MQTT Evangelist
Twitter: @DougieLawson

Since 2012: 1B*5, 2B*2, B+, A+, Zero*2, 3B*3

Please post ALL technical questions on the forum. Do not send private messages.

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Wed Jan 28, 2015 6:10 pm

Thanks, I'll take a look there next time I fire it up.

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Fri Feb 06, 2015 8:16 am

After trying for a couple of days I have given up trying to run jessie on my new RPi 2.

Thanks to Nico's posts above I am now running a self built 1.6 IDE on a standard raspbian wheezy install - and it's also patched to build for panStamp NRGs - hopefully :)
Verify works, the real test still to be done.

ShorTie
Posts: 92
Joined: Sun May 12, 2013 3:54 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Fri Feb 06, 2015 1:39 pm

patched to build for panStamp NRGs - hopefully :)
If you give a little more info, I might be able to include it for others ;)

Did the new patch not work right, or where you still trying the old 1 ??

wget https://www.dropbox.com/s/2bj145rkq9mfg ... .0.1.patch

I don't get my rPi2 till tomorrow, hopefully, but will give it a go around.
As of the date of the edit, new patch, my instructions where working fine once again.

Have A Great Day
ShorTie ;)

NicoHood
Posts: 37
Joined: Fri Jan 23, 2015 12:28 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Fri Feb 06, 2015 4:00 pm

i will get my pi2 in 1-4 days. Now the Arduino IDE actually starts making sense since the desktop is hopefully faster than before. This could be a very cool use for the Raspi. Portable coding everywhere, like the idea!

Let us know about any further updates :)

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Fri Feb 06, 2015 4:40 pm

ShorTie wrote: If you give a little more info, I might be able to include it for others ;)

Did the new patch not work right, or where you still trying the old 1 ??
Sorry, I wasn't very clear.

Your patch is fine and the result works with the original AVR panStamps, but a more recent version uses a MCP430 core.
This requires a patch to the built libraries, hardware, tools etc.

I guess you could add that to your patch but as it took over 8 hours to build... ;)

@Nico
Yes, the RPi 2 is a much faster desktop, seems faster all round in fact - unless you run it from a slow 16GB USB stick as I did for a while. Back to HD now.

User avatar
ilovemipi
Posts: 154
Joined: Mon Dec 02, 2013 11:52 am
Location: Cyprus
Contact: Website

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Fri Feb 13, 2015 5:14 pm

NicoHood wrote:Here it is:
https://nicohood.wordpress.com/2015/01/ ... pberry-pi/

I tried with a fresh install and it should work. No problems with autologin etc anymore.
I worked through your guide and I have IDE 1.6.0 on the Pi. Generally seems to work ok but I have a sketch from 1.0.6 on Windows that doesn't perform on the Pi how it should.
It compiles and uploads to the Arduino and the code runs but it gives different results to those otained on Windows. If I attach an Arduino to the Pi that has the same sketch loaded but from Windows 1.0.6 IDE then the Arduino performs as expected.

So question is what is different between 1.6.0 and 1.0.6?
Combined RF Boiler Controller and RF learner: https://thechariot.co.uk/

NicoHood
Posts: 37
Joined: Fri Jan 23, 2015 12:28 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Fri Feb 13, 2015 5:18 pm

The compiler changed. But this has nothing to do with this thread. Please ask in arduino forums or meet me on freenode irc #arduino ;)

It seems to still work fine on my raspi 2, compiles faster, but it only uses a single mcu, which is not optimal...
But hey it works! I have to do further testing if it really makes sense to code on this computer now.

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Fri Feb 13, 2015 7:04 pm

It's certainly generally much more responsive on a Pi2 - I can type in the IDE and it keeps up with me now.
I have had no problems up to now with code differences.

I wondered if this thread had come alive again because someone had built the official 1.6 release IDE on a Pi ;)

NicoHood
Posts: 37
Joined: Fri Jan 23, 2015 12:28 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Sat Feb 14, 2015 2:01 pm

I tried to recompile with my p2 the new final release but it seems to not work for me. I tried with this quilt and the new patch but then i get this:

Code: Select all

BUILD FAILED
/home/pi/Desktop/a/Arduino-master/build/build.xml:68: The following error occurred while executing this line:
Target "${platform}-build" does not exist in the project "Arduino".

Total time: 2 seconds
debian/rules:28: recipe for target 'override_jh_build' failed
make[1]: *** [override_jh_build] Error 1
make[1]: Leaving directory '/home/pi/Desktop/a/Arduino-master'
debian/rules:19: recipe for target 'binary' failed
make: *** [binary] Error 2
dpkg-buildpackage: error: debian/rules binary gave error exit status 2

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Sat Feb 14, 2015 3:01 pm

Shame, though I guess not unexpected.

I'd have a play but a bit fell off my Pi2 yesterday and I don't fancy the wait on a B+

NicoHood
Posts: 37
Joined: Fri Jan 23, 2015 12:28 pm

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Sat Feb 14, 2015 3:41 pm

Dont missunderstand me: the curren RC is working. I just cannot recompile the current stable. Seems something is wrong with the patch or so.

Also the links to the github page can now be changed to master.

fruit-uk
Posts: 609
Joined: Wed Aug 06, 2014 4:19 pm
Location: Suffolk, UK

Re: Arduino-ide-1.6.0 + due on the Raspberry Pi

Sat Feb 14, 2015 5:05 pm

I assumed that was what you meant, the RC is a good compromise in the meantime

Return to “Raspbian”

Who is online

Users browsing this forum: No registered users and 23 guests