Killerbee
Posts: 62
Joined: Tue Sep 20, 2011 6:38 pm

Squeezebox server and slave

Sun Jun 24, 2012 12:40 pm

Hello Raspbian's

Somebody got squeezeboxserver and squeezeslave succesfully installed on their raspbian pi?
I am struggling with CPAN.

I was able to successfully rebuild the modules but am lost!

When I run squeezeboxserver --d_startup I get this message

Code: Select all

Loaded module: [version] ok!
Loaded module: [Time::HiRes] ok!
Removing [DBI] from the symbol table - load failed.
Removing [EV] from the symbol table - load failed.
Removing [common::sense] from the symbol table - load failed.
Removing [XML::Parser::Expat] from the symbol table - load failed.
Removing [HTML::Parser] from the symbol table - load failed.
Removing [HTML::Entities] from the symbol table - load failed.
Removing [JSON::XS] from the symbol table - load failed.
Removing [common::sense] from the symbol table - load failed.
Removing [Digest::base] from the symbol table - load failed.
Removing [Digest::SHA1] from the symbol table - load failed.
Removing [YAML::XS] from the symbol table - load failed.
Removing [Sub::Name] from the symbol table - load failed.
The following modules are loaded after the first attempt:
        Slim/Utils/OS/Debian.pm => /usr/share/perl5/Slim/Utils/OS/Debian.pm
        File/Spec/Functions.pm => /usr/lib/perl/5.14/File/Spec/Functions.pm
        POSIX.pm => /usr/lib/perl/5.14/POSIX.pm
        Getopt/Long.pm => /usr/share/perl/5.14/Getopt/Long.pm
        /usr/lib/perl/5.14/auto/POSIX/load_imports.al => /usr/lib/perl/5.14/auto/POSIX/load_imports.al
        Tie/Hash.pm => /usr/share/perl/5.14/Tie/Hash.pm
        Cwd.pm => /usr/lib/perl/5.14/Cwd.pm
        warnings.pm => /usr/share/perl/5.14/warnings.pm
        Slim/Utils/OSDetect.pm => /usr/share/perl5/Slim/Utils/OSDetect.pm
        /usr/lib/perl/5.14/auto/POSIX/autosplit.ix => /usr/lib/perl/5.14/auto/POSIX/autosplit.ix
        Slim/Utils/OS/Linux.pm => /usr/share/perl5/Slim/Utils/OS/Linux.pm
        Fcntl.pm => /usr/lib/perl/5.14/Fcntl.pm
        Symbol.pm => /usr/share/perl/5.14/Symbol.pm
        UNIVERSAL.pm => /usr/share/perl/5.14/UNIVERSAL.pm
        Exporter.pm => /usr/share/perl/5.14/Exporter.pm
        Slim/Utils/OS.pm => /usr/share/perl5/Slim/Utils/OS.pm
        version/vpp.pm => /usr/share/squeezeboxserver/CPAN/version/vpp.pm
        File/Spec.pm => /usr/lib/perl/5.14/File/Spec.pm
        File/Path.pm => /usr/share/perl/5.14/File/Path.pm
        FindBin.pm => /usr/share/perl/5.14/FindBin.pm
        locale.pm => /usr/share/perl/5.14/locale.pm
        warnings/register.pm => /usr/share/perl/5.14/warnings/register.pm
        XSLoader.pm => /usr/share/perl/5.14/XSLoader.pm
        Slim/bootstrap.pm => /usr/share/perl5/Slim/bootstrap.pm
        Time/HiRes.pm => /usr/lib/perl/5.14/Time/HiRes.pm
        version.pm => /usr/share/squeezeboxserver/CPAN/version.pm
        Config_git.pl => /usr/lib/perl/5.14/Config_git.pl
        base.pm => /usr/share/perl/5.14/base.pm
        Config.pm => /usr/lib/perl/5.14/Config.pm
        File/Basename.pm => /usr/share/perl/5.14/File/Basename.pm
        Carp.pm => /usr/share/perl/5.14/Carp.pm
        YAML/XS/LibYAML.pm =>
        File/Spec/Unix.pm => /usr/lib/perl/5.14/File/Spec/Unix.pm
        Exporter/Heavy.pm => /usr/share/perl/5.14/Exporter/Heavy.pm
        vars.pm => /usr/share/perl/5.14/vars.pm
        strict.pm => /usr/share/perl/5.14/strict.pm
        constant.pm => /usr/share/perl/5.14/constant.pm
        Config_heavy.pl => /usr/lib/perl/5.14/Config_heavy.pl
        overload.pm => /usr/share/perl/5.14/overload.pm
        AutoLoader.pm => /usr/share/perl/5.14/AutoLoader.pm
        lib.pm => /usr/lib/perl/5.14/lib.pm
        Slim/Utils/OS/Unix.pm => /usr/share/perl5/Slim/Utils/OS/Unix.pm
        DynaLoader.pm => /usr/lib/perl/5.14/DynaLoader.pm

The following modules failed to load on the first attempt: [DBI, EV, XML::Parser::Expat, HTML::Parser, JSON::XS, Digest::SHA1, YAML::XS, Sub::Name] - will try again.

Removing [DBI] from the symbol table - load failed.
Removing [EV] from the symbol table - load failed.
Removing [common::sense] from the symbol table - load failed.
Loaded module: [XML::Parser::Expat] ok!
Removing [HTML::Parser] from the symbol table - load failed.
Removing [HTML::Entities] from the symbol table - load failed.
Removing [JSON::XS] from the symbol table - load failed.
Removing [common::sense] from the symbol table - load failed.
Removing [Digest::base] from the symbol table - load failed.
Removing [Digest::SHA1] from the symbol table - load failed.
Removing [YAML::XS] from the symbol table - load failed.
Removing [Sub::Name] from the symbol table - load failed.
The following modules are loaded after the second attempt:
        Slim/Utils/OS/Debian.pm => /usr/share/perl5/Slim/Utils/OS/Debian.pm
        File/Spec/Functions.pm => /usr/lib/perl/5.14/File/Spec/Functions.pm
        POSIX.pm => /usr/lib/perl/5.14/POSIX.pm
        Getopt/Long.pm => /usr/share/perl/5.14/Getopt/Long.pm
        /usr/lib/perl/5.14/auto/POSIX/load_imports.al => /usr/lib/perl/5.14/auto/POSIX/load_imports.al
        Tie/Hash.pm => /usr/share/perl/5.14/Tie/Hash.pm
        Cwd.pm => /usr/lib/perl/5.14/Cwd.pm
        warnings.pm => /usr/share/perl/5.14/warnings.pm
        Slim/Utils/OSDetect.pm => /usr/share/perl5/Slim/Utils/OSDetect.pm
        /usr/lib/perl/5.14/auto/POSIX/autosplit.ix => /usr/lib/perl/5.14/auto/POSIX/autosplit.ix
        Slim/Utils/OS/Linux.pm => /usr/share/perl5/Slim/Utils/OS/Linux.pm
        Fcntl.pm => /usr/lib/perl/5.14/Fcntl.pm
        Symbol.pm => /usr/share/perl/5.14/Symbol.pm
        UNIVERSAL.pm => /usr/share/perl/5.14/UNIVERSAL.pm
        Exporter.pm => /usr/share/perl/5.14/Exporter.pm
        Slim/Utils/OS.pm => /usr/share/perl5/Slim/Utils/OS.pm
        version/vpp.pm => /usr/share/squeezeboxserver/CPAN/version/vpp.pm
        File/Spec.pm => /usr/lib/perl/5.14/File/Spec.pm
        File/Path.pm => /usr/share/perl/5.14/File/Path.pm
        FindBin.pm => /usr/share/perl/5.14/FindBin.pm
        locale.pm => /usr/share/perl/5.14/locale.pm
        warnings/register.pm => /usr/share/perl/5.14/warnings/register.pm
        XSLoader.pm => /usr/share/perl/5.14/XSLoader.pm
        Slim/bootstrap.pm => /usr/share/perl5/Slim/bootstrap.pm
        Time/HiRes.pm => /usr/lib/perl/5.14/Time/HiRes.pm
        XML/Parser/Expat.pm => /usr/share/squeezeboxserver/CPAN/XML/Parser/Expat.pm
        version.pm => /usr/share/squeezeboxserver/CPAN/version.pm
        Config_git.pl => /usr/lib/perl/5.14/Config_git.pl
        base.pm => /usr/share/perl/5.14/base.pm
        Config.pm => /usr/lib/perl/5.14/Config.pm
        File/Basename.pm => /usr/share/perl/5.14/File/Basename.pm
        Carp.pm => /usr/share/perl/5.14/Carp.pm
        YAML/XS/LibYAML.pm =>
        File/Spec/Unix.pm => /usr/lib/perl/5.14/File/Spec/Unix.pm
        Exporter/Heavy.pm => /usr/share/perl/5.14/Exporter/Heavy.pm
        vars.pm => /usr/share/perl/5.14/vars.pm
        strict.pm => /usr/share/perl/5.14/strict.pm
        constant.pm => /usr/share/perl/5.14/constant.pm
        Config_heavy.pl => /usr/lib/perl/5.14/Config_heavy.pl
        overload.pm => /usr/share/perl/5.14/overload.pm
        AutoLoader.pm => /usr/share/perl/5.14/AutoLoader.pm
        lib.pm => /usr/lib/perl/5.14/lib.pm
        Slim/Utils/OS/Unix.pm => /usr/share/perl5/Slim/Utils/OS/Unix.pm
        DynaLoader.pm => /usr/lib/perl/5.14/DynaLoader.pm

The following modules failed to load: DBI EV HTML::Parser JSON::XS Digest::SHA1 YAML::XS Sub::Name
*******

NOTE:

If you're running some unsupported Linux/Unix platform, please use the buildme.sh
script located here:

http://svn.slimdevices.com/repos/slim/7.7/trunk/vendor/CPAN/

If 7.7 is outdated by the time you read this, Replace "7.7" with the major version
You should never need to do this if you're on Windows or Mac OSX. If the installers
don't work for you, ask for help and/or report a bug.

of Logitech Media Server you are running.

*******


Exiting..
Could somebody point me in the right direction?
Thanks in advance

KB


Killerbee
Posts: 62
Joined: Tue Sep 20, 2011 6:38 pm

Re: Squeezebox server and slave

Tue Jun 26, 2012 9:18 pm

Thanks but the link points to squeezeplug armel version. The armel version doen't work on raspbian. We need to compile the CPAN modules for the armhf architecture.
By the way I already tried squeezeplug and it's a great image.

Thanks anyhow.


Return to “Raspbian”

Who is online

Users browsing this forum: No registered users and 17 guests