User avatar
Network-IT
Posts: 4
Joined: Mon Mar 17, 2014 9:40 pm
Location: Glasgow, Scotland
Contact: Website

USB, Ethernet doesn't work on Pi B+ when using image from B

Wed Jul 16, 2014 1:31 pm

Hello,
Just bought the Pi B+ and very excited to hopefully resolve issues we have with USB power! :D

Im running Raspbian (I believe January release) and I have taken an image from the SD card of a working Pi B and transferred to micro SD to Pi B+ ... Raspbian boots as expected but Ethernet doesn't work and neither does USB. Im using the same mouse & keyboard peripherals that work on the B and the same image .... I'm a bit lost on what to do next to get USB & Ethernet port working on the B+?

User avatar
rpdom
Posts: 15610
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Wed Jul 16, 2014 1:36 pm

You need later firmware which (probably) isn't available via apt-get yet.

Put the card back into the B, run sudo rpi-update then put the card back into the B+

User avatar
truehl
Posts: 642
Joined: Sun Mar 04, 2012 6:47 pm
Contact: Website

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Wed Jul 16, 2014 1:38 pm

Network-IT wrote:Hello,
Just bought the Pi B+ and very excited to hopefully resolve issues we have with USB power! :D

Im running Raspbian (I believe January release) and I have taken an image from the SD card of a working Pi B and transferred to micro SD to Pi B+ ... Raspbian boots as expected but Ethernet doesn't work and neither does USB. Im using the same mouse & keyboard peripherals that work on the B and the same image .... I'm a bit lost on what to do next to get USB & Ethernet port working on the B+?
No, it does not work, same problem here. Do a firmware update with your old Pi before, than it will work!
truehl
http://www.squeezeplug.de

mikerr
Posts: 2789
Joined: Thu Jan 12, 2012 12:46 pm
Location: UK
Contact: Website

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Wed Jul 16, 2014 1:42 pm

Glad you posted, we needed a topic on this to remind people.


My relatively recent image didn't work (booted up - no USB or ethernet)

If in doubt, just download the latest NOOBS image - that's what I did.
http://www.raspberrypi.org/downloads/
Android app - Raspi Card Imager - download and image SD cards - No PC required !

User avatar
Network-IT
Posts: 4
Joined: Mon Mar 17, 2014 9:40 pm
Location: Glasgow, Scotland
Contact: Website

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Wed Jul 16, 2014 1:53 pm

Thanks Guys,
I've pugged back into B and running sudo rpi-update .... I did download noobs and try copying files over but must have done it incorrectly.

Just a note for anyone else reading, I don't know how important this is but after running sudo rpi-update i get the message
"*** A reboot is needed to activate the new firmware".
I've run the reboot command, instead of cycling the power ... just in case this makes a difference. Im sure we're all aware how arsey firmware updates can be if you don't reboot properly.

Plugged back into B+ and working as it should. I'm absolutely delighted my new Raspi can properly handle a handheld barcode scanner without issues the B had :D :D :D

User avatar
DougieLawson
Posts: 36578
Joined: Sun Jun 16, 2013 11:19 pm
Location: Basingstoke, UK
Contact: Website Twitter

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Wed Jul 16, 2014 3:09 pm

rpdom wrote:You need later firmware which (probably) isn't available via apt-get yet.

Put the card back into the B, run sudo rpi-update then put the card back into the B+
Isn't it in the Wheezy sudo apt-get install libraspberrypi* stuff that pulls in the 3.12.22+ kernel and updates firmware.
Note: Having anything humorous in your signature is completely banned on this forum. Wear a tin-foil hat and you'll get a ban.

Any DMs sent on Twitter will be answered next month.

This is a doctor free zone.

sriks
Posts: 2
Joined: Thu Jul 17, 2014 7:58 am

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Thu Jul 17, 2014 8:02 am

Hi Guys...

I just got a new raspberry pi B+ . i have the same issue of no ethernet and no usb on raspbmc.. this is my first raspberry pi. so i cannot update on an older one... can anyone suggest any workaround to this please..

Thanks

User avatar
RaTTuS
Posts: 10506
Joined: Tue Nov 29, 2011 11:12 am
Location: North West UK
Contact: Twitter YouTube

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Thu Jul 17, 2014 8:14 am

sriks wrote:Hi Guys...

I just got a new raspberry pi B+ . i have the same issue of no ethernet and no usb on raspbmc.. this is my first raspberry pi. so i cannot update on an older one... can anyone suggest any workaround to this please..

Thanks
where did you get the image from ?
just download the recent noobs image ?
How To ask Questions :- http://www.catb.org/esr/faqs/smart-questions.html
WARNING - some parts of this post may be erroneous YMMV

1QC43qbL5FySu2Pi51vGqKqxy3UiJgukSX
Covfefe

sriks
Posts: 2
Joined: Thu Jul 17, 2014 7:58 am

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Thu Jul 17, 2014 8:21 am

RaTTuS wrote:
sriks wrote:Hi Guys...

I just got a new raspberry pi B+ . i have the same issue of no ethernet and no usb on raspbmc.. this is my first raspberry pi. so i cannot update on an older one... can anyone suggest any workaround to this please..

Thanks
where did you get the image from ?
just download the recent noobs image ?
Downloaded from the raspbmc site.. another difficulty is that I do not have a usb keyboard or mouse... so I as just planning on using ssh and open vnc to control the pi from my laptop?

Edit : found this ..

https://www.youtube.com/watch?v=1pGSnPgYYrU

will try following and see how it goes

Liamthe1st
Posts: 28
Joined: Tue May 13, 2014 11:13 am

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Sat Jul 19, 2014 1:51 am

Thank you it is now rip updating and I see it is updating the kernels modules so it should be ok now yes it worked on Pi+ 1 and now Pi+ 2
They should have had a piece of paper from the org before mass selling :lol:
Dit Dah Dit Dah Dit

jamesh
Raspberry Pi Engineer & Forum Moderator
Raspberry Pi Engineer & Forum Moderator
Posts: 24192
Joined: Sat Jul 30, 2011 7:41 pm

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Sat Jul 19, 2014 9:19 am

sriks wrote:
RaTTuS wrote:
sriks wrote:Hi Guys...

I just got a new raspberry pi B+ . i have the same issue of no ethernet and no usb on raspbmc.. this is my first raspberry pi. so i cannot update on an older one... can anyone suggest any workaround to this please..

Thanks
where did you get the image from ?
just download the recent noobs image ?
Downloaded from the raspbmc site.. another difficulty is that I do not have a usb keyboard or mouse... so I as just planning on using ssh and open vnc to control the pi from my laptop?

Edit : found this ..

https://www.youtube.com/watch?v=1pGSnPgYYrU

will try following and see how it goes
I presume the image from raspbmc is out of date. They will need to fix that up for the B+.
Principal Software Engineer at Raspberry Pi (Trading) Ltd.
Contrary to popular belief, humorous signatures are allowed. Here's an example...
“I think it’s wrong that only one company makes the game Monopoly.” – Steven Wright

mikerr
Posts: 2789
Joined: Thu Jan 12, 2012 12:46 pm
Location: UK
Contact: Website

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Sat Jul 19, 2014 9:34 am

I've switched to pure raspian and seem to have lost the red power LED, though everything else works ok.

This is on an old raspbian image (not noobs) which has been upgraded via apt-get & rpi-update

I quite like the "stealth mode" - but is it a symptom of wrong firmware ?
USB ports work fine...
Android app - Raspi Card Imager - download and image SD cards - No PC required !

MrEngman
Posts: 3890
Joined: Fri Feb 03, 2012 2:17 pm
Location: Southampton, UK

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Sat Jul 19, 2014 9:38 am

mikerr wrote:I've switched to pure raspian and seem to have lost the red power LED, though everything else works ok.

This is on an old raspbian image (not noobs) which has been upgraded via apt-get & rpi-update

I quite like the "stealth mode" - but is it a symptom of wrong firmware ?
USB ports work fine...
It's been mentioned a few times. The power LED going out is an indication of low voltage.



MrEngman
Simplicity is a prerequisite for reliability. Edsger W. Dijkstra

Please post ALL technical questions on the forum. Please Do Not send private messages.

mikerr
Posts: 2789
Joined: Thu Jan 12, 2012 12:46 pm
Location: UK
Contact: Website

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Sat Jul 19, 2014 9:53 am

I knew that, but thought that would be a flashing red led - the power LED never comes on, no flashes or anything (everything else ok)

[edit] swapped my noobs card back in and it the red LED was still off
it turns out I was inadvertently using a different usb socket for power than before :oops:

Red led is back now I'm using the original PSU !
Android app - Raspi Card Imager - download and image SD cards - No PC required !

tobias1109
Posts: 1
Joined: Tue Dec 02, 2014 4:00 pm

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Tue Dec 02, 2014 4:11 pm

Hello i just bought a raspberry pi b plus and it starts up normal but my usb keyboard and my usb mouse
dosent respond no matter what i do it want work i have a usb wifi nano adapter too

do anybody know what i should do to get it work

mouse: logitech B100

keyboard: Trust keyboard classicline :?: :?: :?: :?: :?: :?: :?: :?: :?:

diederik
Posts: 393
Joined: Wed Mar 26, 2014 11:17 pm

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Tue Dec 02, 2014 8:56 pm

tobias1109 wrote:do anybody know what i should do to get it work
A proper power supply

User avatar
rpdom
Posts: 15610
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Tue Dec 02, 2014 9:08 pm

Are you using the latest software? If you have a B+ Pi and old software then the USB will not work.

valandil
Posts: 7
Joined: Thu May 08, 2014 7:42 am

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Wed Dec 03, 2014 9:07 pm

Found another thing what might solve the issue for some of you.
I had my custom debian/raspbian (not original rapsbian) build.
Didnt manage to get ethernet to work but power led was ok, usb worked just fine.
Found out that in the network settings /etc/network/interfaces eth0 was defined (did this over a year ago).
So totally forgot about that...
While looking into what it really could be i used: route -n and found out my b+ was using eth1 instead of eth0 changed that in the interface rebooted the network: sudo /etc/init.d/networking restart
(didn't work for me but for most will do) rebooted the system and i was up and running!

Please note i have not a standart raspbian build but more like a very naked debian with some necessary stuff from raspbian.
So it might be a little bit different but hope this helps if you already updated the firmware and using a powerfull energy source.

User avatar
rpdom
Posts: 15610
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Thu Dec 04, 2014 9:01 am

valandil wrote:While looking into what it really could be i used: route -n and found out my b+ was using eth1 instead of eth0
You'll find that you have an entry for eth0 and eth1 in /etc/udev/rules.d/70-persistent-net.rules.

This is the default in Debian, but the Raspbian distro uses a different /lib/udev/rules.d/75-persistent-net-generator.rules which doesn't create extra entries for eth or wlan interfaces - otherwise everytime you switched cards between Pis the interface name would change.

plugwash
Forum Moderator
Forum Moderator
Posts: 3477
Joined: Wed Dec 28, 2011 11:45 pm

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Thu Dec 04, 2014 8:29 pm

rpdom wrote: This is the default in Debian, but the Raspbian distro uses a different /lib/udev/rules.d/75-persistent-net-generator.rules which doesn't create extra entries for eth or wlan interfaces - otherwise everytime you switched cards between Pis the interface name would change.
Note: this is a charactersitic of the raspberry pi foundation raspbian image. Not of raspbian in general.

User avatar
rpdom
Posts: 15610
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Thu Dec 04, 2014 9:41 pm

plugwash wrote:Note: this is a charactersitic of the raspberry pi foundation raspbian image. Not of raspbian in general.
Thanks for the clarification :)

valandil
Posts: 7
Joined: Thu May 08, 2014 7:42 am

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Fri Dec 05, 2014 3:56 pm

Ah didn't know that working with linux for less then a year now!
But at least there is a solution ;)
Im glad my B+ is up and running, the old one had issues with the sd-card after a reinsert (i do backup the sd card once a month)

eng.m.attia
Posts: 2
Joined: Tue Dec 23, 2014 12:17 am

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Tue Dec 23, 2014 12:30 am

I have new rasberry pi B+ first time using rasspberry, i'm using latest rasbian, i have problem with Ethernet not working. Could you think this issue will solved when using noobs.???

User avatar
exartemarte
Posts: 373
Joined: Sat Mar 03, 2012 3:51 pm
Location: Middle England
Contact: Website

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Tue Dec 23, 2014 2:36 am

I realise this won't help those without Ethernet or usb but, for what it's worth, I replaced the B Rev 2 running my NAS server with a B+ a few weeks after the B+ came out, using the same OS (on HDD) and, apart from the minor problem described below, it's fine.

Before swapping the hardware I upgraded Raspbian with apt-get. The SD card, which is only needed for booting, was a micro-SD in a carrier and I just transferred it to the B+, plugged in the Ethernet cable, the mouse/keyboard combo and the (usb) hard drives, and booted it up. A little experimentation was needed to determine which drive came up as sda, which as sdb, etc, but once that was sorted it worked.

There is one minor problem: it won't boot with the keyboard/mouse combo and all three hard drives plugged in. If I remove the third hard drive it boots up ok, and I can then reconnect the third drive, mount it, and it all works. This would be irritating if it happened a lot, but it runs 24/7 and is only re-booted once in a blue moon, so I can live with it and, to be honest, I haven't put much effort into trying to fix it. For the record the hard drives - OS, data and data backup - are all self powered so I don't think this will be a power supply problem.

User avatar
rpdom
Posts: 15610
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: USB, Ethernet doesn't work on Pi B+ when using image fro

Tue Dec 23, 2014 7:24 am

exartemarte wrote:For the record the hard drives - OS, data and data backup - are all self powered so I don't think this will be a power supply problem.
Even so, have you tried setting the higher current option for the USB ports in config.txt?

Code: Select all

max_usb_current=1

Return to “Raspbian”