musicboy
Posts: 15
Joined: Fri Feb 14, 2014 6:52 pm

Cannot start X from pi user

Sat Jun 28, 2014 10:59 am

Hi all
I've been running my Pi headless for quite a few months now, and a few days ago I decided to plug in a monitor, mouse and keyboard, partly because I wanted to have a play with the Arduino IDE.
Anyway.
Booted to user credential entry, I logged in as pi, which is the user I use.
Ran "startx". Then lots of messages ending in this:
xinit: connection to X server lost

waiting for X server to shut down Server terminated successfully (0). Closing log file.

And nothing happened. However if I create another user and run startx, or run sudo startx, it works fine.
I have plenty of space on my SD card.
Any help much appreciated, thanks in advance :)

musicboy
Posts: 15
Joined: Fri Feb 14, 2014 6:52 pm

Re: Cannot start X from pi user

Sun Jun 29, 2014 6:35 am

Update:
I can now launch the GUI by doing
xinit /usr/bin/lxsession
But still no luck with startx.
The message that I get after running startx is the same one I get if I close the GUI.

User avatar
rpdom
Posts: 14472
Joined: Sun May 06, 2012 5:17 am
Location: Chelmsford, Essex, UK

Re: Cannot start X from pi user

Sun Jun 29, 2014 7:06 am

The last message isn't the important one. That one basically means "Finished".

The "lots of messages" bit is most likely to show what is wrong, particularly any that have "EE" at the beginning.

If you can post all of those messages (inside

Code: Select all

 
tags to make it easier to read) then we might be able to spot something.

Return to “Raspbian”